aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpd
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-01-03 15:34:02 +0000
committerChris Rees <crees@FreeBSD.org>2013-01-03 15:34:02 +0000
commit5718a4f8eca495d3cff7d84697e1a0481e2a7a04 (patch)
tree1d92eed9e07124c277559ecd76608346867f2ffe /audio/musicpd
parentd899ebd3cc9b6cf2e99002ff4511fc615726dc4d (diff)
Notes
Diffstat (limited to 'audio/musicpd')
-rw-r--r--audio/musicpd/Makefile5
-rw-r--r--audio/musicpd/files/musicpd.in16
-rw-r--r--audio/musicpd/pkg-plist2
3 files changed, 11 insertions, 12 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index a1bac5eb55c1..8cbf8fc2500a 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= musicpd
PORTVERSION= 0.17.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio ipv6
MASTER_SITES= SF/${PORTNAME}/mpd/${PORTVERSION}
DISTNAME= mpd-${PORTVERSION}
@@ -267,8 +267,7 @@ post-install:
${CP} -p ${PREFIX}/etc/${MPDCONF}.sample \
${PREFIX}/etc/${MPDCONF} ; \
fi
- @${MKDIR} ${MPDDIR}
- @${INSTALL} -d -o ${MPDUSER} -g ${MPDGROUP} ${MPDDIR}
+ @${INSTALL} -d -o ${MPDUSER} -g ${MPDGROUP} ${MPDDIR} ${MPDDIR}/.mpd
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/audio/musicpd/files/musicpd.in b/audio/musicpd/files/musicpd.in
index cf41cc5173b5..3ed5412b24e5 100644
--- a/audio/musicpd/files/musicpd.in
+++ b/audio/musicpd/files/musicpd.in
@@ -8,18 +8,22 @@
# Add the following line to /etc/rc.conf to enable mpd:
#
-# musicpd_enable="YES"
+# musicpd_enable=YES
. /etc/rc.subr
name=musicpd
rcvar=musicpd_enable
-start_precmd="${name}_getpidfile"
-stop_precmd="${name}_getpidfile"
+
+load_rc_config $name
+
+: ${musicpd_enable:=NO}
command=%%PREFIX%%/bin/musicpd
command_args=%%PREFIX%%/etc/%%MPDCONF%%
required_files=%%PREFIX%%/etc/%%MPDCONF%%
+start_precmd=${name}_getpidfile
+stop_precmd=${name}_getpidfile
musicpd_getpidfile()
{
@@ -31,8 +35,4 @@ musicpd_getpidfile()
fi
}
-load_rc_config $name
-
-: ${musicpd_enable="NO"}
-
-run_rc_command "$1"
+run_rc_command $1
diff --git a/audio/musicpd/pkg-plist b/audio/musicpd/pkg-plist
index f9f0794eafc4..ab28f37be532 100644
--- a/audio/musicpd/pkg-plist
+++ b/audio/musicpd/pkg-plist
@@ -2,4 +2,4 @@ bin/musicpd
@unexec if cmp -s %D/etc/%%MPDCONF%%.sample %D/etc/%%MPDCONF%%; then rm -f %D/etc/%%MPDCONF%%; fi
etc/%%MPDCONF%%.sample
@exec if [ ! -f %D/etc/%%MPDCONF%% ] ; then cp -p %D/%F %B/%%MPDCONF%%; fi
-@exec install -d -o %%MPDUSER%% -g %%MPDGROUP%% %%MPDDIR%%
+@exec install -d -o %%MPDUSER%% -g %%MPDGROUP%% %%MPDDIR%% %%MPDDIR%%/.mpd