aboutsummaryrefslogtreecommitdiff
path: root/audio/nas
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2005-10-11 18:25:56 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2005-10-11 18:25:56 +0000
commitfa12b7910472e232b9744976026ae5978e59c293 (patch)
tree638bf8b5f5b6208d43185d6824d5073f0399820b /audio/nas
parenta24a39e03a04bb31a41fa9866931b88da2babd80 (diff)
downloadports-fa12b7910472e232b9744976026ae5978e59c293.tar.gz
ports-fa12b7910472e232b9744976026ae5978e59c293.zip
Fix build on 4.x
Notes
Notes: svn path=/head/; revision=144982
Diffstat (limited to 'audio/nas')
-rw-r--r--audio/nas/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/audio/nas/Makefile b/audio/nas/Makefile
index 2e6a3a80d94e..77760afebfc8 100644
--- a/audio/nas/Makefile
+++ b/audio/nas/Makefile
@@ -20,9 +20,14 @@ INSTALLS_SHLIB= yes
CFLAGS+= -Werror
MAKE_ENV+= COMPRESS_CMD="${COMPRESS_CMD:S/c//}"
+.include <bsd.port.pre.mk>
post-patch:
@${FIND} ${WRKSRC} -name '*.c' | ${XARGS} ${GREP} -lF malloc.h \
| ${XARGS} ${REINPLACE_CMD} -n -e "s|<malloc.h>||" -e t -e p
+.if ${OSVERSION} < 500027
+ @${FIND} ${WRKSRC} | ${XARGS} ${GREP} -lF stdint.h \
+ | ${XARGS} ${REINPLACE_CMD} -e "s|<stdint.h>|<inttypes.h>|g"
+.endif
post-configure:
# Work around shortcomings of the Image.rules et. al:
@@ -35,7 +40,6 @@ post-install:
@${SED} -e 's:/usr/X11R6:${PREFIX}:g' ${PKGMESSAGE}
.include "Makefile.man"
-.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
FPIC= -fPIC