aboutsummaryrefslogtreecommitdiff
path: root/audio/ncmpc
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-04-22 14:17:13 +0000
committerSteve Wills <swills@FreeBSD.org>2019-04-22 14:17:13 +0000
commitd30cd9e1c1b793f213d03b066d505c372a533da6 (patch)
treeb6e4ecf085bb2180ca8bd80ccc5ab463a97e1df6 /audio/ncmpc
parent05773f4f5f77c6d1b6f2ed969077b55c14ad049c (diff)
downloadports-d30cd9e1c1b793f213d03b066d505c372a533da6.tar.gz
ports-d30cd9e1c1b793f213d03b066d505c372a533da6.zip
audio/ncmpc: update to 0.34
PR: 237454 Submitted by: Laurent Cimon <laurent@nuxi.ca> (maintainer)
Notes
Notes: svn path=/head/; revision=499647
Diffstat (limited to 'audio/ncmpc')
-rw-r--r--audio/ncmpc/Makefile3
-rw-r--r--audio/ncmpc/distinfo6
-rw-r--r--audio/ncmpc/files/patch-boost-1.70211
-rw-r--r--audio/ncmpc/files/patch-doc_meson.build14
4 files changed, 4 insertions, 230 deletions
diff --git a/audio/ncmpc/Makefile b/audio/ncmpc/Makefile
index 09b6a11059d7..e98861da1c6d 100644
--- a/audio/ncmpc/Makefile
+++ b/audio/ncmpc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ncmpc
-PORTVERSION= 0.33
-PORTREVISION= 3
+PORTVERSION= 0.34
CATEGORIES= audio
MASTER_SITES= http://www.musicpd.org/download/ncmpc/0/
diff --git a/audio/ncmpc/distinfo b/audio/ncmpc/distinfo
index 3d7c7bac429d..23d4c8aa5036 100644
--- a/audio/ncmpc/distinfo
+++ b/audio/ncmpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1540320545
-SHA256 (ncmpc-0.33.tar.xz) = 94e04a34854015aa013b43ec15b578f4541d077cf7ae5bf7c0944475673fd7a5
-SIZE (ncmpc-0.33.tar.xz) = 226344
+TIMESTAMP = 1555674341
+SHA256 (ncmpc-0.34.tar.xz) = 14c5b1dc78e83fa838fb049db76c00706686c98991600a87d2c57ec2b6c9e857
+SIZE (ncmpc-0.34.tar.xz) = 227892
diff --git a/audio/ncmpc/files/patch-boost-1.70 b/audio/ncmpc/files/patch-boost-1.70
deleted file mode 100644
index 7901b331abf7..000000000000
--- a/audio/ncmpc/files/patch-boost-1.70
+++ /dev/null
@@ -1,211 +0,0 @@
-https://github.com/MusicPlayerDaemon/ncmpc/commit/b6c25f3b5fa5
-https://github.com/MusicPlayerDaemon/ncmpc/commit/4f767b38e527
-
---- src/LyricsPage.cxx.orig 2018-10-22 17:04:35 UTC
-+++ src/LyricsPage.cxx
-@@ -75,7 +75,7 @@ class LyricsPage final : public TextPage { (public)
- }
-
- auto &get_io_service() noexcept {
-- return loader_timeout.get_io_service();
-+ return screen.get_io_service();
- }
-
- private:
---- src/aconnect.cxx.orig 2018-10-22 17:04:35 UTC
-+++ src/aconnect.cxx
-@@ -125,7 +125,7 @@ aconnect_start(boost::asio::io_service &io_service,
-
- *acp = ac;
-
-- ac->rconnect.Start(host, port);
-+ ac->rconnect.Start(io_service, host, port);
- }
-
- void
---- src/keyboard.cxx.orig 2018-10-22 17:04:35 UTC
-+++ src/keyboard.cxx
-@@ -43,7 +43,7 @@ void
- UserInput::OnReadable(const boost::system::error_code &error)
- {
- if (error) {
-- d.get_io_service().stop();
-+ get_io_context().stop();
- return;
- }
-
-@@ -81,7 +81,7 @@ UserInput::OnReadable(const boost::system::error_code
-
- begin_input_event();
-
-- if (!do_input_event(d.get_io_service(), cmd))
-+ if (!do_input_event(get_io_context(), cmd))
- return;
-
- end_input_event();
-@@ -89,7 +89,11 @@ UserInput::OnReadable(const boost::system::error_code
- }
-
- UserInput::UserInput(boost::asio::io_service &io_service, WINDOW &_w)
-- :d(io_service), w(_w)
-+ :d(io_service),
-+#if BOOST_VERSION >= 107000
-+ io_context(io_service),
-+#endif
-+ w(_w)
- {
- d.assign(STDIN_FILENO);
- AsyncWait();
---- src/keyboard.hxx.orig 2018-10-22 17:04:35 UTC
-+++ src/keyboard.hxx
-@@ -28,10 +28,23 @@
-
- class UserInput {
- boost::asio::posix::stream_descriptor d;
-+
-+#if BOOST_VERSION >= 107000
-+ boost::asio::io_context &io_context;
-+#endif
-+
- WINDOW &w;
-
- public:
- UserInput(boost::asio::io_service &io_service, WINDOW &_w);
-+
-+ auto &get_io_context() noexcept {
-+#if BOOST_VERSION >= 107000
-+ return io_context;
-+#else
-+ return d.get_io_service();
-+#endif
-+ }
-
- private:
- void AsyncWait() {
---- src/lirc.cxx.orig 2018-10-22 17:04:35 UTC
-+++ src/lirc.cxx
-@@ -37,7 +37,7 @@ LircInput::OnReadable(const boost::system::error_code
- if (lirc_nextcode(&code) == 0) {
- while (lirc_code2char(lc, code, &txt) == 0 && txt != nullptr) {
- const auto cmd = get_key_command_from_name(txt);
-- if (!do_input_event(d.get_io_service(), cmd))
-+ if (!do_input_event(get_io_context(), cmd))
- return;
- }
- }
-@@ -48,6 +48,9 @@ LircInput::OnReadable(const boost::system::error_code
-
- LircInput::LircInput(boost::asio::io_service &io_service)
- :d(io_service)
-+#if BOOST_VERSION >= 107000
-+ , io_context(io_service)
-+#endif
- {
- int lirc_socket = 0;
-
---- src/lirc.hxx.orig 2018-10-22 17:04:35 UTC
-+++ src/lirc.hxx
-@@ -26,11 +26,24 @@
-
- class LircInput {
- boost::asio::posix::stream_descriptor d;
-+
-+#if BOOST_VERSION >= 107000
-+ boost::asio::io_context &io_context;
-+#endif
-+
- struct lirc_config *lc = nullptr;
-
- public:
- explicit LircInput(boost::asio::io_service &io_service);
- ~LircInput();
-+
-+ auto &get_io_context() noexcept {
-+#if BOOST_VERSION >= 107000
-+ return io_context;
-+#else
-+ return d.get_io_service();
-+#endif
-+ }
-
- private:
- void AsyncWait() {
---- src/mpdclient.cxx.orig 2018-10-22 17:04:35 UTC
-+++ src/mpdclient.cxx
-@@ -156,6 +156,9 @@ mpdclient::mpdclient(boost::asio::io_service &io_servi
- const char *_host, unsigned _port,
- unsigned _timeout_ms, const char *_password)
- :timeout_ms(_timeout_ms), password(_password),
-+#if BOOST_VERSION >= 107000
-+ io_context(io_service),
-+#endif
- enter_idle_timer(io_service)
- {
- #ifdef ENABLE_ASYNC_CONNECT
---- src/mpdclient.hxx.orig 2018-10-22 17:04:35 UTC
-+++ src/mpdclient.hxx
-@@ -71,6 +71,10 @@ struct mpdclient final
- struct mpd_status *status = nullptr;
- const struct mpd_song *current_song = nullptr;
-
-+#if BOOST_VERSION >= 107000
-+ boost::asio::io_context &io_context;
-+#endif
-+
- /**
- * A timer which re-enters MPD idle mode before the next main
- * loop iteration.
-@@ -130,7 +134,11 @@ struct mpdclient final
- }
-
- auto &get_io_service() noexcept {
-+#if BOOST_VERSION >= 107000
-+ return io_context;
-+#else
- return enter_idle_timer.get_io_service();
-+#endif
- }
-
- #ifdef ENABLE_ASYNC_CONNECT
---- src/net/AsyncResolveConnect.cxx.orig 2018-10-22 17:04:35 UTC
-+++ src/net/AsyncResolveConnect.cxx
-@@ -54,7 +54,8 @@ AsyncResolveConnect::OnResolved(const boost::system::e
- }
-
- void
--AsyncResolveConnect::Start(const char *host, unsigned port) noexcept
-+AsyncResolveConnect::Start(boost::asio::io_service &io_service,
-+ const char *host, unsigned port) noexcept
- {
- #ifndef _WIN32
- if (host[0] == '/' || host[0] == '@') {
-@@ -64,7 +65,7 @@ AsyncResolveConnect::Start(const char *host, unsigned
- s.front() = 0;
-
- boost::asio::local::stream_protocol::endpoint ep(std::move(s));
-- boost::asio::local::stream_protocol::socket socket(resolver.get_io_service());
-+ boost::asio::local::stream_protocol::socket socket(io_service);
-
- boost::system::error_code error;
- socket.connect(ep, error);
-@@ -76,6 +77,8 @@ AsyncResolveConnect::Start(const char *host, unsigned
- handler.OnConnect(std::move(socket));
- return;
- }
-+#else
-+ (void)io_service;
- #endif /* _WIN32 */
-
- char service[20];
---- src/net/AsyncResolveConnect.hxx.orig 2018-10-22 17:04:35 UTC
-+++ src/net/AsyncResolveConnect.hxx
-@@ -47,7 +47,8 @@ class AsyncResolveConnect { (public)
- /**
- * Resolve a host name and connect to it asynchronously.
- */
-- void Start(const char *host, unsigned port) noexcept;
-+ void Start(boost::asio::io_service &io_service,
-+ const char *host, unsigned port) noexcept;
-
- private:
- void OnResolved(const boost::system::error_code &error,
diff --git a/audio/ncmpc/files/patch-doc_meson.build b/audio/ncmpc/files/patch-doc_meson.build
deleted file mode 100644
index 8aa2dcf2b7e2..000000000000
--- a/audio/ncmpc/files/patch-doc_meson.build
+++ /dev/null
@@ -1,14 +0,0 @@
---- doc/meson.build.orig 2018-10-25 17:01:44 UTC
-+++ doc/meson.build
-@@ -30,9 +30,9 @@ endif
- if get_option('manual')
- custom_target(
- 'Manpage documentation',
-- output: 'man',
-+ output: 'man1',
- input: ['index.rst', 'conf.py'],
-- command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/man_doctrees', meson.current_source_dir(), '@OUTPUT@/man1'],
-+ command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/man_doctrees', meson.current_source_dir(), '@OUTPUT@'],
- build_by_default: true,
- install: true,
- install_dir: get_option('mandir'),