aboutsummaryrefslogtreecommitdiff
path: root/audio/ncmpc
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-05-26 14:57:54 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-05-26 14:57:54 +0000
commite6cb85961dd46da24b91f2f326e937f165a530b1 (patch)
tree2006c5f99de4026a2766d151d1148b31f2b594e6 /audio/ncmpc
parent1c13cbbe50dede93d0010816dc2308fee655efd7 (diff)
downloadports-e6cb85961dd46da24b91f2f326e937f165a530b1.tar.gz
ports-e6cb85961dd46da24b91f2f326e937f165a530b1.zip
Notes
Diffstat (limited to 'audio/ncmpc')
-rw-r--r--audio/ncmpc/Makefile26
1 files changed, 21 insertions, 5 deletions
diff --git a/audio/ncmpc/Makefile b/audio/ncmpc/Makefile
index 2b02e61cd47d..254cd1236b5d 100644
--- a/audio/ncmpc/Makefile
+++ b/audio/ncmpc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ncmpc
PORTVERSION= 0.14
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/musicpd
@@ -15,18 +16,19 @@ COMMENT= Ncurses client for the musicpd
GNU_CONFIGURE= yes
USE_GNOME= glib20
-CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-OPTIONS= NLS "Native language support" on
+OPTIONS= NLS "Native language support" on \
+ LYRICS "Compile with lyrics screen" on
.include <bsd.port.pre.mk>
USE_ICONV= yes
PLIST_FILES= bin/ncmpc \
- %%EXAMPLESDIR%%/config \
- %%EXAMPLESDIR%%/keys \
- %%EXAMPLESDIR%%/ncmpc.lirc
+ %%EXAMPLESDIR%%/config \
+ %%EXAMPLESDIR%%/keys \
+ %%EXAMPLESDIR%%/ncmpc.lirc
PLIST_DIRS=%%EXAMPLESDIR%%
.ifdef(WITHOUT_NLS)
@@ -40,6 +42,17 @@ PLIST_FILES+=share/locale/${language}/LC_MESSAGES/ncmpc.mo
.endif
+.ifdef(WITH_LYRICS)
+CONFIGURE_ARGS+=--enable-lyrics-screen
+PLIST_FILES+= lib/ncmpc/lyrics/01-hd.sh \
+ lib/ncmpc/lyrics/02-lyricwiki.rb \
+ lib/ncmpc/lyrics/03-leoslyrics.py
+PLIST_DIRS+= lib/ncmpc/lyrics \
+ lib/ncmpc
+.else
+CONFIGURE_ARGS+=--disable-lyrics-screen
+.endif
+
MAN1= ncmpc.1
do-install:
@@ -55,5 +68,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/po/${language}.gmo ${PREFIX}/share/locale/${language}/LC_MESSAGES/ncmpc.mo
.endfor
.endif
+.if !defined(WITHOUT_LYRICS)
+ ${MAKE} -C ${WRKSRC} install-exec-local
+.endif
.include <bsd.port.post.mk>