aboutsummaryrefslogtreecommitdiff
path: root/audio/ncmpc
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-12-05 13:54:15 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-12-05 13:54:15 +0000
commitf61a178fbc399a3833401afab5336b6326d6e14a (patch)
tree55b68928aa00f4e7192e3fc4d9f16574dc06bae3 /audio/ncmpc
parent4dbac91cf9ece7e884c824e3549fec06d5deacce (diff)
downloadports-f61a178fbc399a3833401afab5336b6326d6e14a.tar.gz
ports-f61a178fbc399a3833401afab5336b6326d6e14a.zip
audio/ncmpc: Update to 0.33
Changes: https://raw.githubusercontent.com/MusicPlayerDaemon/ncmpc/v0.33/NEWS PR: 231643 Submitted by: Laurent Cimon <laurent@nuxi.ca> (maintainer)
Notes
Notes: svn path=/head/; revision=486669
Diffstat (limited to 'audio/ncmpc')
-rw-r--r--audio/ncmpc/Makefile21
-rw-r--r--audio/ncmpc/distinfo6
-rw-r--r--audio/ncmpc/files/patch-doc_meson.build60
-rw-r--r--audio/ncmpc/files/patch-meson__options.txt14
-rw-r--r--audio/ncmpc/files/patch-src_screen.hxx21
-rw-r--r--audio/ncmpc/pkg-plist74
6 files changed, 66 insertions, 130 deletions
diff --git a/audio/ncmpc/Makefile b/audio/ncmpc/Makefile
index 84fa40266e75..bfab6822592c 100644
--- a/audio/ncmpc/Makefile
+++ b/audio/ncmpc/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ncmpc
-PORTVERSION= 0.30
+PORTVERSION= 0.33
CATEGORIES= audio
MASTER_SITES= http://www.musicpd.org/download/ncmpc/0/
@@ -12,17 +12,22 @@ COMMENT= Ncurses client for the musicpd
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libmpdclient.so:audio/libmpdclient
+LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libmpdclient.so:audio/libmpdclient \
+ libpcre.so:devel/pcre
-USES= compiler:c++14-lang gnome iconv localbase meson ncurses pkgconfig tar:xz
-USE_GNOME= glib20
+USES= compiler:c++14-lang iconv localbase:ldflags meson ncurses \
+ pkgconfig tar:xz
-OPTIONS_DEFINE= DOCS LYRICS MANPAGES NLS
-OPTIONS_DEFAULT= LYRICS MANPAGES
+OPTIONS_DEFINE= COLORS DOCS LYRICS MANPAGES NLS
+OPTIONS_DEFAULT= COLORS LYRICS MANPAGES
OPTIONS_SUB= yes
+COLORS_DESC= Compile with color support
LYRICS_DESC= Compile with lyrics screen
+COLORS_MESON_TRUE= colors
+
DOCS_IMPLIES= MANPAGES
DOCS_MESON_TRUE= html_manual
@@ -34,7 +39,9 @@ MANPAGES_MAKE_ENV= PYTHON=${PYTHON_CMD} \
MANPAGES_MESON_TRUE= manual
MANPAGES_USES= python:build
-NLS_MESON_TRUE= nls
+NLS_LDFLAGS= -lintl
+NLS_MESON_OFF= -Dnls=disabled
+NLS_MESON_ON= -Dnls=enabled
NLS_USES= gettext
.include <bsd.port.mk>
diff --git a/audio/ncmpc/distinfo b/audio/ncmpc/distinfo
index a4a8618216a4..3d7c7bac429d 100644
--- a/audio/ncmpc/distinfo
+++ b/audio/ncmpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1534510290
-SHA256 (ncmpc-0.30.tar.xz) = e3fe0cb58b8a77f63fb1645c2f974b334f1614efdc834ec698ee7d861f1b12a3
-SIZE (ncmpc-0.30.tar.xz) = 245212
+TIMESTAMP = 1540320545
+SHA256 (ncmpc-0.33.tar.xz) = 94e04a34854015aa013b43ec15b578f4541d077cf7ae5bf7c0944475673fd7a5
+SIZE (ncmpc-0.33.tar.xz) = 226344
diff --git a/audio/ncmpc/files/patch-doc_meson.build b/audio/ncmpc/files/patch-doc_meson.build
index f5c882e962b7..8aa2dcf2b7e2 100644
--- a/audio/ncmpc/files/patch-doc_meson.build
+++ b/audio/ncmpc/files/patch-doc_meson.build
@@ -1,50 +1,14 @@
---- doc/meson.build.orig 2018-04-04 08:23:50 UTC
+--- doc/meson.build.orig 2018-10-25 17:01:44 UTC
+++ doc/meson.build
-@@ -1,24 +1,28 @@
- sphinx = find_program('sphinx-build', required:false)
--if sphinx.found()
-- custom_target(
-- 'HTML documentation',
-- output: 'html',
-- input: ['index.rst', 'conf.py'],
-- command: [sphinx, '-q', '-b', 'html', '-d', '@OUTDIR@/doctrees', meson.current_source_dir(), '@OUTPUT@'],
-- build_by_default: true,
-- install: true,
-- install_dir: join_paths(get_option('datadir'), 'doc', meson.project_name()),
-- )
-+if sphinx.found() and get_option('manual')
-+ if get_option('html_manual')
-+ custom_target(
-+ 'HTML documentation',
-+ output: 'html',
-+ input: ['index.rst', 'conf.py'],
-+ command: [sphinx, '-q', '-b', 'html', '-d', '@OUTDIR@/html_doctrees', meson.current_source_dir(), '@OUTPUT@'],
-+ build_by_default: true,
-+ install: true,
-+ install_dir: join_paths(get_option('datadir'), 'doc', meson.project_name()),
-+ )
-+ endif
-
-- custom_target(
-- 'Manpage documentation',
+@@ -30,9 +30,9 @@ endif
+ if get_option('manual')
+ custom_target(
+ 'Manpage documentation',
- output: 'man',
-- input: ['index.rst', 'conf.py'],
-- command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/doctrees', meson.current_source_dir(), '@OUTPUT@/man1'],
-- build_by_default: true,
-- install: true,
-- install_dir: get_option('datadir'),
-- )
-+ if get_option('manual')
-+ custom_target(
-+ 'Manpage documentation',
-+ output: 'man1',
-+ input: ['index.rst', 'conf.py'],
-+ command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/man_doctrees', meson.current_source_dir(), '@OUTPUT@'],
-+ build_by_default: true,
-+ install: true,
-+ install_dir: get_option('mandir'),
-+ )
-+ endif
- endif
-
- if get_option('documentation')
++ output: 'man1',
+ input: ['index.rst', 'conf.py'],
+- command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/man_doctrees', meson.current_source_dir(), '@OUTPUT@/man1'],
++ command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/man_doctrees', meson.current_source_dir(), '@OUTPUT@'],
+ build_by_default: true,
+ install: true,
+ install_dir: get_option('mandir'),
diff --git a/audio/ncmpc/files/patch-meson__options.txt b/audio/ncmpc/files/patch-meson__options.txt
deleted file mode 100644
index bcccaf848dde..000000000000
--- a/audio/ncmpc/files/patch-meson__options.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- meson_options.txt.orig 2018-04-04 08:23:50 UTC
-+++ meson_options.txt
-@@ -83,3 +83,11 @@ option('chat_screen', type: 'boolean',
- option('documentation', type: 'boolean',
- value: false,
- description: 'Build API documentation')
-+
-+option('manual', type: 'boolean',
-+ value: true,
-+ description: 'Build the manual')
-+
-+option('html_manual', type: 'boolean',
-+ value: true,
-+ description: 'Build the HTML manual')
diff --git a/audio/ncmpc/files/patch-src_screen.hxx b/audio/ncmpc/files/patch-src_screen.hxx
deleted file mode 100644
index b2a1df31b307..000000000000
--- a/audio/ncmpc/files/patch-src_screen.hxx
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/screen.hxx.orig 2018-04-04 08:23:50 UTC
-+++ src/screen.hxx
-@@ -82,8 +82,7 @@ class ScreenManager { (public)
- StatusBar status_bar;
-
- private:
-- using PageMap = std::map<const struct screen_functions *,
-- std::unique_ptr<Page>>;
-+ using PageMap = std::map<const struct screen_functions *, Page *>;
- PageMap pages;
- PageMap::iterator current_page = pages.begin();
-
-@@ -120,7 +119,7 @@ class ScreenManager { (public)
-
- gcc_pure
- bool IsVisible(const Page &page) const {
-- return &page == current_page->second.get();
-+ return &page == current_page->second;
- }
-
- void Switch(const struct screen_functions &sf, struct mpdclient &c);
diff --git a/audio/ncmpc/pkg-plist b/audio/ncmpc/pkg-plist
index bad679a0aab8..25396675a654 100644
--- a/audio/ncmpc/pkg-plist
+++ b/audio/ncmpc/pkg-plist
@@ -1,60 +1,60 @@
bin/ncmpc
+%%LYRICS%%lib/ncmpc/lyrics/10-hd.sh
+%%LYRICS%%lib/ncmpc/lyrics/20-lyricwiki.rb
%%MANPAGES%%man/man1/ncmpc.1.gz
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/README.rst
-%%PORTDOCS%%%%DOCSDIR%%/keys.sample
-%%PORTDOCS%%%%DOCSDIR%%/ncmpc.lirc
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README.rst
%%PORTDOCS%%%%DOCSDIR%%/config.sample
-%%PORTDOCS%%%%DOCSDIR%%/html/searchindex.js
-%%PORTDOCS%%%%DOCSDIR%%/html/objects.inv
+%%PORTDOCS%%%%DOCSDIR%%/html/.buildinfo
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/index.rst.txt
-%%PORTDOCS%%%%DOCSDIR%%/html/search.html
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/minus.png
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/file.png
%%PORTDOCS%%%%DOCSDIR%%/html/_static/ajax-loader.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/underscore.js
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/basic.css
%%PORTDOCS%%%%DOCSDIR%%/html/_static/alabaster.css
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/searchtools.js
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/underscore-1.3.1.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/basic.css
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/comment-bright.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/comment-close.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/comment.png
%%PORTDOCS%%%%DOCSDIR%%/html/_static/doctools.js
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/jquery-3.1.0.js
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/up-pressed.png
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/websupport.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/down-pressed.png
%%PORTDOCS%%%%DOCSDIR%%/html/_static/down.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/file.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/jquery-3.1.0.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/minus.png
%%PORTDOCS%%%%DOCSDIR%%/html/_static/plus.png
%%PORTDOCS%%%%DOCSDIR%%/html/_static/pygments.css
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/down-pressed.png
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/comment.png
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/comment-close.png
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/comment-bright.png
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/searchtools.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/underscore-1.3.1.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/underscore.js
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/up-pressed.png
%%PORTDOCS%%%%DOCSDIR%%/html/_static/up.png
-%%PORTDOCS%%%%DOCSDIR%%/html/_static/jquery.js
-%%PORTDOCS%%%%DOCSDIR%%/html/.buildinfo
+%%PORTDOCS%%%%DOCSDIR%%/html/_static/websupport.js
%%PORTDOCS%%%%DOCSDIR%%/html/genindex.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
-%%LYRICS%%lib/ncmpc/lyrics/10-hd.sh
-%%LYRICS%%lib/ncmpc/lyrics/20-lyricwiki.rb
-%%NLS%%share/locale/he/LC_MESSAGES/ncmpc.mo
+%%PORTDOCS%%%%DOCSDIR%%/html/objects.inv
+%%PORTDOCS%%%%DOCSDIR%%/html/search.html
+%%PORTDOCS%%%%DOCSDIR%%/html/searchindex.js
+%%PORTDOCS%%%%DOCSDIR%%/keys.sample
+%%PORTDOCS%%%%DOCSDIR%%/ncmpc.lirc
%%NLS%%share/locale/cs/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/da/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/de/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/es/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/fr/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/nb/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/gl/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/he/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/hu/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/es/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/eo/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/it/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/da/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/sk/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/de/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/ru/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/ncmpc.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/ncmpc.mo
%%NLS%%share/locale/sv/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/ncmpc.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/ncmpc.mo