aboutsummaryrefslogtreecommitdiff
path: root/audio/ncmpcpp
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-04-04 08:27:21 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-04-04 08:27:21 +0000
commit39f654553b0e258f3981c48fd936998009cc39b1 (patch)
tree53cc824bb280dc904ec94149d68021a1b33841e8 /audio/ncmpcpp
parent29eba89b447dbcee09b97a2bdbf1cacb4ed4a1d8 (diff)
downloadports-39f654553b0e258f3981c48fd936998009cc39b1.tar.gz
ports-39f654553b0e258f3981c48fd936998009cc39b1.zip
audio/ncmpcpp: unbreak with ICU 61
In file included from screens/browser.cpp:27: In file included from ./screens/browser.h:26: ./regex_filter.h:45:22: error: unknown type name 'UnicodeString'; did you mean 'icu::UnicodeString'? static void convert(UnicodeString &s) ^~~~~~~~~~~~~ icu::UnicodeString /usr/local/include/unicode/unistr.h:286:20: note: 'icu::UnicodeString' declared here class U_COMMON_API UnicodeString : public Replaceable ^ In file included from screens/browser.cpp:27: In file included from ./screens/browser.h:26: ./regex_filter.h:61:9: error: unknown type name 'Transliterator'; did you mean 'UTransliterator'? static Transliterator *m_converter; ^~~~~~~~~~~~~~ UTransliterator /usr/local/include/unicode/utrans.h:70:15: note: 'UTransliterator' declared here typedef void* UTransliterator; ^ In file included from screens/browser.cpp:27: In file included from ./screens/browser.h:26: ./regex_filter.h:49:4: error: unknown type name 'ErrorCode'; did you mean 'UErrorCode'? ErrorCode result; ^~~~~~~~~ UErrorCode /usr/local/include/unicode/utypes.h:663:3: note: 'UErrorCode' declared here } UErrorCode; ^ In file included from screens/browser.cpp:27: In file included from ./screens/browser.h:26: ./regex_filter.h:50:18: error: use of undeclared identifier 'Transliterator'; did you mean 'icu::Transliterator'? m_converter = Transliterator::createInstance( ^~~~~~~~~~~~~~ icu::Transliterator /usr/local/include/unicode/translit.h:243:18: note: 'icu::Transliterator' declared here class U_I18N_API Transliterator : public UObject { ^ In file included from screens/browser.cpp:27: In file included from ./screens/browser.h:26: ./regex_filter.h:50:18: error: assigning to 'UTransliterator *' (aka 'void **') from incompatible type 'icu::Transliterator *' m_converter = Transliterator::createInstance( ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ./regex_filter.h:52:14: error: member reference base type 'UErrorCode' is not a structure or union if (result.isFailure()) ~~~~~~^~~~~~~~~~ ./regex_filter.h:55:26: error: member reference base type 'UErrorCode' is not a structure or union + std::string(result.errorName())); ~~~~~~^~~~~~~~~~ ./regex_filter.h:57:14: error: member reference base type 'UTransliterator' (aka 'void *') is not a structure or union m_converter->transliterate(s); ~~~~~~~~~~~^ ~~~~~~~~~~~~~ ./regex_filter.h:64:1: error: unknown type name 'Transliterator'; did you mean 'UTransliterator'? Transliterator *StripDiacritics::m_converter; ^~~~~~~~~~~~~~ UTransliterator /usr/local/include/unicode/utrans.h:70:15: note: 'UTransliterator' declared here typedef void* UTransliterator; ^ In file included from screens/browser.cpp:27: In file included from ./screens/browser.h:26: ./regex_filter.h:102:14: error: use of undeclared identifier 'UnicodeString'; did you mean 'icu::UnicodeString'? auto us = UnicodeString::fromUTF8( ^~~~~~~~~~~~~ icu::UnicodeString /usr/local/include/unicode/unistr.h:286:20: note: 'icu::UnicodeString' declared here class U_COMMON_API UnicodeString : public Replaceable ^ In file included from screens/browser.cpp:27: In file included from ./screens/browser.h:26: ./regex_filter.h:103:5: error: use of undeclared identifier 'StringPiece' StringPiece(convertString<char, CharT>::apply(s))); ^ screens/browser.cpp:737:16: note: in instantiation of function template specialization 'Regex::search<char>' requested here return Regex::search(itemToString(item), rx, Config.ignore_diacritics); ^ https://ssl.icu-project.org/trac/changeset/40705 PR: 227042 Reported by: antoine (via exp-run)
Notes
Notes: svn path=/head/; revision=466400
Diffstat (limited to 'audio/ncmpcpp')
-rw-r--r--audio/ncmpcpp/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index f869a22f26e8..715255623324 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -24,6 +24,7 @@ BROKEN_powerpc64= fails to compile: tags.cpp: undefined reference to TagLib::Str
USES= compiler:c++14-lang iconv libtool localbase ncurses:port pkgconfig readline tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= glib20
+CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
LDFLAGS+= -lpthread
CONFIGURE_ENV= BOOST_LIB_SUFFIX=""