aboutsummaryrefslogtreecommitdiff
path: root/audio/nekobi-lv2
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-02 15:38:45 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-02 15:38:45 +0000
commit73c8ff9908301aa79ed8a7324cf5eaf41dd73916 (patch)
treec7a5a78f8cb3aff266a2744ae627d0e82a421898 /audio/nekobi-lv2
parent08bb75576c714eb6dec8e30420a3a0f98e412ecd (diff)
downloadports-73c8ff9908301aa79ed8a7324cf5eaf41dd73916.tar.gz
ports-73c8ff9908301aa79ed8a7324cf5eaf41dd73916.zip
audio/nekobi-lv2: fix build with GCC-based architectures
This port requires C++11-compatible compiler to build on GCC architectures. Additionally, remove -mtune=generic -msse -msse2 on GCC architectures. PR: D20112 Approved by: yuri (maintainer), mat (mentor) Differential Revision: https://reviews.freebsd.org/D20112
Notes
Notes: svn path=/head/; revision=500667
Diffstat (limited to 'audio/nekobi-lv2')
-rw-r--r--audio/nekobi-lv2/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/nekobi-lv2/Makefile b/audio/nekobi-lv2/Makefile
index cbadfe154e8a..e87be11f6e10 100644
--- a/audio/nekobi-lv2/Makefile
+++ b/audio/nekobi-lv2/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= lv2>0:audio/lv2 \
bash:shells/bash
LIB_DEPENDS= libjack.so:audio/jack
-USES= gl gmake localbase pkgconfig shebangfix
+USES= compiler:c++11-lang gl gmake localbase pkgconfig shebangfix
SHEBANG_FILES= dpf/utils/generate-ttl.sh
USE_GITHUB= yes
GH_ACCOUNT= DISTRHO
@@ -29,6 +29,12 @@ USE_XORG= x11
CFLAGS+= -I${FILESDIR}
CFLAGS+= -Wno-c++11-narrowing # clang prints errors: https://github.com/DISTRHO/Nekobi/issues/7
+.if exists(/usr/lib/libstdc++.so)
+post-patch:
+ @${REINPLACE_CMD} -e 's/-mtune=generic -msse -msse2 //' \
+ ${WRKSRC}/dpf/Makefile.base.mk
+.endif
+
do-install: # https://github.com/DISTRHO/Nekobi/issues/8
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/lv2
cd ${WRKSRC}/bin && ${COPYTREE_SHARE} Nekobi.lv2 ${STAGEDIR}${PREFIX}/lib/lv2/