aboutsummaryrefslogtreecommitdiff
path: root/audio/normalize
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-08-28 08:37:46 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-08-28 08:37:46 +0000
commit804a6c180e250176a31ce29e3388490d72133f3a (patch)
tree395216ad6ba1eb0b7fd1a571a5d0c8b73f8bdd54 /audio/normalize
parentac2319576bfb7ecd4e7d31fb03125d599cb411c7 (diff)
downloadports-804a6c180e250176a31ce29e3388490d72133f3a.tar.gz
ports-804a6c180e250176a31ce29e3388490d72133f3a.zip
- When helper programs does not appear at compile time, the generated
script is broken. Therefore, disable helper program search at compile time and let it searches programs at runtime. - Helper programs can be installed via OPTIONS. Install madplay for MP3 as default. PR: ports/107386 (based on) Submitted by: Jonathan Liu <Net147 at hotmail.com> Approved by: maintainer via mail
Notes
Notes: svn path=/head/; revision=198423
Diffstat (limited to 'audio/normalize')
-rw-r--r--audio/normalize/Makefile23
1 files changed, 20 insertions, 3 deletions
diff --git a/audio/normalize/Makefile b/audio/normalize/Makefile
index 9a2823a39e27..1d4b30af50fd 100644
--- a/audio/normalize/Makefile
+++ b/audio/normalize/Makefile
@@ -7,6 +7,7 @@
PORTNAME= normalize
PORTVERSION= 0.7.7
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://download.savannah.gnu.org/releases/normalize/
@@ -16,16 +17,19 @@ COMMENT= A tool for adjusting the volume of wave/MP3 files to a standard level
LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad
USE_BZIP2= yes
-USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --disable-helper-search
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
MAN1= normalize.1 normalize-mp3.1
-OPTIONS= XMMS "Build XMMS plugin" off
+OPTIONS= XMMS "Build XMMS plugin" off \
+ MP3 "MP3 support" on \
+ OGG "OGG support" off \
+ FLAG "FLAC support" off
.include <bsd.port.pre.mk>
@@ -34,10 +38,23 @@ LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
PLIST_SUB+= XMMS=""
PLIST_SUB+= X11BASE="${X11BASE}"
.else
-CONFIGURE_ARGS= --disable-xmms
+CONFIGURE_ARGS+=--disable-xmms
PLIST_SUB+= XMMS="@comment "
.endif
+.if defined(WITH_MP3)
+RUN_DEPENDS+= madplay:${PORTSDIR}/audio/madplay \
+ lame:${PORTSDIR}/audio/lame
+.endif
+
+.if defined(WITH_OGG)
+RUN_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
+.endif
+
+.if defined(WITH_FLAC)
+RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""