aboutsummaryrefslogtreecommitdiff
path: root/audio/normalize
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-08 10:05:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-08 10:05:25 +0000
commitc527d50be3057b79739da609e469f7afc0c16ec6 (patch)
tree3fbe4a55a63129bff57d55a9eda41a671e8b1297 /audio/normalize
parent1ad772b1b758cf6fb54daf714eff7236786f4eb0 (diff)
downloadports-c527d50be3057b79739da609e469f7afc0c16ec6.tar.gz
ports-c527d50be3057b79739da609e469f7afc0c16ec6.zip
Use options helpers
Add a run dependency on perl (which also fixs normalize-mp3 shebang detection)
Notes
Notes: svn path=/head/; revision=350592
Diffstat (limited to 'audio/normalize')
-rw-r--r--audio/normalize/Makefile46
1 files changed, 13 insertions, 33 deletions
diff --git a/audio/normalize/Makefile b/audio/normalize/Makefile
index 96d9b2d3a8d0..3e22854ced43 100644
--- a/audio/normalize/Makefile
+++ b/audio/normalize/Makefile
@@ -3,16 +3,17 @@
PORTNAME= normalize
PORTVERSION= 0.7.7
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= audio
MASTER_SITES= SAVANNAH
MAINTAINER= alex@fafula.com
-COMMENT= A tool for adjusting the volume of wave/MP3 files to a standard level
+COMMENT= Tool for adjusting the volume of wave/MP3 files to a standard level
LIB_DEPENDS= libmad.so:${PORTSDIR}/audio/libmad
-USE_BZIP2= yes
+USES= shebangfix perl5 tar:bzip2
+USE_PERL5= run
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-helper-search
CPPFLAGS+= -I${LOCALBASE}/include
@@ -21,37 +22,16 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= XMMS MP3 OGG FLAC NLS
OPTIONS_DEFAULT= MP3
+OPTIONS_SUB= yes
XMMS_DESC= XMMS plugin
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MXMMS}
-LIB_DEPENDS+= libxmms.so:${PORTSDIR}/multimedia/xmms
-PLIST_SUB+= XMMS=""
-.else
-CONFIGURE_ARGS+=--disable-xmms
-PLIST_SUB+= XMMS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMP3}
-RUN_DEPENDS+= madplay:${PORTSDIR}/audio/madplay \
- lame:${PORTSDIR}/audio/lame
-.endif
-
-.if ${PORT_OPTIONS:MOGG}
-RUN_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
-.endif
-
-.if ${PORT_OPTIONS:MFLAC}
-RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+XMMS_LIB_DEPENDS= libxmms.so:${PORTSDIR}/multimedia/xmms
+XMMS_CONFIGURE_ENABLE= xmms
+MP3_RUN_DEPENDS+= madplay:${PORTSDIR}/audio/madplay \
+ lame:${PORTSDIR}/audio/lame
+OGG_RUN_DEPENDS= oggdec:${PORTSDIR}/audio/vorbis-tools
+FLAC_RUN_DEPENDS= flac:${PORTSDIR}/audio/flac
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
.include <bsd.port.mk>