aboutsummaryrefslogtreecommitdiff
path: root/audio/nosefart
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-30 04:16:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-30 04:16:51 +0000
commita1c50f9316d71b792a773031489832391cd75762 (patch)
tree459a33a4a4b73ed4270601e2a59e404ccd5b42f0 /audio/nosefart
parenta54d79fa38d297eb3983d3ad0cc98f7c113ccb1d (diff)
downloadports-a1c50f9316d71b792a773031489832391cd75762.tar.gz
ports-a1c50f9316d71b792a773031489832391cd75762.zip
- Unbreak parallel builds (-jX) by making automatic dependency generation
actually work (and be used) - Trim Makefile header and remove an indefinite article from COMMENT line - No need for a fancy, environment-aware "make clean" when all it does is it does is just "rm -rf nsfobj" - Define LICENSE (GPLv2), adjust WWW: line in port description while here Reported by: marino
Notes
Notes: svn path=/head/; revision=325660
Diffstat (limited to 'audio/nosefart')
-rw-r--r--audio/nosefart/Makefile18
-rw-r--r--audio/nosefart/files/patch-aa28
-rw-r--r--audio/nosefart/pkg-descr2
3 files changed, 26 insertions, 22 deletions
diff --git a/audio/nosefart/Makefile b/audio/nosefart/Makefile
index b86813b22c91..3b4bb42d6ba0 100644
--- a/audio/nosefart/Makefile
+++ b/audio/nosefart/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nosefart
-# Date created: 11 October 2000
-# Whom: sethk
-#
+# Created by: Seth Kingsley <sethk@osd.bsdi.com>
# $FreeBSD$
-#
PORTNAME= nosefart
PORTVERSION= 1.92f
@@ -13,15 +9,17 @@ MASTER_SITES= SF/${PORTNAME}/OldFiles
DISTNAME= ${PORTNAME}-${PORTVERSION}-mls
MAINTAINER= sethk@meowfishies.com
-COMMENT= A player for NES Sound Format (NSF)
+COMMENT= Player for NES Sound Format (NSF)
-USE_GMAKE= yes
+LICENSE= GPLv2
-MAKE_ENV= INSTALL="${INSTALL}" COPY="${COPY}" STRIP="${STRIP}"\
+USES= gmake
+MAKE_ENV= INSTALL="${INSTALL}" COPY="${COPY}" STRIP="${STRIP}" \
BINGRP="${BINGRP}" BINMODE="${BINMODE}" BINOWN="${BINOWN}"
+
PLIST_FILES= bin/nosefart
pre-build:
- @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} clean)
+ @${RM} -rf ${BUILD_WRKSRC}/nsfobj
-.include <bsd.port.mk>
+.include <bsd.port.mk>
diff --git a/audio/nosefart/files/patch-aa b/audio/nosefart/files/patch-aa
index d6fba4496bb7..d4af7a2b2769 100644
--- a/audio/nosefart/files/patch-aa
+++ b/audio/nosefart/files/patch-aa
@@ -1,6 +1,6 @@
--- Makefile.orig Wed Sep 24 11:02:34 2003
+++ Makefile Wed Sep 24 19:43:19 2003
-@@ -1,12 +1,6 @@
+@@ -1,11 +1,10 @@
################################
# Configuration
@@ -9,11 +9,14 @@
-LDFLAGS = -lm
-PREFIX = /usr/local
-WANT_DEBUG=TRUE
--
++CC ?= gcc
++CFLAGS ?=
++LDFLAGS ?= -lm
++PREFIX ?= /usr/local
+
# nothing below here should need to be changed
- ################################
-@@ -21,19 +15,13 @@
+@@ -21,19 +20,13 @@ SRCDIR = src
CFLAGS += -DNSF_PLAYER
@@ -34,7 +37,7 @@
-I$(BUILDTOP)\
-I/usr/local/include/
-@@ -59,9 +47,11 @@
+@@ -59,6 +52,8 @@ SRCS = $(addsuffix .c, $(FILES) linux/ma
SOURCES = $(addprefix $(SRCDIR)/, $(SRCS))
OBJECTS = $(patsubst $(SRCDIR)/%.c,$(BUILDDIR)/%.o,$(SOURCES))
@@ -42,12 +45,15 @@
+
ALL_OBJECTS = $(OBJECTS)
--ALL_TARGETS = $(BUILDTOP)/$(NAME)
-+ALL_TARGETS = $(BUILDTOP)/config.h $(BUILDTOP)/$(NAME)
+ ALL_TARGETS = $(BUILDTOP)/$(NAME)
+@@ -82,12 +77,13 @@ $(BUILDTOP)/config.h: $(BUILDDIR) Makefi
- ################################
- # Rules
-@@ -87,7 +77,7 @@
+ $(BUILDDIR)/dep: $(BUILDTOP)/config.h
+ $(CC) $(NSFINFO_CFLAGS) $(CFLAGS) -M $(SOURCES) > $@
++dep: $(BUILDDIR)/dep
+
+--include $(BUILDDIR)/dep/
++-include $(BUILDDIR)/dep
install: all
mkdir -p $(PREFIX)/bin
@@ -56,7 +62,7 @@
@echo "-----------------------------------------------"
@echo "Be sure to run chmod +s $(PREFIX)/bin/$(NAME) if you want ordinary users"
@echo "to be able to use /dev/dsp. SUID isn't necessary, though, if you want to"
-@@ -105,7 +95,7 @@
+@@ -105,7 +101,7 @@ clean:
# The real heavy lifting
$(BUILDTOP)/$(NAME): $(OBJECTS)
diff --git a/audio/nosefart/pkg-descr b/audio/nosefart/pkg-descr
index e55aee48f948..4f0deae5916d 100644
--- a/audio/nosefart/pkg-descr
+++ b/audio/nosefart/pkg-descr
@@ -2,4 +2,4 @@ This is a port of Nosefart, a player for the NSF sound format, which
describes music taken from Nintendo Entertainment System game cartridges
in a compact form.
-WWW: http://sourceforge.net/projects/nosefart
+WWW: http://nosefart.sourceforge.net/