aboutsummaryrefslogtreecommitdiff
path: root/audio/ocp
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2024-02-20 03:47:00 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2024-02-20 03:48:59 +0000
commite0f0ad3b412daad84add6e73502d0ed5d9857b26 (patch)
tree64ec15a5ccecd183a5c39da35a3c3577b2ea2f6c /audio/ocp
parent474931d755fc45083d212d236a0218ab54eb6781 (diff)
downloadports-e0f0ad3b412daad84add6e73502d0ed5d9857b26.tar.gz
ports-e0f0ad3b412daad84add6e73502d0ed5d9857b26.zip
Diffstat (limited to 'audio/ocp')
-rw-r--r--audio/ocp/Makefile3
-rw-r--r--audio/ocp/distinfo6
-rw-r--r--audio/ocp/files/patch-filesel_filesystem-rpg.c15
3 files changed, 19 insertions, 5 deletions
diff --git a/audio/ocp/Makefile b/audio/ocp/Makefile
index 094537b908f9..945f633041d0 100644
--- a/audio/ocp/Makefile
+++ b/audio/ocp/Makefile
@@ -1,6 +1,5 @@
PORTNAME= ocp
-PORTVERSION= 0.2.106
-PORTREVISION= 3
+PORTVERSION= 0.2.107
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= https://stian.cubic.org/ocp/
diff --git a/audio/ocp/distinfo b/audio/ocp/distinfo
index d223edd1050f..d299fbb8eb8f 100644
--- a/audio/ocp/distinfo
+++ b/audio/ocp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1690785269
-SHA256 (ocp-0.2.106.tar.xz) = bf11d96d4a58bbf9c344eb53cf815fc2097c63a3c2c713f7ffb134073bd84721
-SIZE (ocp-0.2.106.tar.xz) = 3985404
+TIMESTAMP = 1708372777
+SHA256 (ocp-0.2.107.tar.xz) = 7627e4fe3acf7ffd7108ac2a6bf53e8a28de7a220c054338c8642c4e37d94626
+SIZE (ocp-0.2.107.tar.xz) = 3994444
diff --git a/audio/ocp/files/patch-filesel_filesystem-rpg.c b/audio/ocp/files/patch-filesel_filesystem-rpg.c
new file mode 100644
index 000000000000..c58d9c4866d8
--- /dev/null
+++ b/audio/ocp/files/patch-filesel_filesystem-rpg.c
@@ -0,0 +1,15 @@
+--- filesel/filesystem-rpg.c.orig 2024-02-19 21:41:47 UTC
++++ filesel/filesystem-rpg.c
+@@ -609,11 +609,11 @@ static int rpg_dir_readdir_iterate (ocpdirhandle_pt _s
+ self->dir->owner->archive_filehandle->seek_set (self->dir->owner->archive_filehandle, self->nextheader_offset);
+ if (self->dir->owner->archive_filehandle->read (self->dir->owner->archive_filehandle, header, sizeof (header)) < 6)
+ {
+-finished:
+ const char *filename;
+ uint8_t *metadata = 0;
+ size_t metadatasize = 0;
+
++finished:
+ self->dir->owner->ready = 1;
+ rpg_instance_encode_blob (self->dir->owner, &metadata, &metadatasize);
+ if (metadata)