aboutsummaryrefslogtreecommitdiff
path: root/audio/ogg2mp3
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-09 13:01:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-09 13:01:12 +0000
commit542c5d529a1887794be6f0d5ff60b91578eced94 (patch)
tree1e6cd2a9ac1848b5be155b87d92e9d52c3ef6fcb /audio/ogg2mp3
parentd0bd9acc957cbe3c39229b757d8c2b35966a8438 (diff)
downloadports-542c5d529a1887794be6f0d5ff60b91578eced94.tar.gz
ports-542c5d529a1887794be6f0d5ff60b91578eced94.zip
- Converted mp3-files sound like pure static.
This is fixed by removing the "-x" flag from the lame commandline. - Pass maintainership to submitter PR: 131495 Submitted by: Tobias Rehbein <tobias.rehbein@web.de>
Notes
Notes: svn path=/head/; revision=227878
Diffstat (limited to 'audio/ogg2mp3')
-rw-r--r--audio/ogg2mp3/Makefile4
-rw-r--r--audio/ogg2mp3/files/patch-ogg2mp337
2 files changed, 37 insertions, 4 deletions
diff --git a/audio/ogg2mp3/Makefile b/audio/ogg2mp3/Makefile
index c241a146f54a..646cc5f21eb7 100644
--- a/audio/ogg2mp3/Makefile
+++ b/audio/ogg2mp3/Makefile
@@ -6,11 +6,11 @@
PORTNAME= ogg2mp3
PORTVERSION= 0.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://amor.cms.hu-berlin.de/~h0444y2j/pub/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tobias.rehbein@web.de
COMMENT= Perl script that converts Ogg Vorbis files to MP3 format
RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
diff --git a/audio/ogg2mp3/files/patch-ogg2mp3 b/audio/ogg2mp3/files/patch-ogg2mp3
index b65976fa567f..0e5bea7eb6fc 100644
--- a/audio/ogg2mp3/files/patch-ogg2mp3
+++ b/audio/ogg2mp3/files/patch-ogg2mp3
@@ -1,5 +1,26 @@
---- ./ogg2mp3.orig 2009-02-02 20:13:18.000000000 +0000
-+++ ./ogg2mp3 2009-02-02 20:13:44.000000000 +0000
+--- ./ogg2mp3.orig 2005-05-16 18:07:33.000000000 +0000
++++ ./ogg2mp3 2009-02-08 12:29:27.000000000 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/local/bin/perl
+
+ # ogg2mp3
+ #
+@@ -51,10 +51,10 @@
+ print " Thanks to all who took an interest. Have fun!\n";
+ print " ------------------------------------------------------------------- \n\n";
+
+-my $MP3ENC = "/usr/bin/lame";
+-#my $MP3INFO = "/usr/bin/mp3_check";
+-my $OGGINFO = "/usr/bin/ogginfo";
+-my $OGG123 = "/usr/bin/ogg123";
++my $MP3ENC = "/usr/local/bin/lame";
++#my $MP3INFO = "/usr/local/bin/mp3_check";
++my $OGGINFO = "/usr/local/bin/ogginfo";
++my $OGG123 = "/usr/local/bin/ogg123";
+
+ # check presence of executables
+ stat($MP3ENC) or die "Error: $MP3ENC not present!\n";
@@ -68,7 +68,7 @@
# build genre hash
@@ -9,3 +30,15 @@
while(<GENRES>) {
chomp;
next if /^\s*$/;
+@@ -308,10 +308,8 @@
+
+ $mp3outputfile_escaped = shell_quote($mp3outputfile);
+ $oggfile_escaped = shell_quote($oggfile);
+- # this took me some time to figure
+- # note that byte order is swapped by lame via -x option
+ # TODO: somebody please tell me how to supress the "Assuming bla bla" output without devnull
+- $result = system("$OGG123 $decquiet -d raw -f - $oggfile_escaped | $MP3ENC $encquiet -r -x -q $quality -b $bitrate -s $frequency -m $channels $infostring - $mp3outputfile_escaped");
++ $result = system("$OGG123 $decquiet -d raw -f - $oggfile_escaped | $MP3ENC $encquiet -r -q $quality -b $bitrate -s $frequency -m $channels $infostring - $mp3outputfile_escaped");
+
+ # TODO: find some widely used mp3 checker
+ # disabled the checking due to lack of checker