aboutsummaryrefslogtreecommitdiff
path: root/audio/ogg2mp3
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-13 01:34:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-13 01:34:01 +0000
commitc50058224486f6124d98c4f2163d0a009061e17e (patch)
tree03b8fafe1be0f39c2586762c4aff08594e171c66 /audio/ogg2mp3
parent7dc4f37594f41c1f80919684056c9344db3026d4 (diff)
downloadports-c50058224486f6124d98c4f2163d0a009061e17e.tar.gz
ports-c50058224486f6124d98c4f2163d0a009061e17e.zip
Re-add audio/ogg2mp3: It was unfetchable because it moved to github
PR: 234428 Submitted by: tobias.rehbein@web.de (maintainer)
Notes
Notes: svn path=/head/; revision=501511
Diffstat (limited to 'audio/ogg2mp3')
-rw-r--r--audio/ogg2mp3/Makefile37
-rw-r--r--audio/ogg2mp3/distinfo3
-rw-r--r--audio/ogg2mp3/files/patch-ogg2mp317
-rw-r--r--audio/ogg2mp3/pkg-descr3
4 files changed, 60 insertions, 0 deletions
diff --git a/audio/ogg2mp3/Makefile b/audio/ogg2mp3/Makefile
new file mode 100644
index 000000000000..6098ad053b65
--- /dev/null
+++ b/audio/ogg2mp3/Makefile
@@ -0,0 +1,37 @@
+# Created by: Aleksander Fafula <alex@bsdguru.org>
+# $FreeBSD$
+
+PORTNAME= ogg2mp3
+PORTVERSION= 0.6.1
+PORTREVISION?= 3
+CATEGORIES= audio
+
+MAINTAINER= tobias.rehbein@web.de
+COMMENT= Perl script that converts Ogg Vorbis files to MP3 format
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/doc/LICENSE
+
+RUN_DEPENDS= lame:audio/lame \
+ p5-String-ShellQuote>=0:textproc/p5-String-ShellQuote \
+ ogginfo:audio/vorbis-tools
+
+USES= perl5 shebangfix tar:tgz
+USE_GITHUB= yes
+GH_ACCOUNT= fithp
+GH_TAGNAME= f3bee47c3bce01a33b5bce88fa70bd9ecadca0ad
+
+SHEBANG_FILES= ogg2mp3
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= bin/ogg2mp3
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/ogg2mp3
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ogg2mp3 ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/ogg2mp3/distinfo b/audio/ogg2mp3/distinfo
new file mode 100644
index 000000000000..563ba3e07169
--- /dev/null
+++ b/audio/ogg2mp3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545856210
+SHA256 (fithp-ogg2mp3-0.6.1-f3bee47c3bce01a33b5bce88fa70bd9ecadca0ad_GH0.tar.gz) = d43e9e3854db5a7fa9f3bbf40198dca95f2ed429e100ad361447df8c8e1bb078
+SIZE (fithp-ogg2mp3-0.6.1-f3bee47c3bce01a33b5bce88fa70bd9ecadca0ad_GH0.tar.gz) = 13257
diff --git a/audio/ogg2mp3/files/patch-ogg2mp3 b/audio/ogg2mp3/files/patch-ogg2mp3
new file mode 100644
index 000000000000..ce6043e9468a
--- /dev/null
+++ b/audio/ogg2mp3/files/patch-ogg2mp3
@@ -0,0 +1,17 @@
+--- ogg2mp3.orig 2009-08-28 00:49:03 UTC
++++ ogg2mp3
+@@ -50,10 +50,10 @@ print " Maintainership assumed by James Ausmus\n";
+ print " This code is released under the General Public License v2.\n";
+ print " ------------------------------------------------------------------- \n\n";
+
+-my $MP3ENC = "/usr/bin/lame";
+-#my $MP3INFO = "/usr/bin/mp3_check";
+-my $OGGINFO = "/usr/bin/ogginfo";
+-my $OGG123 = "/usr/bin/ogg123";
++my $MP3ENC = "%%LOCALBASE%%/bin/lame";
++#my $MP3INFO = "%%LOCALBASE%%/bin/mp3_check";
++my $OGGINFO = "%%LOCALBASE%%/bin/ogginfo";
++my $OGG123 = "%%LOCALBASE%%/bin/ogg123";
+
+ # check presence of executables
+ stat($MP3ENC) or die "Error: $MP3ENC not present!\n";
diff --git a/audio/ogg2mp3/pkg-descr b/audio/ogg2mp3/pkg-descr
new file mode 100644
index 000000000000..2795f9385c41
--- /dev/null
+++ b/audio/ogg2mp3/pkg-descr
@@ -0,0 +1,3 @@
+ogg2mp3 is a perl script that converts Ogg Vorbis files into MP3 format.
+
+WWW: https://github.com/fithp/ogg2mp3