aboutsummaryrefslogtreecommitdiff
path: root/audio/openal-soft/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-10-19 07:28:28 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-10-19 07:28:28 +0000
commit6488eeb32e4de6a000b652832b444d1c428a8094 (patch)
tree6d91eed5cfcdfbe6f5f6dd0371358033c43d2f10 /audio/openal-soft/files/patch-CMakeLists.txt
parent1c6b792c5d5964801084513f4f4a4b6f078c388d (diff)
downloadports-6488eeb32e4de6a000b652832b444d1c428a8094.tar.gz
ports-6488eeb32e4de6a000b652832b444d1c428a8094.zip
Notes
Diffstat (limited to 'audio/openal-soft/files/patch-CMakeLists.txt')
-rw-r--r--audio/openal-soft/files/patch-CMakeLists.txt30
1 files changed, 25 insertions, 5 deletions
diff --git a/audio/openal-soft/files/patch-CMakeLists.txt b/audio/openal-soft/files/patch-CMakeLists.txt
index 723a700b56c9..3d83e5817d4e 100644
--- a/audio/openal-soft/files/patch-CMakeLists.txt
+++ b/audio/openal-soft/files/patch-CMakeLists.txt
@@ -1,8 +1,28 @@
---- CMakeLists.txt.orig 2011-02-15 21:05:40.000000000 +0100
-+++ CMakeLists.txt 2011-02-17 21:52:49.000000000 +0100
-@@ -270,10 +270,6 @@
+--- CMakeLists.txt.orig 2014-08-15 07:06:59 UTC
++++ CMakeLists.txt
+@@ -62,8 +62,8 @@
+ SET(LIBNAME openal)
- CHECK_LIBRARY_EXISTS(pthread pthread_setschedparam "" HAVE_PTHREAD_SETSCHEDPARAM)
+ # These are needed on non-Windows systems for extra features
+- ADD_DEFINITIONS(-D_GNU_SOURCE=1 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700)
+- SET(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -D_GNU_SOURCE=1 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700")
++ ADD_DEFINITIONS(-D_GNU_SOURCE=1)
++ SET(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -D_GNU_SOURCE=1")
+ ENDIF()
+
+ # Set defines for large file support
+@@ -186,7 +186,7 @@
+ # Check if we have C11 _Atomic
+ CHECK_C_SOURCE_COMPILES(
+ "#include <stdatomic.h>
+- int _Atomic foo;
++ const int _Atomic foo = ATOMIC_VAR_INIT(~0);
+ int main()
+ {
+ return atomic_load(&foo);
+@@ -523,10 +523,6 @@
+
+ CHECK_SYMBOL_EXISTS(pthread_mutex_timedlock pthread.h HAVE_PTHREAD_MUTEX_TIMEDLOCK)
- CHECK_LIBRARY_EXISTS(rt clock_gettime "" HAVE_LIBRT)
- IF(HAVE_LIBRT)
@@ -11,7 +31,7 @@
ENDIF()
# Check for a 64-bit type
-@@ -502,7 +498,7 @@
+@@ -1108,7 +1104,7 @@
DESTINATION include/AL
)
INSTALL(FILES "${OpenAL_BINARY_DIR}/openal.pc"