aboutsummaryrefslogtreecommitdiff
path: root/audio/openal-soft/files
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-06-21 06:32:16 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-06-21 06:32:16 +0000
commit50346552a35f32244c25a253a4b77c6c6db96c90 (patch)
tree2030ff22e0b4cfb27ae912edccc19eab00ad5003 /audio/openal-soft/files
parente3ba5463c7fb4855888330938ce2d7721eb27436 (diff)
downloadports-50346552a35f32244c25a253a4b77c6c6db96c90.tar.gz
ports-50346552a35f32244c25a253a4b77c6c6db96c90.zip
Notes
Diffstat (limited to 'audio/openal-soft/files')
-rw-r--r--audio/openal-soft/files/patch-Alc_ALc.c22
-rw-r--r--audio/openal-soft/files/patch-CMakeLists.txt47
2 files changed, 49 insertions, 20 deletions
diff --git a/audio/openal-soft/files/patch-Alc_ALc.c b/audio/openal-soft/files/patch-Alc_ALc.c
new file mode 100644
index 000000000000..d628605f0a55
--- /dev/null
+++ b/audio/openal-soft/files/patch-Alc_ALc.c
@@ -0,0 +1,22 @@
+Prefer sndio over OSS when it's enabled.
+
+--- Alc/ALc.c.orig 2018-06-21 02:27:21 UTC
++++ Alc/ALc.c
+@@ -69,14 +69,14 @@ static struct BackendInfo BackendList[] = {
+ #ifdef HAVE_COREAUDIO
+ { "core", ALCcoreAudioBackendFactory_getFactory },
+ #endif
+-#ifdef HAVE_OSS
+- { "oss", ALCossBackendFactory_getFactory },
+-#endif
+ #ifdef HAVE_SOLARIS
+ { "solaris", ALCsolarisBackendFactory_getFactory },
+ #endif
+ #ifdef HAVE_SNDIO
+ { "sndio", ALCsndioBackendFactory_getFactory },
++#endif
++#ifdef HAVE_OSS
++ { "oss", ALCossBackendFactory_getFactory },
+ #endif
+ #ifdef HAVE_QSA
+ { "qsa", ALCqsaBackendFactory_getFactory },
diff --git a/audio/openal-soft/files/patch-CMakeLists.txt b/audio/openal-soft/files/patch-CMakeLists.txt
index 4f330d5f9840..a4a07355bc54 100644
--- a/audio/openal-soft/files/patch-CMakeLists.txt
+++ b/audio/openal-soft/files/patch-CMakeLists.txt
@@ -1,22 +1,29 @@
---- CMakeLists.txt.orig 2017-07-30 05:09:21 UTC
+--- CMakeLists.txt.orig 2017-09-24 13:41:50 UTC
+++ CMakeLists.txt
-@@ -646,10 +646,6 @@ int main()
-
- CHECK_SYMBOL_EXISTS(pthread_mutex_timedlock pthread.h HAVE_PTHREAD_MUTEX_TIMEDLOCK)
-
-- CHECK_LIBRARY_EXISTS(rt clock_gettime "" HAVE_LIBRT)
-- IF(HAVE_LIBRT)
-- SET(EXTRA_LIBS rt ${EXTRA_LIBS})
-- ENDIF()
- ENDIF()
-
- # Check for a 64-bit type
-@@ -1322,7 +1318,7 @@ IF(ALSOFT_INSTALL)
- DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/AL
+@@ -1381,7 +1381,7 @@ endif()
+ # Install alsoft.conf configuration file
+ IF(ALSOFT_CONFIG)
+ INSTALL(FILES alsoftrc.sample
+- DESTINATION ${CMAKE_INSTALL_DATADIR}/openal
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/openal-soft
)
- INSTALL(FILES "${OpenAL_BINARY_DIR}/openal.pc"
-- DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
-+ DESTINATION "libdata/pkgconfig")
- IF(TARGET soft_oal)
- INSTALL(TARGETS soft_oal
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ MESSAGE(STATUS "Installing sample configuration")
+ MESSAGE(STATUS "")
+@@ -1391,7 +1391,7 @@ ENDIF()
+ IF(ALSOFT_HRTF_DEFS)
+ INSTALL(FILES hrtf/default-44100.mhr
+ hrtf/default-48000.mhr
+- DESTINATION ${CMAKE_INSTALL_DATADIR}/openal/hrtf
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/openal-soft/hrtf
+ )
+ MESSAGE(STATUS "Installing HRTF definitions")
+ MESSAGE(STATUS "")
+@@ -1405,7 +1405,7 @@ IF(ALSOFT_AMBDEC_PRESETS)
+ presets/rectangle.ambdec
+ presets/square.ambdec
+ presets/presets.txt
+- DESTINATION ${CMAKE_INSTALL_DATADIR}/openal/presets
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/openal-soft/presets
+ )
+ MESSAGE(STATUS "Installing AmbDec presets")
+ MESSAGE(STATUS "")