aboutsummaryrefslogtreecommitdiff
path: root/audio/openal-soft
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-12 10:39:39 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-12 10:39:39 +0000
commitdeeb46784c3acc222f015bf47371c0844fd511c2 (patch)
treee8322adb6ba668a2572878564acc45b1d8c738ca /audio/openal-soft
parentf0b4f83222d101593a670b0746df654ad2e75c08 (diff)
downloadports-deeb46784c3acc222f015bf47371c0844fd511c2.tar.gz
ports-deeb46784c3acc222f015bf47371c0844fd511c2.zip
audio/openal-soft: Use ld.gold instead of ld.bfd
openal-soft has stopped linking on 12-STABLE with ld.bfd. As a workaround use ld.gold for now until we can discover why that happens all of a sudden. PR: 235603 Reported by: Robert Cina <transitive@gmail.com>
Notes
Notes: svn path=/head/; revision=492771
Diffstat (limited to 'audio/openal-soft')
-rw-r--r--audio/openal-soft/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
index da0b892912a4..8fb063e3783b 100644
--- a/audio/openal-soft/Makefile
+++ b/audio/openal-soft/Makefile
@@ -15,8 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS= openal-200[0-9]*
USES= cmake compiler:c11 tar:bzip2
+USE_BINUTILS= yes
USE_LDCONFIG= yes
-LLD_UNSAFE= yes
+
CMAKE_ARGS= -DCMAKE_INSTALL_DATADIR:STRING="${PREFIX}/etc"
CMAKE_OFF= ALSOFT_BACKEND_ALSA \
ALSOFT_DLOPEN \
@@ -25,7 +26,12 @@ CMAKE_OFF= ALSOFT_BACKEND_ALSA \
ALSOFT_REQUIRE_QSA
CMAKE_ON= ALSOFT_BACKEND_WAVE \
ALSOFT_UTILS
-LDFLAGS+= -Wl,--as-needed # do not link with librt and libdl
+
+# use gold linker due to some problems with ld.bfd on 12-STABLE,
+# cf. PR 235603
+# do not link with librt and libdl.
+LDFLAGS+= -fuse-ld=gold \
+ -Wl,--as-needed
OPTIONS_DEFINE= EXAMPLES CONFIG JACK OSS PORTAUDIO PULSEAUDIO SDL SNDIO
OPTIONS_DEFAULT= OSS