aboutsummaryrefslogtreecommitdiff
path: root/audio/openspc
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-11 20:10:40 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-11 20:10:40 +0000
commit862bb5de98e1ca9da02cac338c959818be444af9 (patch)
tree4ef80162f9ab4e7be0b2fe302505a032e8c40024 /audio/openspc
parent179f774c4c2b60fc981d7a06f6356f4875794cb1 (diff)
downloadports-862bb5de98e1ca9da02cac338c959818be444af9.tar.gz
ports-862bb5de98e1ca9da02cac338c959818be444af9.zip
- Convert to USES=libtool and add INSTALL_TARGET=install-strip
- Add USE_AUTOTOOLS=libtoolize (and others) because the bundled libtool is too old to support FreeBSD 4 and higher
Notes
Notes: svn path=/head/; revision=367974
Diffstat (limited to 'audio/openspc')
-rw-r--r--audio/openspc/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/audio/openspc/Makefile b/audio/openspc/Makefile
index 7c306a8bfb15..2370419d2c20 100644
--- a/audio/openspc/Makefile
+++ b/audio/openspc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openspc
PORTVERSION= 0.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://membres.lycos.fr/pixels/ \
CRITICAL
@@ -13,16 +13,25 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Command-line player for .spc and .zst files
ONLY_FOR_ARCHS= i386 # contains x86 asm code
-USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= libtool
+USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
+AUTOMAKE_ARGS= -a -c -f
USE_GCC= any
+USE_LDCONFIG= yes
PORTDOCS= README
-PLIST_FILES= bin/OpenSPClite include/OpenSPC.h lib/libOpenSPC.so \
- lib/libOpenSPC.so.3 lib/libOpenSPC.la lib/libOpenSPC.a
+PLIST_FILES= bin/OpenSPClite include/OpenSPC.h lib/libOpenSPC.a \
+ lib/libOpenSPC.so lib/libOpenSPC.so.0 lib/libOpenSPC.so.0.3.1
OPTIONS_DEFINE= DOCS
+post-patch:
+ @${REINPLACE_CMD} '1,/AUDIOFILE/d' ${WRKSRC}/acinclude.m4
+ @${REINPLACE_CMD} '/AC_PROG_CC/{p;s/.*/AM_PROG_AS/;}' \
+ ${WRKSRC}/configure.in
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}