aboutsummaryrefslogtreecommitdiff
path: root/audio/opus-tools
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2017-04-06 20:59:33 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2017-04-06 20:59:33 +0000
commit5605ee4abc8b936270ce65e66ea1621dd1473a16 (patch)
tree3c7eb6db264e3d552ac2d069d710bea9af1929cb /audio/opus-tools
parent1e8d0f91a6a5559f26f154730092fce8a7d43919 (diff)
downloadports-5605ee4abc8b936270ce65e66ea1621dd1473a16.tar.gz
ports-5605ee4abc8b936270ce65e66ea1621dd1473a16.zip
Update to 0.1.10. No list of changes available, but looks like bug fixes.
Notes
Notes: svn path=/head/; revision=437876
Diffstat (limited to 'audio/opus-tools')
-rw-r--r--audio/opus-tools/Makefile3
-rw-r--r--audio/opus-tools/distinfo5
-rw-r--r--audio/opus-tools/files/patch-src_audio-in.c85
-rw-r--r--audio/opus-tools/files/patch-src_cpusupport.h13
4 files changed, 4 insertions, 102 deletions
diff --git a/audio/opus-tools/Makefile b/audio/opus-tools/Makefile
index 657b0e961b83..395b58d02cc0 100644
--- a/audio/opus-tools/Makefile
+++ b/audio/opus-tools/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= opus-tools
-PORTVERSION= 0.1.9
-PORTREVISION= 3
+PORTVERSION= 0.1.10
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/opus/ \
MOZILLA/opus
diff --git a/audio/opus-tools/distinfo b/audio/opus-tools/distinfo
index 47ca001ea459..0c8fdb3fd9c3 100644
--- a/audio/opus-tools/distinfo
+++ b/audio/opus-tools/distinfo
@@ -1,2 +1,3 @@
-SHA256 (opus-tools-0.1.9.tar.gz) = b1873dd78c7fbc98cf65d6e10cfddb5c2c03b3af93f922139a2104baedb4643a
-SIZE (opus-tools-0.1.9.tar.gz) = 385158
+TIMESTAMP = 1491508200
+SHA256 (opus-tools-0.1.10.tar.gz) = a2357532d19471b70666e0e0ec17d514246d8b3cb2eb168f68bb0f6fd372b28c
+SIZE (opus-tools-0.1.10.tar.gz) = 312093
diff --git a/audio/opus-tools/files/patch-src_audio-in.c b/audio/opus-tools/files/patch-src_audio-in.c
deleted file mode 100644
index 8c72337c9c39..000000000000
--- a/audio/opus-tools/files/patch-src_audio-in.c
+++ /dev/null
@@ -1,85 +0,0 @@
---- src/audio-in.c.orig 2014-02-26 00:55:47 UTC
-+++ src/audio-in.c
-@@ -42,6 +42,7 @@
- # define _FILE_OFFSET_BITS 64
- #endif
-
-+#include <limits.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
-@@ -287,13 +288,14 @@ static int aiff_permute_matrix[6][6] =
- int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen)
- {
- int aifc; /* AIFC or AIFF? */
-- unsigned int len;
-- unsigned char *buffer;
-+ unsigned int len, readlen;
-+ unsigned char buffer[22];
- unsigned char buf2[8];
- int bigendian = 1;
- aiff_fmt format;
- aifffile *aiff;
- int i;
-+ long channels;
- (void)buflen;/*unused*/
-
- if(buf[11]=='C')
-@@ -313,19 +315,25 @@ int aiff_open(FILE *in, oe_enc_opt *opt,
- return 0; /* Weird common chunk */
- }
-
-- buffer = alloca(len);
--
-- if(fread(buffer,1,len,in) < len)
-+ readlen = len < sizeof(buffer) ? len : sizeof(buffer);
-+ if(fread(buffer,1,readlen,in) < readlen ||
-+ (len > readlen && !seek_forward(in, len-readlen)))
- {
- fprintf(stderr, _("Warning: Unexpected EOF reading AIFF header\n"));
- return 0;
- }
-
-- format.channels = READ_U16_BE(buffer);
-+ format.channels = channels = READ_U16_BE(buffer);
- format.totalframes = READ_U32_BE(buffer+2);
- format.samplesize = READ_U16_BE(buffer+6);
- format.rate = (int)read_IEEE80(buffer+8);
-
-+ if(channels <= 0L || SHRT_MAX < channels)
-+ {
-+ fprintf(stderr, _("Warning: Unsupported count of channels in AIFF header\n"));
-+ return 0;
-+ }
-+
- if(aifc)
- {
- if(len < 22)
-@@ -442,6 +450,7 @@ int wav_open(FILE *in, oe_enc_opt *opt,
- wav_fmt format;
- wavfile *wav;
- int i;
-+ long channels;
- (void)buflen;/*unused*/
- (void)oldbuf;/*unused*/
-
-@@ -481,12 +490,18 @@ int wav_open(FILE *in, oe_enc_opt *opt,
- }
-
- format.format = READ_U16_LE(buf);
-- format.channels = READ_U16_LE(buf+2);
-+ format.channels = channels = READ_U16_LE(buf+2);
- format.samplerate = READ_U32_LE(buf+4);
- format.bytespersec = READ_U32_LE(buf+8);
- format.align = READ_U16_LE(buf+12);
- format.samplesize = READ_U16_LE(buf+14);
-
-+ if(channels <= 0L || SHRT_MAX < channels)
-+ {
-+ fprintf(stderr, _("Warning: Unsupported count of channels in WAV header\n"));
-+ return 0;
-+ }
-+
- if(format.format == -2) /* WAVE_FORMAT_EXTENSIBLE */
- {
- if(len<40)
diff --git a/audio/opus-tools/files/patch-src_cpusupport.h b/audio/opus-tools/files/patch-src_cpusupport.h
deleted file mode 100644
index c2e0b15e8daa..000000000000
--- a/audio/opus-tools/files/patch-src_cpusupport.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/cpusupport.h.orig 2012-12-17 23:17:07 UTC
-+++ src/cpusupport.h
-@@ -33,7 +33,9 @@
- on a host without those instructions. Therefore we disable
- the query both if the compiler isn't supporting SSE, and on
- targets which are guaranteed to have SSE. */
--# if !defined(__SSE__) || defined(_M_X64) || defined(__amd64__)
-+/* XXX GCC on FreeBSD 9 does not have <cpuid.h>. On i386, __SSE__ can
-+ appear with -march=CPU-TYPE, so disable the SSE check completely. */
-+# if !defined(__SSE__) || defined(_M_X64) || defined(__amd64__) || defined(__i386__)
- # define query_cpu_support() 0
- # else
-