aboutsummaryrefslogtreecommitdiff
path: root/audio/orbit-lv2
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-08-15 00:13:32 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-08-15 00:13:32 +0000
commit4042b3871276e9dbcde3e21788d38c47f9aa8841 (patch)
treebff820b90a4a08d148aae77bdb0cf46dbdb27399 /audio/orbit-lv2
parent0991d7673590f07fe11e4ca09edb215c1f3d34d9 (diff)
downloadports-4042b3871276e9dbcde3e21788d38c47f9aa8841.tar.gz
ports-4042b3871276e9dbcde3e21788d38c47f9aa8841.zip
Several LV2 plugin bundled together:
* Beatbox Creates MIDI events based on LV2 time position events, e.g. to drive a drum machine. Bars and beats can be disabled/enabled separately. * Cargoship Record/Playback of arbitrary LV2 atoms to/from disk. Record all incoming atom messages with sample accuracy and play them back later from disk. Stored atom event data is part of the plugin state and is preserved across instantiations. * Click Synthesizes click tracks based on LV2 time position events (bars and beats). Bars and beats can be disabled/enabled separately. * Looper Loops arbitrary LV2 atom events on a ping-pong buffer. E.g. loops MIDI, OSC or anything else that can be packed into LV2 atoms with sample accuracy. Needs to be driven by LV2 time position events. * Pacemaker Creates LV2 time position events from scratch to drive other plugins. * Quantum Quantizes incoming events to whole beats. * Subspace Subdivide or multiply incoming time signals by whole fractions, e.g. to speed up time x2, x3, ... or slow it down to x1/2, x1/3, ... WWW: https://open-music-kontrollers.ch/lv2/orbit/ PR: 221325 Submitted by: Yuri Victorovich (maintainer) Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D12026
Notes
Notes: svn path=/head/; revision=447972
Diffstat (limited to 'audio/orbit-lv2')
-rw-r--r--audio/orbit-lv2/Makefile27
-rw-r--r--audio/orbit-lv2/distinfo3
-rw-r--r--audio/orbit-lv2/pkg-descr24
3 files changed, 54 insertions, 0 deletions
diff --git a/audio/orbit-lv2/Makefile b/audio/orbit-lv2/Makefile
new file mode 100644
index 000000000000..440f3e0387a6
--- /dev/null
+++ b/audio/orbit-lv2/Makefile
@@ -0,0 +1,27 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= orbit
+PORTVERSION= 0.1.431
+CATEGORIES= audio
+MASTER_SITES= https://gitlab.com/OpenMusicKontrollers/orbit.lv2/repository/archive.tar.gz?ref=aca0b7a&dummy=/
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= LV2 plugin bundle from Open Music Kontrollers
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+
+USES= cmake pkgconfig
+CMAKE_ARGS= -DCMAKE_BUILD_TYPE="Release"
+PLIST_FILES= lib/lv2/orbit.lv2/manifest.ttl \
+ lib/lv2/orbit.lv2/orbit.so \
+ lib/lv2/orbit.lv2/orbit.ttl
+
+post-extract:
+ @${MV} ${WRKDIR}/orbit* ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/audio/orbit-lv2/distinfo b/audio/orbit-lv2/distinfo
new file mode 100644
index 000000000000..9c8e706f7a46
--- /dev/null
+++ b/audio/orbit-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502740312
+SHA256 (orbit-0.1.431.tar.gz) = 504292ffa0c999776e6cb13638d21e0326f7d665f374d445afa74afa715a35b1
+SIZE (orbit-0.1.431.tar.gz) = 53329
diff --git a/audio/orbit-lv2/pkg-descr b/audio/orbit-lv2/pkg-descr
new file mode 100644
index 000000000000..5df139d9daeb
--- /dev/null
+++ b/audio/orbit-lv2/pkg-descr
@@ -0,0 +1,24 @@
+Several LV2 plugin bundled together:
+* Beatbox
+ Creates MIDI events based on LV2 time position events, e.g. to drive a
+ drum machine. Bars and beats can be disabled/enabled separately.
+* Cargoship
+ Record/Playback of arbitrary LV2 atoms to/from disk. Record all incoming atom
+ messages with sample accuracy and play them back later from disk. Stored atom
+ event data is part of the plugin state and is preserved across instantiations.
+* Click
+ Synthesizes click tracks based on LV2 time position events (bars and beats).
+ Bars and beats can be disabled/enabled separately.
+* Looper
+ Loops arbitrary LV2 atom events on a ping-pong buffer. E.g. loops MIDI, OSC
+ or anything else that can be packed into LV2 atoms with sample accuracy.
+ Needs to be driven by LV2 time position events.
+* Pacemaker
+ Creates LV2 time position events from scratch to drive other plugins.
+* Quantum
+ Quantizes incoming events to whole beats.
+* Subspace
+ Subdivide or multiply incoming time signals by whole fractions, e.g. to speed
+ up time x2, x3, ... or slow it down to x1/2, x1/3, ...
+
+WWW: https://open-music-kontrollers.ch/lv2/orbit/