aboutsummaryrefslogtreecommitdiff
path: root/audio/osd-lyrics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-09-26 08:46:40 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-09-26 08:46:40 +0000
commit16274f4dca5acb1fef245976de41804914ab5872 (patch)
tree28e1b6d19074eb2a56a56dc3af558d6f2a2a0df3 /audio/osd-lyrics
parentd1b672e7dc4a884920e98ace46a255a68c5e9a5d (diff)
downloadports-16274f4dca5acb1fef245976de41804914ab5872.tar.gz
ports-16274f4dca5acb1fef245976de41804914ab5872.zip
Convert to OptionsNG
Notes
Notes: svn path=/head/; revision=304886
Diffstat (limited to 'audio/osd-lyrics')
-rw-r--r--audio/osd-lyrics/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/audio/osd-lyrics/Makefile b/audio/osd-lyrics/Makefile
index 7782f4e2184b..481ba4e31cd4 100644
--- a/audio/osd-lyrics/Makefile
+++ b/audio/osd-lyrics/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: OSD Lyrics
-# Date created: 18 Nov 2011
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= osdlyrics
PORTVERSION= 0.4.3
@@ -32,30 +28,31 @@ USE_SQLITE= yes
INSTALLS_ICONS= yes
PORTDOCS= AUTHORS ChangeLog NEWS README
-OPTIONS= MPD "Enable MPD support" off \
- XMMS2 "Enable XMMS2 support" off \
- AMAROK "Enable Amarok 1.4 support" off
+OPTIONS_DEFINE= DOCS MPD XMMS2 AMAROK
+MPD_DESC= Enable MPD support
+XMMS2_DESC= Enable XMMS2 support
+AMAROK_DESC= Enable Amarok 1.4 support
.include <bsd.port.options.mk>
-.if defined(WITH_MPD)
+.if ${PORT_OPTIONS:MMPD}
LIB_DEPENDS+= mpd:${PORTSDIR}/audio/libmpd
.else
CONFIGURE_ARGS+= --disable-mpd
.endif
-.if defined(WITH_XMMS2)
+.if ${PORT_OPTIONS:MXMMS2}
LIB_DEPENDS+= xmmsclient:${PORTSDIR}/audio/xmms2
.else
CONFIGURE_ARGS+= --disable-xmms2
.endif
-.if defined(WITH_AMAROK)
+.if ${PORT_OPTIONS:MAMAROK}
CONFIGURE_ARGS+= --enable-amarok1
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif