aboutsummaryrefslogtreecommitdiff
path: root/audio/osd-lyrics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-26 14:31:26 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-26 14:31:26 +0000
commit86ede9d6321ab2ad04c43e797b46e61b1268d1be (patch)
treeae2dd29f34810152633676a1be73d67617be4287 /audio/osd-lyrics
parent5563abefa4c0bda598891c6ec8af0f5ce503c0c6 (diff)
downloadports-86ede9d6321ab2ad04c43e797b46e61b1268d1be.tar.gz
ports-86ede9d6321ab2ad04c43e797b46e61b1268d1be.zip
Add an explicit dependency on iconv and pkgconfig
Fix build with newer binutils Use options helpers
Notes
Notes: svn path=/head/; revision=323724
Diffstat (limited to 'audio/osd-lyrics')
-rw-r--r--audio/osd-lyrics/Makefile26
1 files changed, 8 insertions, 18 deletions
diff --git a/audio/osd-lyrics/Makefile b/audio/osd-lyrics/Makefile
index 9ded90e35fa7..fad998fdf494 100644
--- a/audio/osd-lyrics/Makefile
+++ b/audio/osd-lyrics/Makefile
@@ -22,35 +22,25 @@ CONFIGURE_ENV= DATADIRNAME=share
# Cannot enable -Werror yet: Clang does not like the code `printf(_("..."))',
# see this bug for details: http://llvm.org/bugs/show_bug.cgi?id=3814
#CONFIGURE_ARGS= --with-werror
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake iconv pkgconfig
USE_GNOME= gtk20
USE_SQLITE= yes
INSTALLS_ICONS= yes
PORTDOCS= AUTHORS ChangeLog NEWS README
+LDFLAGS= -liconv
OPTIONS_DEFINE= DOCS MPD XMMS2 AMAROK
MPD_DESC= Enable MPD support
XMMS2_DESC= Enable XMMS2 support
AMAROK_DESC= Enable Amarok 1.4 support
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMPD}
-LIB_DEPENDS+= mpd:${PORTSDIR}/audio/libmpd
-.else
-CONFIGURE_ARGS+= --disable-mpd
-.endif
+MPD_LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd
+MPD_CONFIGURE_OFF= --disable-mpd
+XMMS2_LIB_DEPENDS= xmmsclient:${PORTSDIR}/audio/xmms2
+XMMS2_CONFIGURE_OFF= --disable-xmms2
+AMAROK_CONFIGURE_ENABLE= amarok1
-.if ${PORT_OPTIONS:MXMMS2}
-LIB_DEPENDS+= xmmsclient:${PORTSDIR}/audio/xmms2
-.else
-CONFIGURE_ARGS+= --disable-xmms2
-.endif
-
-.if ${PORT_OPTIONS:MAMAROK}
-CONFIGURE_ARGS+= --enable-amarok1
-.endif
+.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}