aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Audio-Ecasound
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-11-21 12:17:40 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-11-21 12:17:40 +0000
commit6aef4f76d67a4371b67583a509d1641bc0b338a5 (patch)
treeea1c8174616a3b634e6bb2c43555e8fb73a71caa /audio/p5-Audio-Ecasound
parentb8d397f62b75b28f382a0e4ccafbe3dfe4581173 (diff)
downloadports-6aef4f76d67a4371b67583a509d1641bc0b338a5.tar.gz
ports-6aef4f76d67a4371b67583a509d1641bc0b338a5.zip
Audio::Ecasound provides perl bindings to the ecasound control
interface of the ecasound program. You can use perl to automate or interact with ecasound so you don't have to turn you back on the adoring masses packed into Wembly Stadium. Ecasound is a software package designed for multitrack audio processing. It can be used for audio playback, recording, format conversions, effects processing, mixing, as a LADSPA plugin host and JACK node. Version >= 2.2.X must be installed to use this package. "SEE ALSO" for more info. WWW: http://search.cpan.org/dist/Audio-Ecasound/
Notes
Notes: svn path=/head/; revision=264867
Diffstat (limited to 'audio/p5-Audio-Ecasound')
-rw-r--r--audio/p5-Audio-Ecasound/Makefile23
-rw-r--r--audio/p5-Audio-Ecasound/distinfo2
-rw-r--r--audio/p5-Audio-Ecasound/files/patch-Makefile.PL11
-rw-r--r--audio/p5-Audio-Ecasound/pkg-descr12
-rw-r--r--audio/p5-Audio-Ecasound/pkg-plist7
5 files changed, 55 insertions, 0 deletions
diff --git a/audio/p5-Audio-Ecasound/Makefile b/audio/p5-Audio-Ecasound/Makefile
new file mode 100644
index 000000000000..5d4ab4fc0312
--- /dev/null
+++ b/audio/p5-Audio-Ecasound/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Audio::Ecasound
+# Date created: 20 Nov 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Audio-Ecasound
+PORTVERSION= 1.01
+CATEGORIES= audio perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for ecasound sampler, recorder, fx-processor
+
+BUILD_DEPENDS= libecasoundc-config:${PORTSDIR}/audio/ecasound
+
+PERL_CONFIGURE= yes
+
+MAN3= Audio::Ecasound.3
+
+.include <bsd.port.mk>
diff --git a/audio/p5-Audio-Ecasound/distinfo b/audio/p5-Audio-Ecasound/distinfo
new file mode 100644
index 000000000000..a76629822c62
--- /dev/null
+++ b/audio/p5-Audio-Ecasound/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Audio-Ecasound-1.01.tar.gz) = 32e6af320d8a9dc04cb5a14152e64f699e07a31f44e78d0cf8f47b469c4f6572
+SIZE (Audio-Ecasound-1.01.tar.gz) = 11770
diff --git a/audio/p5-Audio-Ecasound/files/patch-Makefile.PL b/audio/p5-Audio-Ecasound/files/patch-Makefile.PL
new file mode 100644
index 000000000000..b73dc2dce76a
--- /dev/null
+++ b/audio/p5-Audio-Ecasound/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig 2010-11-21 12:26:33.201477139 +0900
++++ Makefile.PL 2010-11-21 12:26:54.018506858 +0900
+@@ -8,7 +8,7 @@
+ # next two could be from libecasoundc-config --libs --cflags
+ # not for now since want it to install w/o libecasoundc-config
+ LIBS => ['-lecasoundc'],
+- INC => '',
++ INC => "-I\${PREFIX}/include",
+ ABSTRACT_FROM => 'Ecasound.pm',
+ AUTHOR => 'Brad Bowman <eci-perl@bereft.net>',
+ LICENSE => 'artistic_2',
diff --git a/audio/p5-Audio-Ecasound/pkg-descr b/audio/p5-Audio-Ecasound/pkg-descr
new file mode 100644
index 000000000000..68572f5de57c
--- /dev/null
+++ b/audio/p5-Audio-Ecasound/pkg-descr
@@ -0,0 +1,12 @@
+Audio::Ecasound provides perl bindings to the ecasound control
+interface of the ecasound program. You can use perl to automate or
+interact with ecasound so you don't have to turn you back on the
+adoring masses packed into Wembly Stadium.
+
+Ecasound is a software package designed for multitrack audio
+processing. It can be used for audio playback, recording, format
+conversions, effects processing, mixing, as a LADSPA plugin host and
+JACK node. Version >= 2.2.X must be installed to use this
+package. "SEE ALSO" for more info.
+
+WWW: http://search.cpan.org/dist/Audio-Ecasound/
diff --git a/audio/p5-Audio-Ecasound/pkg-plist b/audio/p5-Audio-Ecasound/pkg-plist
new file mode 100644
index 000000000000..e412f08b2e50
--- /dev/null
+++ b/audio/p5-Audio-Ecasound/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Audio/Ecasound.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/Ecasound/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/Ecasound/Ecasound.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/Ecasound/Ecasound.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/Ecasound
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Audio