aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Audio-MPD-Common
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-10-28 16:16:56 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-10-28 16:16:56 +0000
commit59cb55ef97a6076c4aad60d3853dfeb906cb93df (patch)
treec446df2a593d3db7919fc90e1e5254a7ce3e442c /audio/p5-Audio-MPD-Common
parent725847fcf7cc1a0f7adf75b801f0834c413dde96 (diff)
downloadports-59cb55ef97a6076c4aad60d3853dfeb906cb93df.tar.gz
ports-59cb55ef97a6076c4aad60d3853dfeb906cb93df.zip
Add p5-Audio-MPD-Common, a bunch of common helper classes for mpd.
Notes
Notes: svn path=/head/; revision=222164
Diffstat (limited to 'audio/p5-Audio-MPD-Common')
-rw-r--r--audio/p5-Audio-MPD-Common/Makefile32
-rw-r--r--audio/p5-Audio-MPD-Common/distinfo3
-rw-r--r--audio/p5-Audio-MPD-Common/pkg-descr11
-rw-r--r--audio/p5-Audio-MPD-Common/pkg-plist16
4 files changed, 62 insertions, 0 deletions
diff --git a/audio/p5-Audio-MPD-Common/Makefile b/audio/p5-Audio-MPD-Common/Makefile
new file mode 100644
index 000000000000..f980bcbdd008
--- /dev/null
+++ b/audio/p5-Audio-MPD-Common/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Audio-MPD-Common
+# Date created: 28 Oct 2008
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Audio-MPD-Common
+PORTVERSION= 0.1.3
+CATEGORIES= audio perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= A bunch of common helper classes for mpd
+
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Readonly>=0:${PORTSDIR}/devel/p5-Readonly
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Audio::MPD::Common.3 \
+ Audio::MPD::Common::Item.3 \
+ Audio::MPD::Common::Item::Directory.3 \
+ Audio::MPD::Common::Item::Song.3 \
+ Audio::MPD::Common::Item::Playlist.3 \
+ Audio::MPD::Common::Stats.3 \
+ Audio::MPD::Common::Status.3 \
+ Audio::MPD::Common::Time.3
+
+.include <bsd.port.mk>
diff --git a/audio/p5-Audio-MPD-Common/distinfo b/audio/p5-Audio-MPD-Common/distinfo
new file mode 100644
index 000000000000..2405f2fcbce0
--- /dev/null
+++ b/audio/p5-Audio-MPD-Common/distinfo
@@ -0,0 +1,3 @@
+MD5 (Audio-MPD-Common-0.1.3.tar.gz) = 30d319cb5acb5c3e066ccd63c3465549
+SHA256 (Audio-MPD-Common-0.1.3.tar.gz) = 4b78cd573a9bddf1355108cce18560d73d11b1e9fa7313e675997d437bce6b41
+SIZE (Audio-MPD-Common-0.1.3.tar.gz) = 8405
diff --git a/audio/p5-Audio-MPD-Common/pkg-descr b/audio/p5-Audio-MPD-Common/pkg-descr
new file mode 100644
index 000000000000..e09482cccb86
--- /dev/null
+++ b/audio/p5-Audio-MPD-Common/pkg-descr
@@ -0,0 +1,11 @@
+Depending on whether you're using a POE-aware environment or not, people
+wanting to tinker with mpd (Music Player Daemon) will use either
+POE::Component::Client::MPD or Audio::MPD.
+
+But even if the run-cores of those two modules differ completely, they are
+using the exact same common classes to represent the various mpd states and
+information.
+
+Therefore, those common classes have been outsourced to Audio::MPD::Common.
+
+WWW: http://search.cpan.org/dist/Audio-MPD-Common/
diff --git a/audio/p5-Audio-MPD-Common/pkg-plist b/audio/p5-Audio-MPD-Common/pkg-plist
new file mode 100644
index 000000000000..53678c22ed2a
--- /dev/null
+++ b/audio/p5-Audio-MPD-Common/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/MPD/Common/.packlist
+%%SITE_PERL%%/Audio/MPD/Common.pm
+%%SITE_PERL%%/Audio/MPD/Common/Item.pm
+%%SITE_PERL%%/Audio/MPD/Common/Item/Directory.pm
+%%SITE_PERL%%/Audio/MPD/Common/Item/Playlist.pm
+%%SITE_PERL%%/Audio/MPD/Common/Item/Song.pm
+%%SITE_PERL%%/Audio/MPD/Common/Status.pm
+%%SITE_PERL%%/Audio/MPD/Common/Stats.pm
+%%SITE_PERL%%/Audio/MPD/Common/Time.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/MPD/Common
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio/MPD
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Audio
+@dirrmtry %%SITE_PERL%%/Audio/MPD/Common/Item
+@dirrmtry %%SITE_PERL%%/Audio/MPD/Common
+@dirrmtry %%SITE_PERL%%/Audio/MPD
+@dirrmtry %%SITE_PERL%%/Audio