aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Audio-Scrobbler
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-02-01 20:26:56 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-02-01 20:26:56 +0000
commit7ba5634f76f0731d4fe18fc7b4dee568fa042488 (patch)
tree0c6fd390634828e8cf361fa4d1942fe6f9f2aa70 /audio/p5-Audio-Scrobbler
parent65c6c84edffe09bf1be3ced842825d87ca4674c7 (diff)
downloadports-7ba5634f76f0731d4fe18fc7b4dee568fa042488.tar.gz
ports-7ba5634f76f0731d4fe18fc7b4dee568fa042488.zip
Arrrrgh. Use PERL_ARCH properly instead of hardcoding "mach".
While I'm here, mark it as IGNORE'd on Perl versions earlier than 5.6 anyway - we kinda need all the goodies provided by "use bytes" and friends. Reported by: pointyhat via kris Pointy hat to: roam (myself)
Notes
Notes: svn path=/head/; revision=155025
Diffstat (limited to 'audio/p5-Audio-Scrobbler')
-rw-r--r--audio/p5-Audio-Scrobbler/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/audio/p5-Audio-Scrobbler/Makefile b/audio/p5-Audio-Scrobbler/Makefile
index b9dafb75b605..c713b8a6e6e5 100644
--- a/audio/p5-Audio-Scrobbler/Makefile
+++ b/audio/p5-Audio-Scrobbler/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= roam@FreeBSD.org
COMMENT= A Perl interface to Last.fm / AudioScrobbler
BUILD_DEPENDS= ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles \
- ${SITE_PERL}/mach/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/Bundle/LWP.pm:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -25,4 +25,10 @@ PERL_CONFIGURE= yes
MAN1= scrobbler-helper.1
MAN3= Audio::Scrobbler.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= needs at least Perl 5.6 for the UTF-8 handling
+.endif
+
+.include <bsd.port.post.mk>