aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-CDDB
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-03-14 23:02:27 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-03-14 23:02:27 +0000
commitc5958795753f39b8dfaae9b4e71c32ac6cb7f0fb (patch)
treec39552852049703d5bd40ef95b9a9fcc5bc81a03 /audio/p5-CDDB
parent8894f2316ba1421cf6fdabdb8796a43abef7c28c (diff)
downloadports-c5958795753f39b8dfaae9b4e71c32ac6cb7f0fb.tar.gz
ports-c5958795753f39b8dfaae9b4e71c32ac6cb7f0fb.zip
A high-level interface to the Compact Disc Database.
PR: ports/25804 Submitted by: Yar Tikhiy <yar@comp.chem.msu.su>
Notes
Notes: svn path=/head/; revision=39863
Diffstat (limited to 'audio/p5-CDDB')
-rw-r--r--audio/p5-CDDB/Makefile22
-rw-r--r--audio/p5-CDDB/distinfo1
-rw-r--r--audio/p5-CDDB/files/patch-aa42
-rw-r--r--audio/p5-CDDB/pkg-comment1
-rw-r--r--audio/p5-CDDB/pkg-descr21
-rw-r--r--audio/p5-CDDB/pkg-plist3
6 files changed, 90 insertions, 0 deletions
diff --git a/audio/p5-CDDB/Makefile b/audio/p5-CDDB/Makefile
new file mode 100644
index 000000000000..212ed06dabfb
--- /dev/null
+++ b/audio/p5-CDDB/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-CDDB
+# Date created: 11-Mar-2001
+# Whom: Yar Tikhiy <yar@comp.chem.msu.su>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CDDB
+PORTVERSION= 1.03
+CATEGORIES= audio perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=../by-authors/id/R/RC/RCAPUTO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@freebsd.org
+
+PERL_CONFIGURE= yes
+
+MAN3= CDDB.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/audio/p5-CDDB/distinfo b/audio/p5-CDDB/distinfo
new file mode 100644
index 000000000000..1ece673339fe
--- /dev/null
+++ b/audio/p5-CDDB/distinfo
@@ -0,0 +1 @@
+MD5 (CDDB-1.03.tar.gz) = a679c76fc4ce74c04c0c6e22398f399b
diff --git a/audio/p5-CDDB/files/patch-aa b/audio/p5-CDDB/files/patch-aa
new file mode 100644
index 000000000000..65cb6dfdf74d
--- /dev/null
+++ b/audio/p5-CDDB/files/patch-aa
@@ -0,0 +1,42 @@
+--- CDDB.pm.orig Sun Apr 30 06:33:12 2000
++++ CDDB.pm Mon Mar 12 15:11:35 2001
+@@ -15,9 +15,9 @@
+ # list of known cddb servers
+
+ my @cddb_hosts =
+- ( [ 'cddb.cddb.com' => 8880 ],
+- [ 'sj.ca.us.cddb.com' => 8880 ],
+- [ 'sc.ca.us.cddb.com' => 8880 ],
++ ( [ 'freedb.freedb.org' => 8880 ],
++ [ 'ca.freedb.org' => 8880 ],
++ [ 'sk.freedb.org' => 8880 ],
+ );
+
+ #------------------------------------------------------------------------------
+@@ -177,7 +177,7 @@
+ login => $login,
+ libname => 'CDDB.pm',
+ libver => $VERSION,
+- cddbmail => 'cddb-test@submit.cddb.com',
++ cddbmail => 'freedb-submit@freedb.org',
+ debug => $debug,
+ host => $host,
+ port => $port,
+@@ -615,7 +615,7 @@
+ use CDDB;
+
+ ### connect to the CDDB server
+- my $cddb = new CDDB( Host => 'www.cddb.com', # default
++ my $cddb = new CDDB( Host => 'freedb.freedb.org', # default
+ Port => 8880, # default
+ Login => $login_id, # defaults to %ENV's
+ ) or die $!;
+@@ -682,7 +682,7 @@
+ protocol may require several separate connections (sometimes one per
+ query).
+
+-C<new> accepts these parameters: Host (defaults to www.cddb.com), Port
++C<new> accepts these parameters: Host (defaults to freedb.freedb.org), Port
+ (defaults to 8880), Login (defaults to your login ID), and Debug
+ (defaults to boolean false) parameters.
+
diff --git a/audio/p5-CDDB/pkg-comment b/audio/p5-CDDB/pkg-comment
new file mode 100644
index 000000000000..af8d1da83a38
--- /dev/null
+++ b/audio/p5-CDDB/pkg-comment
@@ -0,0 +1 @@
+A high-level interface to the Compact Disc Database
diff --git a/audio/p5-CDDB/pkg-descr b/audio/p5-CDDB/pkg-descr
new file mode 100644
index 000000000000..95dae6bf758d
--- /dev/null
+++ b/audio/p5-CDDB/pkg-descr
@@ -0,0 +1,21 @@
+The CDDB module implements a Perl class for communicating with an
+audio compact disc database through the CDDBP protocol. It allows
+quering the database and submitting new entries to it via e-mail
+(the Mail::Internet and Mail::Header modules are required for
+submitting, but their absence won't affect other functions). Unlike
+its analogs, CDDB.pm doesn't try to read a disc in your CD-ROM by
+itself, but relies on the main program supplying disc data.
+Therefore, it is particularly useful for developing software that
+deals with alternative media, such as MPEG audio files.
+
+*Note*: The original CDDB project (http://www.cddb.com) was aquired
+by some greedy folks that decided to force developers pay license
+fees. Thus they no longer provide service to those who use unlicensed
+client software. So a patch is included in this port that changes
+the default server to that of the freedb.org project
+(http://www.freedb.org).
+
+WWW: http://search.cpan.org/search?module=CDDB
+
+- Yar
+yar@comp.chem.msu.su
diff --git a/audio/p5-CDDB/pkg-plist b/audio/p5-CDDB/pkg-plist
new file mode 100644
index 000000000000..705138ca75c0
--- /dev/null
+++ b/audio/p5-CDDB/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/CDDB.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CDDB/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/CDDB