aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Net-FreeDB
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-07-14 16:09:57 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-07-14 16:09:57 +0000
commit6c4c5bc720b0450441bbc598b8fe02108a0957be (patch)
treea120b1bd6f78c5abfe226d1f0fca48436efac259 /audio/p5-Net-FreeDB
parent00c0ec74641bb67d86f8020ec2731547955ffff2 (diff)
downloadports-6c4c5bc720b0450441bbc598b8fe02108a0957be.tar.gz
ports-6c4c5bc720b0450441bbc598b8fe02108a0957be.zip
- Update to 0.07
- Restrict to Perl 5.6+ due to dependency upon p5-Authen-SASL - Regen 5.00503 patchfile just in case the dependency can be resolved PR: ports/99134 Submitted by: aaron Approved by: maintainer timeout, tobez (implicit)
Notes
Notes: svn path=/head/; revision=167814
Diffstat (limited to 'audio/p5-Net-FreeDB')
-rw-r--r--audio/p5-Net-FreeDB/Makefile15
-rw-r--r--audio/p5-Net-FreeDB/distinfo9
-rw-r--r--audio/p5-Net-FreeDB/files/perl-5005.patch28
3 files changed, 20 insertions, 32 deletions
diff --git a/audio/p5-Net-FreeDB/Makefile b/audio/p5-Net-FreeDB/Makefile
index 0113f2f97059..f966930227f8 100644
--- a/audio/p5-Net-FreeDB/Makefile
+++ b/audio/p5-Net-FreeDB/Makefile
@@ -6,18 +6,12 @@
#
PORTNAME= Net-FreeDB
-PORTVERSION= 0.06
-PORTREVISION= 2
+PORTVERSION= 0.07
CATEGORIES= audio perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Net
+MASTER_SITE_SUBDIR= ../../authors/id/R/RO/ROAM
PKGNAMEPREFIX= p5-
-PATCH_SITES= ${MASTER_SITE_LOCAL} \
- http://people.FreeBSD.org/~roam/ports/patches/net/
-PATCH_SITE_SUBDIR= roam/net
-PATCHFILES= Net-FreeDB-0.06-FreeBSD-2.patch
-
MAINTAINER= roam@FreeBSD.org
COMMENT= Get the CDID of an audio CD and query the FreeDB servers
@@ -31,8 +25,9 @@ MAN3= Net::FreeDB.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-EXTRA_PATCHES+= ${FILESDIR}/perl-5005.patch
+.if ${PERL_LEVEL} < 500600 # inherited by p5-Authen-SASL
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+#EXTRA_PATCHES+= ${FILESDIR}/perl-5005.patch
.endif
.include <bsd.port.post.mk>
diff --git a/audio/p5-Net-FreeDB/distinfo b/audio/p5-Net-FreeDB/distinfo
index ee9cc88b97bb..2629daa524c7 100644
--- a/audio/p5-Net-FreeDB/distinfo
+++ b/audio/p5-Net-FreeDB/distinfo
@@ -1,6 +1,3 @@
-MD5 (Net-FreeDB-0.06.tar.gz) = e36554b1fd80860b61e00162fd0325a8
-SHA256 (Net-FreeDB-0.06.tar.gz) = ba09b6e561101b293ec74b49e74625f77fe32be13b6aa72dc6586d909e4fd600
-SIZE (Net-FreeDB-0.06.tar.gz) = 17516
-MD5 (Net-FreeDB-0.06-FreeBSD-2.patch) = 82cd9fa75154169b9915e302e9699fbd
-SHA256 (Net-FreeDB-0.06-FreeBSD-2.patch) = 9529789b3d87eccbd6678cda74dc18dcf598d45056b9bbfc3497a4dd1396d07e
-SIZE (Net-FreeDB-0.06-FreeBSD-2.patch) = 7625
+MD5 (Net-FreeDB-0.07.tar.gz) = cd345f8d38c736746a5015ae0e290872
+SHA256 (Net-FreeDB-0.07.tar.gz) = ec8d38b57e07e0c989071a0b0697fcbdfcb7df99ab77cc69b7e438ee90eae690
+SIZE (Net-FreeDB-0.07.tar.gz) = 18590
diff --git a/audio/p5-Net-FreeDB/files/perl-5005.patch b/audio/p5-Net-FreeDB/files/perl-5005.patch
index 7920e3d10eaf..97d7123c12cb 100644
--- a/audio/p5-Net-FreeDB/files/perl-5005.patch
+++ b/audio/p5-Net-FreeDB/files/perl-5005.patch
@@ -1,6 +1,5 @@
-diff -urN Net-FreeDB-0.06/FreeDB.pm roam/FreeDB.pm
---- FreeDB.pm Wed Mar 20 22:19:50 2002
-+++ FreeDB.pm Mon Oct 17 13:03:00 2005
+--- FreeDB.pm.orig Tue Jan 3 08:58:51 2006
++++ FreeDB.pm Sun Jun 18 19:50:43 2006
@@ -1,6 +1,6 @@
package Net::FreeDB;
@@ -9,18 +8,17 @@ diff -urN Net-FreeDB-0.06/FreeDB.pm roam/FreeDB.pm
use strict;
use warnings;
use IO::Socket;
-@@ -13,7 +13,9 @@
+@@ -13,7 +13,8 @@
require DynaLoader;
use AutoLoader;
-our @ISA = qw(Exporter DynaLoader Net::Cmd IO::Socket::INET);
+use vars qw/@ISA %EXPORT_TAGS @EXPORT_OK @EXPORT $VERSION $ERROR/;
-+
+@ISA = qw(Exporter DynaLoader Net::Cmd IO::Socket::INET);
# Items to export into callers namespace by default. Note: do not export
# names by default without a very good reason. Use EXPORT_OK instead.
-@@ -22,22 +24,21 @@
+@@ -22,22 +23,21 @@
# This allows declaration use Net::FreeDB ':all';
# If you do not need this, moving things directly into @EXPORT or @EXPORT_OK
# will save memory.
@@ -33,8 +31,8 @@ diff -urN Net-FreeDB-0.06/FreeDB.pm roam/FreeDB.pm
-our @EXPORT = qw();
+@EXPORT = qw();
--our $VERSION = '0.06';
-+$VERSION = '0.06';
+-our $VERSION = '0.07';
++$VERSION = '0.07';
-our $ERROR;
sub AUTOLOAD {
@@ -48,10 +46,9 @@ diff -urN Net-FreeDB-0.06/FreeDB.pm roam/FreeDB.pm
($constname = $AUTOLOAD) =~ s/.*:://;
croak "& not defined" if $constname eq 'constant';
my $val = constant($constname, @_ ? $_[0] : 0);
-diff -urN Net-FreeDB-0.06/FreeDB.xs.linux roam/FreeDB.xs.linux
---- FreeDB.xs.linux Wed Mar 20 22:19:50 2002
-+++ FreeDB.xs.linux Mon Oct 17 12:09:00 2005
-@@ -36,7 +38,8 @@
+--- FreeDB.xs.linux.orig Mon Oct 17 07:11:29 2005
++++ FreeDB.xs.linux Sun Jun 18 19:53:17 2006
+@@ -38,7 +38,8 @@
RETVAL
char*
@@ -61,7 +58,7 @@ diff -urN Net-FreeDB-0.06/FreeDB.xs.linux roam/FreeDB.xs.linux
INIT:
int i;
char id[30];
-@@ -54,7 +57,8 @@
+@@ -56,7 +57,8 @@
RETVAL
SV*
@@ -71,9 +68,8 @@ diff -urN Net-FreeDB-0.06/FreeDB.xs.linux roam/FreeDB.xs.linux
INIT:
int i;
char id[30];
-diff -urN Net-FreeDB-0.06/lib/discid.h roam/lib/discid.h
---- lib/discid.h Mon Oct 17 13:05:09 2005
-+++ lib/discid.h Mon Oct 17 12:00:02 2005
+--- lib/discid.h.orig Wed Sep 28 08:45:55 2005
++++ lib/discid.h Sun Jun 18 19:54:13 2006
@@ -39,6 +39,7 @@
#ifdef __FreeBSD__