aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Net-FreeDB
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-09-29 13:17:26 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-09-29 13:17:26 +0000
commit76a628b6c705cfdd12b600fe47a2c387cfd15da1 (patch)
tree5ef88bfc6b43029209a760f0901b9e1ae5104ce8 /audio/p5-Net-FreeDB
parent1400e9bac50fb0ea80a45d256e8a9f33dfa24ddb (diff)
downloadports-76a628b6c705cfdd12b600fe47a2c387cfd15da1.tar.gz
ports-76a628b6c705cfdd12b600fe47a2c387cfd15da1.zip
Update to Net::FreeDB 0.08 - a fully official release this time, after
David Shultz kindly added me to PAUSE as a module co-maintainer. Since this port depends on File::Temp now, drop all vestiges of support for Perl 5.005.
Notes
Notes: svn path=/head/; revision=174109
Diffstat (limited to 'audio/p5-Net-FreeDB')
-rw-r--r--audio/p5-Net-FreeDB/Makefile9
-rw-r--r--audio/p5-Net-FreeDB/distinfo6
-rw-r--r--audio/p5-Net-FreeDB/files/perl-5005.patch80
3 files changed, 8 insertions, 87 deletions
diff --git a/audio/p5-Net-FreeDB/Makefile b/audio/p5-Net-FreeDB/Makefile
index f966930227f8..4e5de60dfe31 100644
--- a/audio/p5-Net-FreeDB/Makefile
+++ b/audio/p5-Net-FreeDB/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net-FreeDB
-PORTVERSION= 0.07
+PORTVERSION= 0.08
CATEGORIES= audio perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/R/RO/ROAM
@@ -16,7 +16,8 @@ MAINTAINER= roam@FreeBSD.org
COMMENT= Get the CDID of an audio CD and query the FreeDB servers
BUILD_DEPENDS= ${SITE_PERL}/CDDB/File.pm:${PORTSDIR}/audio/p5-CDDB-File \
- ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
+ ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -25,9 +26,9 @@ MAN3= Net::FreeDB.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600 # inherited by p5-Authen-SASL
+# devel/p5-File-Temp only works on Perl 5.6 or higher.
+.if ${PERL_LEVEL} < 500600
IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-#EXTRA_PATCHES+= ${FILESDIR}/perl-5005.patch
.endif
.include <bsd.port.post.mk>
diff --git a/audio/p5-Net-FreeDB/distinfo b/audio/p5-Net-FreeDB/distinfo
index 2629daa524c7..ce50ec7a14f3 100644
--- a/audio/p5-Net-FreeDB/distinfo
+++ b/audio/p5-Net-FreeDB/distinfo
@@ -1,3 +1,3 @@
-MD5 (Net-FreeDB-0.07.tar.gz) = cd345f8d38c736746a5015ae0e290872
-SHA256 (Net-FreeDB-0.07.tar.gz) = ec8d38b57e07e0c989071a0b0697fcbdfcb7df99ab77cc69b7e438ee90eae690
-SIZE (Net-FreeDB-0.07.tar.gz) = 18590
+MD5 (Net-FreeDB-0.08.tar.gz) = 8307bb8127518f7afaa2487c0a9adc23
+SHA256 (Net-FreeDB-0.08.tar.gz) = f9774b85cd8edae72d3f90dcb2efb78d4fa759b0008e0c90e1c0254bec5c86b6
+SIZE (Net-FreeDB-0.08.tar.gz) = 19210
diff --git a/audio/p5-Net-FreeDB/files/perl-5005.patch b/audio/p5-Net-FreeDB/files/perl-5005.patch
deleted file mode 100644
index 97d7123c12cb..000000000000
--- a/audio/p5-Net-FreeDB/files/perl-5005.patch
+++ /dev/null
@@ -1,80 +0,0 @@
---- FreeDB.pm.orig Tue Jan 3 08:58:51 2006
-+++ FreeDB.pm Sun Jun 18 19:50:43 2006
-@@ -1,6 +1,6 @@
- package Net::FreeDB;
-
--use 5.006;
-+use 5.00503;
- use strict;
- use warnings;
- use IO::Socket;
-@@ -13,7 +13,8 @@
- require DynaLoader;
- use AutoLoader;
-
--our @ISA = qw(Exporter DynaLoader Net::Cmd IO::Socket::INET);
-+use vars qw/@ISA %EXPORT_TAGS @EXPORT_OK @EXPORT $VERSION $ERROR/;
-+@ISA = qw(Exporter DynaLoader Net::Cmd IO::Socket::INET);
-
- # Items to export into callers namespace by default. Note: do not export
- # names by default without a very good reason. Use EXPORT_OK instead.
-@@ -22,22 +23,21 @@
- # This allows declaration use Net::FreeDB ':all';
- # If you do not need this, moving things directly into @EXPORT or @EXPORT_OK
- # will save memory.
--our %EXPORT_TAGS = ( 'all' => [ qw() ] );
-+%EXPORT_TAGS = ( 'all' => [ qw() ] );
-
--our @EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
-+@EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
-
--our @EXPORT = qw();
-+@EXPORT = qw();
-
--our $VERSION = '0.07';
-+$VERSION = '0.07';
-
--our $ERROR;
- sub AUTOLOAD {
- # This AUTOLOAD is used to 'autoload' constants from the constant()
- # XS function. If a constant is not found then control is passed
- # to the AUTOLOAD in AutoLoader.
-
- my $constname;
-- our $AUTOLOAD;
-+ use vars qw/$AUTOLOAD/;
- ($constname = $AUTOLOAD) =~ s/.*:://;
- croak "& not defined" if $constname eq 'constant';
- my $val = constant($constname, @_ ? $_[0] : 0);
---- FreeDB.xs.linux.orig Mon Oct 17 07:11:29 2005
-+++ FreeDB.xs.linux Sun Jun 18 19:53:17 2006
-@@ -38,7 +38,8 @@
- RETVAL
-
- char*
--discid(char* dev)
-+discid(dev)
-+ char *dev;
- INIT:
- int i;
- char id[30];
-@@ -56,7 +57,8 @@
- RETVAL
-
- SV*
--discinfo(char* dev)
-+discinfo(dev)
-+ char *dev;
- INIT:
- int i;
- char id[30];
---- lib/discid.h.orig Wed Sep 28 08:45:55 2005
-+++ lib/discid.h Sun Jun 18 19:54:13 2006
-@@ -39,6 +39,7 @@
-
- #ifdef __FreeBSD__
- #include <sys/cdio.h>
-+#include <sys/fcntl.h>
- #include "freebsd.h"
- #endif // __FreeBSD__
-