aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Shout/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 07:50:25 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 07:50:25 +0000
commit6b43aa6217e7f8936b436a78af480c250967da5e (patch)
tree32e1f31fca1019b590943fc7f96e7cdd9e76a725 /audio/p5-Shout/Makefile
parentccc0ead913625dd0af6158679d7dffde4804aac3 (diff)
downloadports-6b43aa6217e7f8936b436a78af480c250967da5e.tar.gz
ports-6b43aa6217e7f8936b436a78af480c250967da5e.zip
Notes
Diffstat (limited to 'audio/p5-Shout/Makefile')
-rw-r--r--audio/p5-Shout/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/audio/p5-Shout/Makefile b/audio/p5-Shout/Makefile
index b4c57f598722..3fad43f1a693 100644
--- a/audio/p5-Shout/Makefile
+++ b/audio/p5-Shout/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= Shout
-PORTVERSION= 0.99
+PORTVERSION= 1.0
CATEGORIES= audio perl5
MASTER_SITES= http://developer.icecast.org/libshout/releases/
PKGNAMEPREFIX= p5-
MAINTAINER= leo@florida.sarang.net
-LIB_DEPENDS= shout.1:${PORTSDIR}/audio/libshout
+LIB_DEPENDS= shout.2:${PORTSDIR}/audio/libshout
PERL_CONFIGURE= yes
@@ -21,6 +21,14 @@ MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Shout.3
pre-configure:
- @(cd ${WRKSRC} && ${RM} example.pl example2.pl)
+ ${MKDIR} ${WRKSRC}/examples
+ ${MV} ${WRKSRC}/example.pl ${WRKSRC}/example2.pl ${WRKSRC}/examples
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* \
+ ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+.endif
.include <bsd.port.mk>