aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Shout
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /audio/p5-Shout
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'audio/p5-Shout')
-rw-r--r--audio/p5-Shout/Makefile4
-rw-r--r--audio/p5-Shout/pkg-plist11
2 files changed, 7 insertions, 8 deletions
diff --git a/audio/p5-Shout/Makefile b/audio/p5-Shout/Makefile
index 346648e8e752..74a4bcdd7f10 100644
--- a/audio/p5-Shout/Makefile
+++ b/audio/p5-Shout/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Shout
PORTVERSION= 2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio perl5
MASTER_SITES= http://downloads.us.xiph.org/releases/libshout/
PKGNAMEPREFIX= p5-
@@ -30,7 +30,7 @@ post-configure:
OPTIONS_DEFINE= DOCS
post-install:
- ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Shout/Shout.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Shout/Shout.so
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_SCRIPT} ${WRKSRC}/example*.pl ${STAGEDIR}${DOCSDIR}
diff --git a/audio/p5-Shout/pkg-plist b/audio/p5-Shout/pkg-plist
index 48048c513c6d..9a6c4c2ec3a6 100644
--- a/audio/p5-Shout/pkg-plist
+++ b/audio/p5-Shout/pkg-plist
@@ -1,9 +1,8 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/Shout.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Shout/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Shout/Shout.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Shout/autosplit.ix
-%%SITE_PERL%%/%%PERL_ARCH%%/example.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/example2.pl
+%%SITE_ARCH%%/Shout.pm
+%%SITE_ARCH%%/auto/Shout/Shout.so
+%%SITE_ARCH%%/auto/Shout/autosplit.ix
+%%SITE_ARCH%%/example.pl
+%%SITE_ARCH%%/example2.pl
%%PERL5_MAN3%%/Shout.3.gz
%%PORTDOCS%%%%DOCSDIR%%/example.pl
%%PORTDOCS%%%%DOCSDIR%%/example2.pl