aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-libvorbis
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-07-31 16:48:55 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-07-31 16:48:55 +0000
commitbcbd724ac4fd70f5b89518710e29068634d2fc1f (patch)
tree4389517ced3e75378336e47fd01fdb638d7671b1 /audio/p5-libvorbis
parent08d42db8f0a3832a619e4491d42eb6aa32b8f1e3 (diff)
downloadports-bcbd724ac4fd70f5b89518710e29068634d2fc1f.tar.gz
ports-bcbd724ac4fd70f5b89518710e29068634d2fc1f.zip
Import libvorbis-perl 0.04.
This is an object-oriented interface to the Ogg Vorbis libvorbisfile convenience library. PR: 41160 Submitted by: Dominic Mitchell <dom@happygiraffe.net>
Notes
Notes: svn path=/head/; revision=63807
Diffstat (limited to 'audio/p5-libvorbis')
-rw-r--r--audio/p5-libvorbis/Makefile33
-rw-r--r--audio/p5-libvorbis/distinfo1
-rw-r--r--audio/p5-libvorbis/files/patch-Makefile.PL16
-rw-r--r--audio/p5-libvorbis/pkg-comment1
-rw-r--r--audio/p5-libvorbis/pkg-descr4
-rw-r--r--audio/p5-libvorbis/pkg-plist9
6 files changed, 64 insertions, 0 deletions
diff --git a/audio/p5-libvorbis/Makefile b/audio/p5-libvorbis/Makefile
new file mode 100644
index 000000000000..b7f923d79c36
--- /dev/null
+++ b/audio/p5-libvorbis/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-libvorbis
+# Date created: 30 Jul 2002
+# Whom: Dominic Mitchell <dom@happygiraffe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libvorbis
+PORTVERSION= 0.04
+CATEGORIES= audio perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=../by-authors/id/F/FO/FOOF
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-perl-${PORTVERSION}
+
+MAINTAINER= dom@happygiraffe.net
+
+LIB_DEPENDS= vorbis.2:${PORTSDIR}/audio/libvorbis
+
+USE_REINPLACE= yes
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Ogg::Vorbis.3
+
+post-extract:
+ @${RM} -rf ${WRKSRC}/blib ${WRKSRC}/pm_to_blib
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/audio/p5-libvorbis/distinfo b/audio/p5-libvorbis/distinfo
new file mode 100644
index 000000000000..054616dcf077
--- /dev/null
+++ b/audio/p5-libvorbis/distinfo
@@ -0,0 +1 @@
+MD5 (libvorbis-perl-0.04.tar.gz) = 764e0ad14ce0a1ea9f7ae1e05f71ffed
diff --git a/audio/p5-libvorbis/files/patch-Makefile.PL b/audio/p5-libvorbis/files/patch-Makefile.PL
new file mode 100644
index 000000000000..84cd0171d79c
--- /dev/null
+++ b/audio/p5-libvorbis/files/patch-Makefile.PL
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- Makefile.PL.orig Mon Oct 23 08:53:08 2000
++++ Makefile.PL Wed Jul 31 16:09:47 2002
+@@ -4,8 +4,7 @@
+ WriteMakefile(
+ 'NAME' => 'Ogg::Vorbis',
+ 'VERSION_FROM' => 'Vorbis.pm',
+- 'LIBS' => ['-logg -lvorbis -lvorbisfile'],
++ 'LIBS' => ['-L%%PREFIX%%/lib -logg -lvorbis -lvorbisfile'],
+ 'DEFINE' => '',
+- 'INC' => '-I/usr/local/include/vorbis',
+- 'EXE_FILES' => ['pogg'],
++ 'INC' => '-I%%PREFIX%%/include',
+ );
diff --git a/audio/p5-libvorbis/pkg-comment b/audio/p5-libvorbis/pkg-comment
new file mode 100644
index 000000000000..b7f7726debec
--- /dev/null
+++ b/audio/p5-libvorbis/pkg-comment
@@ -0,0 +1 @@
+Perl extension for Ogg Vorbis streams
diff --git a/audio/p5-libvorbis/pkg-descr b/audio/p5-libvorbis/pkg-descr
new file mode 100644
index 000000000000..a8c1afb103a4
--- /dev/null
+++ b/audio/p5-libvorbis/pkg-descr
@@ -0,0 +1,4 @@
+This is an object-oriented interface to the Ogg Vorbis
+libvorbisfile convenience library.
+
+WWW: http://synthcode.com/code/vorbis
diff --git a/audio/p5-libvorbis/pkg-plist b/audio/p5-libvorbis/pkg-plist
new file mode 100644
index 000000000000..edb91b517881
--- /dev/null
+++ b/audio/p5-libvorbis/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Ogg/Vorbis.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Ogg/Vorbis/Vorbis.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Ogg/Vorbis/Vorbis.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Ogg/Vorbis/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Ogg/Vorbis/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Ogg
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Ogg/Vorbis
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Ogg