aboutsummaryrefslogtreecommitdiff
path: root/audio/pacpl
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-27 14:14:14 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-27 14:14:14 +0000
commit5c7f0ac953e3a2ded56360b098b2a46743a7140b (patch)
treea2aa9e4854d8e39f838377e721560e72b7b79cc9 /audio/pacpl
parentad24eb92650a7fe15fa59c5a7fad21c06540ea8f (diff)
downloadports-5c7f0ac953e3a2ded56360b098b2a46743a7140b.tar.gz
ports-5c7f0ac953e3a2ded56360b098b2a46743a7140b.zip
Update to 5.0.1. Fix numerous spelling mistakes in the names of OPTIONS and
PORT_OPTIONS:Mxyz checks that rendered many OPTIONS useless. That said, most of the OPTIONS just bring in dependencies and don't do anything to the port itself, so the port definitely still needs work. Hopefully this should also fix the scattered build failures.
Notes
Notes: svn path=/head/; revision=363070
Diffstat (limited to 'audio/pacpl')
-rw-r--r--audio/pacpl/Makefile219
-rw-r--r--audio/pacpl/distinfo4
-rw-r--r--audio/pacpl/files/patch-pacpl101
-rw-r--r--audio/pacpl/pkg-plist34
4 files changed, 62 insertions, 296 deletions
diff --git a/audio/pacpl/Makefile b/audio/pacpl/Makefile
index 04004493bd51..13d5cb7251ca 100644
--- a/audio/pacpl/Makefile
+++ b/audio/pacpl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pacpl
-PORTVERSION= 4.0.5
+PORTVERSION= 5.0.1
PORTREVISION= 9
CATEGORIES= audio
MASTER_SITES= SF
@@ -13,14 +13,12 @@ COMMENT= Perl Audio Converter
USES= shebangfix perl5
ONLY_FOR_ARCHS= i386 amd64
NO_BUILD= yes
-BUILD_DEPENDS= p5-Switch>0:${PORTSDIR}/lang/p5-Switch
NO_ARCH= yes
OPTIONS_DEFINE= CDPARANOIA CDDB FAAC FAAD FFMPEG FLAC FLACTAG \
LAME LAUDIO SNDFILE LPAC APE APETAG MP3TAG MP4TAG \
- MPP MPLAYER OPTIMFROG VORBIS VORBISTAG SHORTEN \
- SOX SPEEX TOOLAME TTA WAVPACK WMATAG KDE4 AMAROK NORELANGS \
- DOCS
+ MPPTAG MPLAYER NLS OPTIMFROG VORBIS VORBISTAG SHORTEN \
+ SOX SPEEX TOOLAME TTA WAVPACK WMATAG KDE4 DOCS
OPTIONS_DEFAULT= CDPARANOIA CDDB FAAD FFMPEG FLAC FLACTAG MP3TAG \
VORBIS VORBISTAG
@@ -28,7 +26,8 @@ OPTIONS_DEFAULT= CDPARANOIA CDDB FAAD FFMPEG FLAC FLACTAG MP3TAG \
OPTIONS_DEFAULT= LAME FAAC
.endif
-AMAROK_DESC= Enable Amarok integration (BROKEN)
+OPTIONS_SUB= yes
+
APETAG_DESC= Enable Monkey's tagging support
FLACTAG_DESC= Enable FLAC tagging support
KDE4_DESC= Enable Konqueror/Dolphin integration
@@ -48,194 +47,64 @@ WAVPACK_DESC= Enable wavpack support
WMATAG_DESC= Enable WMA tagging support
MORELANGS_DESC= Enable Additional language support
-PACPL_PO= en_US.po
-
-SHEBANG_FILES= pacpl plugins/amarok/pacx
+SHEBANG_FILES= pacpl
+
+APE_RUN_DEPENDS= mac:${PORTSDIR}/audio/mac
+APETAG_RUN_DEPENDS= p5-Audio-Musepack>0:${PORTSDIR}/audio/p5-Audio-Musepack
+CDDB_RUN_DEPENDS= p5-CDDB_get>0:${PORTSDIR}/audio/p5-CDDB_get
+CDPARANOIA_RUN_DEPENDS= cdparanoia:${PORTSDIR}/audio/cdparanoia
+FAAC_RUN_DEPENDS= faac:${PORTSDIR}/audio/faac
+FAAD_RUN_DEPENDS= faad:${PORTSDIR}/audio/faad
+FFMPEG_RUN_DEPENDS= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
+FLAC_RUN_DEPENDS= flac:${PORTSDIR}/audio/flac
+FLACTAG_RUN_DEPENDS= p5-Audio-FLAC-Header>0:${PORTSDIR}/audio/p5-Audio-FLAC-Header
+KDE4_USE= KDE4=kdehier
+LAME_RUN_DEPENDS= lame:${PORTSDIR}/audio/lame
+LAUDIO_RUN_DEPENDS= laudio:${PORTSDIR}/audio/linux-laudio
+SNDFILE_RUN_DEPENDS= sndfile-convert:${PORTSDIR}/audio/libsndfile
+LPAC_RUN_DEPENDS= lpac:${PORTSDIR}/audio/lpac
+MPPTAG_RUN_DEPENDS= p5-Audio-Musepack>0:${PORTSDIR}/audio/p5-Audio-Musepack
+MP3TAG_RUN_DEPENDS= p5-MP3-Tag>0:${PORTSDIR}/audio/p5-MP3-Tag
+MP4TAG_RUN_DEPENDS= p5-MP4-Info>0:${PORTSDIR}/multimedia/p5-MP4-Info
+MPLAYER_RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
+MPPPACK_RUN_DEPENDS= mppenc:${PORTSDIR}/audio/musepack
+OPTIMFROG_RUN_DEPENDS= ofr:${PORTSDIR}/audio/optimfrog
+VORBIS_RUN_DEPENDS= oggenc:${PORTSDIR}/audio/vorbis-tools
+VORBISTAG_RUN_DEPENDS= p5-Ogg-Vorbis-Header>0:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header
+SHORTEN_RUN_DEPENDS= shorten:${PORTSDIR}/audio/shorten
+SOX_RUN_DEPENDS= sox:${PORTSDIR}/audio/sox
+SPEEX_RUN_DEPENDS= speexenc:${PORTSDIR}/audio/speex
+TOOLAME_RUN_DEPENDS= toolame:${PORTSDIR}/audio/toolame
+TTA_RUN_DEPENDS= ttaenc:${PORTSDIR}/audio/tta
+WAVPACK_RUN_DEPENDS= wavpack:${PORTSDIR}/audio/wavpack
+WMATAG_RUN_DEPENDS= p5-Audio-WMA>0:${PORTSDIR}/audio/p5-Audio-WMA
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MKDE4}
-USE_KDE4= kdehier
-PLIST_SUB+= KDE4SERVICEMENU="" KDE4_PREFIX="${KDE4_PREFIX}"
-.else
-PLIST_SUB+= KDE4SERVICEMENU="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MAMAROK}
-BROKEN= Amarok support temporarily broken in 4.05+
-RUN_DEPENDS+= amarok:${PORTSDIR}/audio/amarok
-PLIST_SUB+= AMAROK=""
-.else
-PLIST_SUB+= AMAROK="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MCDDB}
-RUN_DEPENDS+= p5-CDDB_get>0:${PORTSDIR}/audio/p5-CDDB_get
-.endif
-
-.if ${PORT_OPTIONS:MCDPARANOIA}
-RUN_DEPENDS+= cdparanoia:${PORTSDIR}/audio/cdparanoia
-.endif
-
-.if ${PORT_OPTIONS:MFAAC}
-RUN_DEPENDS+= faac:${PORTSDIR}/audio/faac
-.endif
-
-.if ${PORT_OPTIONS:MFAAD}
-RUN_DEPENDS+= faad:${PORTSDIR}/audio/faad
-.endif
-
-.if ${PORT_OPTIONS:MFFMPEG}
-RUN_DEPENDS+= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
-.endif
-
-.if ${PORT_OPTIONS:MFLAC}
-RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
-.endif
-
-.if ${PORT_OPTIONS:MFLACTAG}
-RUN_DEPENDS+= p5-Audio-FLAC-Header>0:${PORTSDIR}/audio/p5-Audio-FLAC-Header
-.endif
-
-.if ${PORT_OPTIONS:MLAME}
-RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
-.endif
-
-.if ${PORT_OPTIONS:MLAUDIO}
-RUN_DEPENDS+= laudio:${PORTSDIR}/audio/linux-laudio
-.endif
-
-.if ${PORT_OPTIONS:MSNDFILE}
-RUN_DEPENDS+= sndfile-convert:${PORTSDIR}/audio/libsndfile
-.endif
-
-.if ${PORT_OPTIONS:MLPAC}
-RUN_DEPENDS+= lpac:${PORTSDIR}/audio/lpac
-.endif
-
-.if ${PORT_OPTIONS:MAPE}
-RUN_DEPENDS+= mac:${PORTSDIR}/audio/mac
-.endif
-
-.if ${PORT_OPTIONS:MMPPTAG} || ${PORT_OPTIONS:MAPETAG}
-RUN_DEPENDS+= p5-Audio-Musepack>0:${PORTSDIR}/audio/p5-Audio-Musepack
-.endif
-
-.if ${PORT_OPTIONS:MMP3TAG}
-RUN_DEPENDS+= p5-MP3-Tag>0:${PORTSDIR}/audio/p5-MP3-Tag
-.endif
-
-.if ${PORT_OPTIONS:MMP4TAG}
-RUN_DEPENDS+= p5-MP4-Info>0:${PORTSDIR}/multimedia/p5-MP4-Info
-.endif
-
-.if ${PORT_OPTIONS:MMPLAYER}
-RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+PLIST_SUB+= KDE4_PREFIX="${KDE4_PREFIX}"
.endif
-.if ${PORT_OPTIONS:MMPPPACK}
-RUN_DEPENDS+= mppenc:${PORTSDIR}/audio/musepack
-.endif
-
-.if ${PORT_OPTIONS:MOPTIMFROG}
-RUN_DEPENDS+= ofr:${PORTSDIR}/audio/optimfrog
-.endif
-
-.if ${PORT_OPTIONS:MVORBISVORBIS}
-RUN_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
-.endif
-
-.if ${PORT_OPTIONS:MVORBISTAG}
-RUN_DEPENDS+= p5-Ogg-Vorbis-Header>0:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header
-.endif
-
-.if ${PORT_OPTIONS:MSHORTEN}
-RUN_DEPENDS+= shorten:${PORTSDIR}/audio/shorten
-.endif
-
-.if ${PORT_OPTIONS:MSOX}
-RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox
-.endif
-
-.if ${PORT_OPTIONS:MSPEEX}
-RUN_DEPENDS+= speexenc:${PORTSDIR}/audio/speex
-.endif
-
-.if ${PORT_OPTIONS:MTOOLAME}
-RUN_DEPENDS+= toolame:${PORTSDIR}/audio/toolame
-.endif
-
-.if ${PORT_OPTIONS:MTTA}
-RUN_DEPENDS+= ttaenc:${PORTSDIR}/audio/tta
-.endif
-
-.if ${PORT_OPTIONS:MWAVPACK}
-RUN_DEPENDS+= wavpack:${PORTSDIR}/audio/wavpack
-.endif
-
-.if ${PORT_OPTIONS:MWMATAG}
-RUN_DEPENDS+= p5-Audio-WMA>0:${PORTSDIR}/audio/p5-Audio-WMA
-.endif
-
-.if ${PORT_OPTIONS:MMORELANGS}
-PACPL_PO+= ca.po de.po es.po et.po fr_FR.po it_IT.po nl_NL.po pl.po pt.po ro.po ru_RU.po tr.po zh_CN.po
-PLIST_SUB+= ADDITIONAL_LANGS=""
-.else
-PLIST_SUB+= ADDITIONAL_LANGS="@comment "
-.endif
-
-post-extract:
-
- @${ECHO_MSG} ""
- @${ECHO_MSG} " * * * * * * * * * W A R N I N G * * * * * * * * * * * * * "
- @${ECHO_MSG} ""
- @${ECHO_MSG} "WARNING: Integration options with Amarok, KDE4 Dolphin and"
- @${ECHO_MSG} "Konqueror now pull in their respective ports!"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "The port now provides the option to select codecs, CD"
- @${ECHO_MSG} "burning, CDDB and tagging modules individually so you don't"
- @${ECHO_MSG} "have to install all by default. You will still be offered"
- @${ECHO_MSG} "the ability to convert to and from these formats in the"
- @${ECHO_MSG} "pacpl options even if the codec is not installed."
- @${ECHO_MSG} ""
- @${ECHO_MSG} "CTRL-C now if you'd like to reconfigure, read the Changelog,"
- @${ECHO_MSG} "or README:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " ${WRKSRC}/ChangeLog"
- @${ECHO_MSG} " ${WRKSRC}/README"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " * * * * * * * * * * * * * * * * * * * * * * * * * * * * * "
- @${ECHO_MSG} ""
- @sleep 5
-
post-patch:
@${REINPLACE_CMD} -e 's@/etc/pacpl@${PREFIX}/etc/pacpl@; \
s@/usr/share/pacpl@${DATADIR}@' ${WRKSRC}/pacpl ${WRKSRC}/pacpl.conf
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/pacpl ${STAGEDIR}${PREFIX}/bin/
- ${MKDIR} ${STAGEDIR}${PREFIX}/etc/pacpl/modules/
- ${MKDIR} ${STAGEDIR}${DATADIR}/locale/
+ ${INSTALL_SCRIPT} ${WRKSRC}/pacpl ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/pacpl/modules
+ @${MKDIR} ${STAGEDIR}${DATADIR}/locale
${INSTALL_DATA} ${WRKSRC}/pacpl.conf ${STAGEDIR}${PREFIX}/etc/pacpl/pacpl.conf.sample
${INSTALL_DATA} ${WRKSRC}/codecs.conf ${STAGEDIR}${PREFIX}/etc/pacpl/codecs.conf.sample
${INSTALL_DATA} ${WRKSRC}/extra/sample.m ${STAGEDIR}${PREFIX}/etc/pacpl/modules/sample.m
-.for po in ${PACPL_PO}
- ${INSTALL_DATA} ${WRKSRC}/po/${po} ${STAGEDIR}${DATADIR}/locale
-.endfor
+ ${INSTALL_DATA} ${WRKSRC}/po/* ${STAGEDIR}${DATADIR}/locale
@pod2man ${WRKSRC}/pacpl ${WRKSRC}/pacpl.1
- ${INSTALL_MAN} ${WRKSRC}/pacpl.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/pacpl.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.if ${PORT_OPTIONS:MKDE4}
- ${INSTALL_DATA} ${WRKSRC}/plugins/konqueror/pacpl.desktop ${STAGEDIR}${KDE4_PREFIX}/share/kde4/services/ServiceMenus
-.endif
-
-.if ${PORT_OPTIONS:MAMAROK}
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/apps/amarok/scripts/transcoding_pacx
- ${INSTALL_DATA} ${WRKSRC}/plugins/amarok/pacx ${STAGEDIR}${PREFIX}/share/apps/amarok/scripts/transcoding_pacx/transcoding_pacx.pl
- ${PERL} -e 'print qq(name = Pacx\ntype = transcode)' > ${STAGEDIR}${PREFIX}/share/apps/amarok/scripts/transcoding_pacx/transcoding_pacx.spec
+ ${INSTALL_DATA} ${WRKSRC}/plugins/kde/pacpl.desktop ${STAGEDIR}${KDE4_PREFIX}/share/kde4/services/ServiceMenus
.endif
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/extra/README.module ${WRKSRC}/ChangeLog ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
post-install:
diff --git a/audio/pacpl/distinfo b/audio/pacpl/distinfo
index 61405922ce8d..d0c10f4d7bf0 100644
--- a/audio/pacpl/distinfo
+++ b/audio/pacpl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pacpl-4.0.5.tar.gz) = e6b3ff88acde0bdd7cb4469064afd58cce7fd6463b615713ff36caadbc668de7
-SIZE (pacpl-4.0.5.tar.gz) = 110384
+SHA256 (pacpl-5.0.1.tar.gz) = 52d4373d76ba217293cd7a4d9513b0167f44281bebfe1d82b531fbf7e0828a65
+SIZE (pacpl-5.0.1.tar.gz) = 144849
diff --git a/audio/pacpl/files/patch-pacpl b/audio/pacpl/files/patch-pacpl
deleted file mode 100644
index b9a84870f154..000000000000
--- a/audio/pacpl/files/patch-pacpl
+++ /dev/null
@@ -1,101 +0,0 @@
---- pacpl.orig 2008-08-16 21:31:57.000000000 -0600
-+++ pacpl 2009-02-15 09:21:16.000000000 -0700
-@@ -25,18 +25,6 @@
- use File::Find;
- use File::Spec::Functions qw(rel2abs);
-
--# Tagging modules
--use Ogg::Vorbis::Header;
--use MP3::Tag;
--use Audio::FLAC::Header;
--use MP4::Info;
--use Audio::WMA;
--use Audio::Musepack;
--use Audio::APETags;
--
--# CDDB module
--use CDDB_get qw(get_cddb);
--
- # non-encoder/decoder related options
- my
- (
-@@ -202,8 +190,8 @@
-
- # load po file and store in %lang hash
- sub load_lang {
--
-- my $po = "$po_dir/$ENV{LANG}.po";
-+ my $lang = $ENV{LANG} || 'en_US';
-+ my $po = "$po_dir/$lang.po";
- $po =~ s/\.UTF-8//i if $po =~ /UTF-8/i;
- $po =~ s/\.utf8//i if $po =~ /utf8/i;
- $po =~ s/_\w+// if not -e $po;
-@@ -1541,6 +1529,17 @@
- # load codecs.conf file
- load_codecs() if -e $codecs_conf;
-
-+# Now that %run is populated, verify tagging modules
-+for my $format (keys %run){
-+ if(defined $run{$format}{TAGS}{MODULE}){
-+ eval "require $run{$format}{TAGS}{MODULE}";
-+ @{$run{$format}{TAGS}}{qw(READ WRITE)} = (0,0) if $@;
-+ }
-+}
-+
-+eval "require CDDB_get";
-+$nocddb = 1 if $@;
-+
- my $out_name = $outfile;
- my $out_dir = $outdir;
-
-@@ -2177,7 +2176,7 @@
- }
-
- case 'wma' {
-- my $wma_tag = Audio::WMA->new($in_file)->tags();
-+ my $wma_tag = $tag_module->new($in_file)->tags();
-
- $tag_name{title} = $wma_tag->{TITLE} if $wma_tag->{TITLE};
- $tag_name{track} = $wma_tag->{TRACKNUMBER} if $wma_tag->{TRACKNUMBER};
-@@ -2198,12 +2197,13 @@
- sub write_tags {
-
- my ($out_file, $out_format) = @_;
-+ my $tag_module = $run{$out_format}{TAGS}{MODULE};
- my $tag_m;
-
- switch ($out_format) {
-
- case 'mp3' {
-- $tag_m = MP3::Tag->new("$out_file");
-+ $tag_m = $tag_module->new("$out_file");
-
- # ID3v2 Tags
- unless(exists($tag_m->{ID3v2})) { $tag_m->new_tag("ID3v2"); }
-@@ -2236,7 +2236,7 @@
- }
-
- case 'ogg' {
-- $tag_m = Ogg::Vorbis::Header->new("$out_file");
-+ $tag_m = $tag_module->new("$out_file");
-
- # this prevents duplicate tags =)
- $tag_m->clear_comments();
-@@ -2257,7 +2257,7 @@
- }
-
- case /fla|flac/ {
-- $tag_m = Audio::FLAC::Header->new("$out_file");
-+ $tag_m = $tag_module->new("$out_file");
- my $tag_i = $tag_m->tags();
-
- $tag_i->{TITLE} = "$tag_name{title}" if $tag_name{title};
-@@ -2446,7 +2446,7 @@
- $ripconfig{DEVICE} = $device;
- $ripconfig{CDDB_INPUT} = $config{CDDB_INPUT};
-
-- %cd = get_cddb(\%ripconfig);
-+ %cd = CDDB_get::get_cddb(\%ripconfig);
-
- if (not $cd{title}) {
- pnotice("no_cddb","",2);
diff --git a/audio/pacpl/pkg-plist b/audio/pacpl/pkg-plist
index 376175f0f6e6..e0482ebd3a7e 100644
--- a/audio/pacpl/pkg-plist
+++ b/audio/pacpl/pkg-plist
@@ -1,21 +1,20 @@
bin/pacpl
man/man1/pacpl.1.gz
%%DATADIR%%/locale/en_US.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/ca.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/de.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/es.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/et.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/fr_FR.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/it_IT.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/nl_NL.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/pl.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/pt.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/ro.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/ru_RU.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/tr.po
-%%ADDITIONAL_LANGS%%%%DATADIR%%/locale/zh_CN.po
-%%AMAROK%%share/apps/amarok/scripts/transcoding_pacx/transcoding_pacx.pl
-%%AMAROK%%share/apps/amarok/scripts/transcoding_pacx/transcoding_pacx.spec
+%%NLS%%%%DATADIR%%/locale/ca.po
+%%NLS%%%%DATADIR%%/locale/de.po
+%%NLS%%%%DATADIR%%/locale/es.po
+%%NLS%%%%DATADIR%%/locale/et.po
+%%NLS%%%%DATADIR%%/locale/fr_FR.po
+%%NLS%%%%DATADIR%%/locale/GR.po
+%%NLS%%%%DATADIR%%/locale/it_IT.po
+%%NLS%%%%DATADIR%%/locale/nl_NL.po
+%%NLS%%%%DATADIR%%/locale/pl.po
+%%NLS%%%%DATADIR%%/locale/pt.po
+%%NLS%%%%DATADIR%%/locale/ro.po
+%%NLS%%%%DATADIR%%/locale/ru_RU.po
+%%NLS%%%%DATADIR%%/locale/tr.po
+%%NLS%%%%DATADIR%%/locale/zh_CN.po
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.module
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
@@ -23,10 +22,9 @@ man/man1/pacpl.1.gz
etc/pacpl/modules/sample.m
etc/pacpl/pacpl.conf.sample
etc/pacpl/codecs.conf.sample
-%%AMAROK%%@dirrm share/apps/amarok/scripts/transcoding_pacx
@dirrm %%DATADIR%%/locale
@dirrm %%DATADIR%%
@dirrmtry etc/pacpl/modules
@dirrmtry etc/pacpl
-%%KDE4SERVICEMENU%%@cwd %%KDE4_PREFIX%%
-%%KDE4SERVICEMENU%%share/kde4/services/ServiceMenus/pacpl.desktop
+%%KDE4%%@cwd %%KDE4_PREFIX%%
+%%KDE4%%share/kde4/services/ServiceMenus/pacpl.desktop