aboutsummaryrefslogtreecommitdiff
path: root/audio/paman
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2007-05-30 22:00:42 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2007-05-30 22:00:42 +0000
commita71eb2fba311ad62e8dba5ef45158ec775037872 (patch)
treecd69926e0173f1142d81fa01025e7dd8cd9b74df /audio/paman
parent9f78c7bb15c5cc603c52b7333ed25d1a3f3135cd (diff)
downloadports-a71eb2fba311ad62e8dba5ef45158ec775037872.tar.gz
ports-a71eb2fba311ad62e8dba5ef45158ec775037872.zip
Use system compiler on CURRENT, fix build with gcc4
Notes
Notes: svn path=/head/; revision=192427
Diffstat (limited to 'audio/paman')
-rw-r--r--audio/paman/Makefile2
-rw-r--r--audio/paman/files/patch-src_paman.cc21
2 files changed, 22 insertions, 1 deletions
diff --git a/audio/paman/Makefile b/audio/paman/Makefile
index a920cabd7680..6aa89162e10e 100644
--- a/audio/paman/Makefile
+++ b/audio/paman/Makefile
@@ -17,7 +17,7 @@ COMMENT= Gtk+ frontend for the polypaudio sound server
LIB_DEPENDS= glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
polyp-0.7.0:${PORTSDIR}/audio/polypaudio
-USE_GCC= 3.4
+USE_GCC= 3.4+
GNU_CONFIGURE= yes
USE_GNOME= gnomeprefix gnomehack
USE_XLIB= yes
diff --git a/audio/paman/files/patch-src_paman.cc b/audio/paman/files/patch-src_paman.cc
new file mode 100644
index 000000000000..0cbf53e59eea
--- /dev/null
+++ b/audio/paman/files/patch-src_paman.cc
@@ -0,0 +1,21 @@
+--- src/paman.cc.orig Wed May 30 16:58:45 2007
++++ src/paman.cc Wed May 30 16:59:37 2007
+@@ -16,7 +16,9 @@
+ struct pa_context *context = NULL;
+ struct pa_mainloop_api *mainloop_api = NULL;
+
+-extern "C" static void context_state_callback(struct pa_context *c, void *userdata);
++extern "C"
++{
++static void context_state_callback(struct pa_context *c, void *userdata);
+
+ #define WINDOW_TITLE "Polypaudio Manager"
+
+@@ -66,6 +68,7 @@
+ }
+
+ killConnection();
++}
+ }
+
+ void createConnection() {