aboutsummaryrefslogtreecommitdiff
path: root/audio/pd
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-02-09 22:08:33 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-02-09 22:08:33 +0000
commit8ea6895dc050ba14586ea8fdd5f75f11ff0ab5b6 (patch)
tree77bfb7002325ca1b171c2f1b0f494f4c1e6f51d8 /audio/pd
parentd373eb175ceb3c7dac0a7df975067a5e6dea9691 (diff)
downloadports-8ea6895dc050ba14586ea8fdd5f75f11ff0ab5b6.tar.gz
ports-8ea6895dc050ba14586ea8fdd5f75f11ff0ab5b6.zip
Let libtoolize copy missing files instead of linking them so that
USES=libtool can patch them.
Notes
Notes: svn path=/head/; revision=343548
Diffstat (limited to 'audio/pd')
-rw-r--r--audio/pd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/audio/pd/Makefile b/audio/pd/Makefile
index ece68173dcdd..e7627af4c442 100644
--- a/audio/pd/Makefile
+++ b/audio/pd/Makefile
@@ -20,14 +20,14 @@ OPTIONS_DEFAULT=FFTW
WRKSRC= ${WRKDIR}/${DISTNAME:S,${DISTVERSIONSUFFIX},,}
-USES= gettext gmake pkgconfig shebangfix tk:wrapper
+USES= gettext gmake libtool pkgconfig shebangfix tk:wrapper
SHEBANG_FILES= tcl/pkg_mkIndex.tcl
SHEBANG_LANG= tclsh
tclsh_OLD_CMD= /usr/bin/tclsh
tclsh_CMD= ${LOCALBASE}/bin/tclsh
USE_AUTOTOOLS= aclocal libtoolize autoconf automake
ACLOCAL_ARGS= -I m4/generated -I m4
-LIBTOOLIZE_ARGS=--install --force
+LIBTOOLIZE_ARGS=--install --copy --force
AUTOMAKE_ARGS= --add-missing --copy --force-missing
CONFIGURE_ENV= ac_cv_lib_pthread_pthread_create=no
@@ -82,7 +82,7 @@ post-patch:
pre-configure:
@(cd ${WRKSRC}/portaudio \
&& ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL} \
- && ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE} \
+ && ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE} ${LIBTOOLIZE_ARGS} \
&& ${SETENV} ${AUTOTOOLS_ENV} ${AUTOCONF})
do-install: