aboutsummaryrefslogtreecommitdiff
path: root/audio/pd
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-05-11 06:35:31 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-05-11 06:35:31 +0000
commitfbd8c6aa22f70d3e13f4a1591726f474513706d5 (patch)
tree5afc3a615d5920df97774bc03f276adc6aecfbb8 /audio/pd
parent8f7607bb5f8d538e2374f7923d76a2e83776fa13 (diff)
downloadports-fbd8c6aa22f70d3e13f4a1591726f474513706d5.tar.gz
ports-fbd8c6aa22f70d3e13f4a1591726f474513706d5.zip
audio/pd: 0.46-7 -> 0.47-0
- The "deken" plug-in is integrated into the Pd help menu - you can download and install Pd libraries using the "Find Externals" menu command. - New clone object that opens multiple copies of an abstraction and routes messages and signals to/from them, for making banks of voices or whatnot - "Zoom" feature for dealing with high-resolution displays. IEM GUIs are only somewhat dodgily handled (font sizes of labels aren't managed well). - Controllable font sizes for menus and dialogs: setting the "pd window" font size also sets font sizes for menus/dialogs. - The expr, expr~, and fexpr~ objects are included in Pd proper, not loaded as externs as before. THis reflects their new license (lgpl) and should allow them to be used in IOS apps via libpd. Shahrohk Yadegari has updated the source and made manifold improvements in the objects. Notably, they now allow access to variables in Pd defined via the "value" object. - Backward messaging to netsend now works in UDP as well as TCP. - Dialogs now work more Appleshly (changes taking place without the need to hit an "apply" button in many cases). Thanks to danomatica. - API support for "initbang" and "closebang" objects (from IEM library I think, but anyhow you can now get them in Pd Vanilla via deken (help menu "Find externals"). - "Declare" object path settings now take effect immediately when you edit the declare object. - (Iohannes) Abstractions, externs, and stuff written in other languages (pythin, Lua, etc) are now loaded logically, that is, if you have one patch that loads an external named X, you can still load abstractions named X in other patches. Miller now oficially Does Not Know How This Works (DNKHTW). - Many bug fixes. PR: 209438 Submitted by: Tobias Brodel <brittlehaus@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=414975
Diffstat (limited to 'audio/pd')
-rw-r--r--audio/pd/Makefile9
-rw-r--r--audio/pd/distinfo4
-rw-r--r--audio/pd/files/patch-src_s__loader.c34
-rw-r--r--audio/pd/pkg-plist29
4 files changed, 17 insertions, 59 deletions
diff --git a/audio/pd/Makefile b/audio/pd/Makefile
index 7322cb85e18a..d9956b226725 100644
--- a/audio/pd/Makefile
+++ b/audio/pd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pd
-PORTREVISION= 1
-DISTVERSION= 0.46-7
+DISTVERSION= 0.47-0
DISTVERSIONSUFFIX= .src
CATEGORIES= audio
MASTER_SITES= http://msp.ucsd.edu/Software/
@@ -32,7 +31,7 @@ CONFIGURE_ENV= ac_cv_lib_pthread_pthread_create=no
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -pthread
-DESKTOP_ENTRIES="Pd" "" "${PREFIX}/lib/pd/tcl/pd.ico" "pd" "" false
+DESKTOP_ENTRIES="Pd" "" "${PREFIX}/lib/pd/tcl/pd.ico" "pd" "" ${FALSE}
OPTIONS_DEFINE= ALSA DOCS JACK
@@ -64,10 +63,6 @@ post-patch:
's|-O2 | | ; \
s|-lc ||g' ${WRKSRC}/extra/makefile.subdir
${REINPLACE_CMD} -e \
- 's|-O2 |$$(CFLAGS) | ; \
- s|-g ||g ; \
- s|-lc ||g' ${WRKSRC}/extra/expr~/makefile
- ${REINPLACE_CMD} -e \
'/libpthread/s|_ERROR|_WARN|' ${WRKSRC}/portaudio/configure.in
do-install:
diff --git a/audio/pd/distinfo b/audio/pd/distinfo
index 846f4cb785f2..9132b25297a7 100644
--- a/audio/pd/distinfo
+++ b/audio/pd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pd-0.46-7.src.tar.gz) = 543802341bb0c7d03ed3a64cd56e2fafdbd35505d815ae3ced6555b43eaf58e5
-SIZE (pd-0.46-7.src.tar.gz) = 2254022
+SHA256 (pd-0.47-0.src.tar.gz) = 0e383f8d4786dde4f1241b80dc62845ea2ed91a08b1dfad14df2827eb8689370
+SIZE (pd-0.47-0.src.tar.gz) = 2294960
diff --git a/audio/pd/files/patch-src_s__loader.c b/audio/pd/files/patch-src_s__loader.c
deleted file mode 100644
index 79385411a5ef..000000000000
--- a/audio/pd/files/patch-src_s__loader.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/s_loader.c.orig 2014-08-18 00:35:53 UTC
-+++ src/s_loader.c
-@@ -2,7 +2,7 @@
- * For information on usage and redistribution, and for a DISCLAIMER OF ALL
- * WARRANTIES, see the file, "LICENSE.txt," in this distribution. */
-
--#ifdef HAVE_LIBDL
-+#if defined(HAVE_LIBDL) || defined(__FreeBSD__)
- #include <dlfcn.h>
- #endif
- #ifdef HAVE_UNISTD_H
-@@ -37,11 +37,9 @@ objects. The specific name is the lette
- darwin, or microsoft, followed by a more specific string, either "fat" for
- a fat binary or an indication of the instruction set. */
-
--#ifdef __FreeBSD__
--static char sys_dllextent[] = ".b_i386", sys_dllextent2[] = ".pd_freebsd";
--#elif defined(__linux__) || defined(__FreeBSD_kernel__) || defined(__GNU__)
-+#if defined(__linux__) || defined(__FreeBSD__) || defined(__GNU__) || defined(__FreeBSD__)
- static char sys_dllextent2[] = ".pd_linux";
--# ifdef __x86_64__
-+# ifdef __amd64__
- static char sys_dllextent[] = ".l_ia64"; // this should be .l_x86_64 or .l_amd64
- # elif defined(__i386__) || defined(_M_IX86)
- static char sys_dllextent[] = ".l_i386";
-@@ -216,7 +214,7 @@ gotone:
- makeout = (t_xxx)GetProcAddress(ntdll, "setup");
- SetDllDirectory(NULL); /* reset DLL dir to nothing */
- }
--#elif defined HAVE_LIBDL
-+#elif defined(HAVE_LIBDL) || defined(__FreeBSD__)
- dlobj = dlopen(filename, RTLD_NOW | RTLD_GLOBAL);
- if (!dlobj)
- {
diff --git a/audio/pd/pkg-plist b/audio/pd/pkg-plist
index 00a7c4a4ab28..72bdba29c98e 100644
--- a/audio/pd/pkg-plist
+++ b/audio/pd/pkg-plist
@@ -10,7 +10,7 @@ include/pd/m_pd.h
include/pd/s_stuff.h
lib/pd/bin/pd
lib/pd/bin/pd-watchdog
-%%PORTDOCS%%lib/pd/doc
+lib/pd/doc
lib/pd/extra/bob~/bob~-help.pd
lib/pd/extra/bob~/bob~.pd_linux
lib/pd/extra/bob~/output~.pd
@@ -21,18 +21,6 @@ lib/pd/extra/choice/choice-help.pd
lib/pd/extra/choice/choice.pd_linux
lib/pd/extra/complex-mod~-help.pd
lib/pd/extra/complex-mod~.pd
-lib/pd/extra/expr-help.pd
-lib/pd/extra/expr.pd_linux
-lib/pd/extra/expr~/LICENSE.txt
-lib/pd/extra/expr~/README.txt
-lib/pd/extra/expr~/expr-help.pd
-lib/pd/extra/expr~/expr.pd_linux
-lib/pd/extra/expr~/expr~.pd_linux
-lib/pd/extra/expr~/fexpr~.pd_linux
-lib/pd/extra/expr~-help.pd
-lib/pd/extra/expr~.pd_linux
-lib/pd/extra/fexpr~-help.pd
-lib/pd/extra/fexpr~.pd_linux
lib/pd/extra/fiddle~/fiddle~-help.pd
lib/pd/extra/fiddle~/fiddle~.pd_linux
lib/pd/extra/hilbert~-help.pd
@@ -100,6 +88,7 @@ lib/pd/tcl/pd-gui.tcl
lib/pd/tcl/pd.ico
lib/pd/tcl/pd_bindings.tcl
lib/pd/tcl/pd_connect.tcl
+lib/pd/tcl/pd_deken.tcl
lib/pd/tcl/pd_guiprefs.tcl
lib/pd/tcl/pd_menucommands.tcl
lib/pd/tcl/pd_menus.tcl
@@ -365,7 +354,10 @@ man/man1/pdsend.1.gz
%%PORTDOCS%%%%DOCSDIR%%/5.reference/bp~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/canvas-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/change-help.pd
+%%PORTDOCS%%%%DOCSDIR%%/5.reference/clip-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/clip~-help.pd
+%%PORTDOCS%%%%DOCSDIR%%/5.reference/clone-help.pd
+%%PORTDOCS%%%%DOCSDIR%%/5.reference/clone-subpatch.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/cos~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/cpole~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/cputime-help.pd
@@ -373,12 +365,14 @@ man/man1/pdsend.1.gz
%%PORTDOCS%%%%DOCSDIR%%/5.reference/czero~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/declare-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/delay-help.pd
+%%PORTDOCS%%%%DOCSDIR%%/5.reference/delread4~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/delread~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/delwrite~-help.pd
-%%PORTDOCS%%%%DOCSDIR%%/5.reference/drawtext-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/drawpolygon-help.pd
+%%PORTDOCS%%%%DOCSDIR%%/5.reference/drawtext-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/element-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/env~-help.pd
+%%PORTDOCS%%%%DOCSDIR%%/5.reference/expr-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/exp~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/fft~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/float-help.pd
@@ -397,6 +391,7 @@ man/man1/pdsend.1.gz
%%PORTDOCS%%%%DOCSDIR%%/5.reference/line-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/line~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/list-help.pd
+%%PORTDOCS%%%%DOCSDIR%%/5.reference/loadbang-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/log~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/lop~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/makefilename-help.pd
@@ -414,10 +409,11 @@ man/man1/pdsend.1.gz
%%PORTDOCS%%%%DOCSDIR%%/5.reference/numbox2-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/openpanel-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/operators-help.pd
-%%PORTDOCS%%%%DOCSDIR%%/5.reference/osc~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/oscformat-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/oscparse-help.pd
+%%PORTDOCS%%%%DOCSDIR%%/5.reference/osc~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/otherbinops-help.pd
+%%PORTDOCS%%%%DOCSDIR%%/5.reference/out1~.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/pack-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/pd-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/phasor~-help.pd
@@ -440,6 +436,7 @@ man/man1/pdsend.1.gz
%%PORTDOCS%%%%DOCSDIR%%/5.reference/rzero_rev~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/rzero~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/samphold~-help.pd
+%%PORTDOCS%%%%DOCSDIR%%/5.reference/samplerate~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/savepanel-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/scalar-object-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/select-help.pd
@@ -485,10 +482,10 @@ man/man1/pdsend.1.gz
%%PORTDOCS%%%%DOCSDIR%%/5.reference/value-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/vcf~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/vdial-help.pd
-%%PORTDOCS%%%%DOCSDIR%%/5.reference/vd~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/vline~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/vradio-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/vslider-help.pd
+%%PORTDOCS%%%%DOCSDIR%%/5.reference/vsnapshot~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/vu-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/wrap~-help.pd
%%PORTDOCS%%%%DOCSDIR%%/5.reference/writesf~-help.pd