aboutsummaryrefslogtreecommitdiff
path: root/audio/pithos
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2012-04-16 18:47:55 +0000
committerXin LI <delphij@FreeBSD.org>2012-04-16 18:47:55 +0000
commit491fe777be64061ecf6c79c6bd175d9a93f06805 (patch)
tree6d01f5a62bfea4b75ed0f6beaa53d9ec85a1a284 /audio/pithos
parentedb95032f6a7d634486d5d55400ff687b8efd9cf (diff)
downloadports-491fe777be64061ecf6c79c6bd175d9a93f06805.tar.gz
ports-491fe777be64061ecf6c79c6bd175d9a93f06805.zip
New Port: audio/pithos GNOME Pandora player
PR: ports/158925 Submitted by: John Hixson <john ixsystems.com>
Notes
Notes: svn path=/head/; revision=294924
Diffstat (limited to 'audio/pithos')
-rw-r--r--audio/pithos/Makefile45
-rw-r--r--audio/pithos/distinfo2
-rw-r--r--audio/pithos/files/patch-bin__pithos8
-rw-r--r--audio/pithos/files/patch-setup.py80
-rw-r--r--audio/pithos/pkg-descr5
-rw-r--r--audio/pithos/pkg-plist97
6 files changed, 237 insertions, 0 deletions
diff --git a/audio/pithos/Makefile b/audio/pithos/Makefile
new file mode 100644
index 000000000000..b9c9d2339031
--- /dev/null
+++ b/audio/pithos/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: pithos
+# Date created: 14 July 2011
+# Whom: John Hixson <john@pcbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pithos
+PORTVERSION= 0.3.14
+CATEGORIES= audio
+MASTER_SITES= DEBIAN
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= john@pcbsd.org
+COMMENT= A Pandora client for the GNOME desktop
+
+LICENSE= GPLv3
+
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg \
+ ${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject \
+ ${LOCALBASE}/libdata/pkgconfig/notify-python.pc:${PORTSDIR}/devel/py-notify \
+ ${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
+
+USE_PYTHON= 2.6+
+USE_GNOME= pygtk2
+USE_PYDISTUTILS= yes
+USE_GSTREAMER= good bad python
+USE_DISPLAY= yes
+PYDISTUTILS_PKGNAME= ${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,../data/,${DATADIR}/," ${WRKSRC}/pithos/pithosconfig.py
+ ${REINPLACE_CMD} -e "s,Icon=pithos,${DATADIR}/media/icon.png," ${WRKSRC}/pithos.desktop.in
+
+post-install:
+ @${INSTALL} -o ${BINOWN} -g ${BINGRP} -m 555 \
+ ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC}/data/ && ${COPYTREE_SHARE} \* ${DATADIR})
+
+.include <bsd.port.post.mk>
diff --git a/audio/pithos/distinfo b/audio/pithos/distinfo
new file mode 100644
index 000000000000..b3bea2ef9ce3
--- /dev/null
+++ b/audio/pithos/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pithos_0.3.14.orig.tar.gz) = 94bddb70259712d5605de461e7d2cf816d5b0b65ffedf35cee71b2d1f7041bc5
+SIZE (pithos_0.3.14.orig.tar.gz) = 141370
diff --git a/audio/pithos/files/patch-bin__pithos b/audio/pithos/files/patch-bin__pithos
new file mode 100644
index 000000000000..e659abebd119
--- /dev/null
+++ b/audio/pithos/files/patch-bin__pithos
@@ -0,0 +1,8 @@
+--- ./bin/pithos.orig 2011-12-14 16:33:47.000000000 -0800
++++ ./bin/pithos 2012-04-16 10:58:58.472393323 -0700
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python
+ # -*- coding: utf-8; tab-width: 4; indent-tabs-mode: nil; -*-
+ ### BEGIN LICENSE
+ # Copyright (C) 2010 Kevin Mehall <km@kevinmehall.net>
diff --git a/audio/pithos/files/patch-setup.py b/audio/pithos/files/patch-setup.py
new file mode 100644
index 000000000000..7f96757c6597
--- /dev/null
+++ b/audio/pithos/files/patch-setup.py
@@ -0,0 +1,80 @@
+--- ./setup.py.orig 2011-12-14 16:33:47.000000000 -0800
++++ ./setup.py 2012-04-16 10:58:58.477390915 -0700
+@@ -17,67 +17,19 @@
+
+ ###################### DO NOT TOUCH THIS (HEAD TO THE SECOND PART) ######################
+
+-try:
+- import DistUtilsExtra.auto
+-except ImportError:
+- import sys
+- print >> sys.stderr, 'To build pithos you need https://launchpad.net/python-distutils-extra'
+- sys.exit(1)
+-
+-assert DistUtilsExtra.auto.__version__ >= '2.10', 'needs DistUtilsExtra.auto >= 2.10'
++import sys
+ import os
++from distutils.core import setup
+
+-
+-def update_data_path(prefix, oldvalue=None):
+-
+- try:
+- fin = file('pithos/pithosconfig.py', 'r')
+- fout = file(fin.name + '.new', 'w')
+-
+- for line in fin:
+- fields = line.split(' = ') # Separate variable from value
+- if fields[0] == '__pithos_data_directory__':
+- # update to prefix, store oldvalue
+- if not oldvalue:
+- oldvalue = fields[1]
+- line = "%s = '%s'\n" % (fields[0], prefix)
+- else: # restore oldvalue
+- line = "%s = %s" % (fields[0], oldvalue)
+- fout.write(line)
+-
+- fout.flush()
+- fout.close()
+- fin.close()
+- os.rename(fout.name, fin.name)
+- except (OSError, IOError), e:
+- print ("ERROR: Can't find pithos/pithosconfig.py")
+- sys.exit(1)
+- return oldvalue
+-
+-
+-class InstallAndUpdateDataDirectory(DistUtilsExtra.auto.install_auto):
+- def run(self):
+- if self.root or self.home:
+- print "WARNING: You don't use a standard --prefix installation, take care that you eventually " \
+- "need to update quickly/quicklyconfig.py file to adjust __quickly_data_directory__. You can " \
+- "ignore this warning if you are packaging and uses --prefix."
+- previous_value = update_data_path(self.prefix + '/share/pithos/')
+- DistUtilsExtra.auto.install_auto.run(self)
+- update_data_path(self.prefix, previous_value)
+-
+-from DistUtilsExtra.command.build_extra import build_extra
+-from DistUtilsExtra.command.build_icons import build_icons
+-
+-DistUtilsExtra.auto.setup(
++required = []
++setup(
+ name='pithos',
+- version='0.3',
+- ext_modules=[],
+- license='GPL-3',
++ version='0.3.14',
++ description='Pandora.com client for the GNOME desktop',
+ author='Kevin Mehall',
+ author_email='km@kevinmehall.net',
+- description='Pandora.com client for the GNOME desktop',
+- #long_description='Here a longer description',
+ url='https://launchpad.net/pithos',
+- cmdclass={'install': InstallAndUpdateDataDirectory, 'build_icons':build_icons, 'build':build_extra}
+- )
+-
++ license='GPL-3',
++ packages=['pithos', 'pithos.pandora', 'pithos.plugins'],
++ package_dir = {'pithos':'pithos'}
++)
diff --git a/audio/pithos/pkg-descr b/audio/pithos/pkg-descr
new file mode 100644
index 000000000000..c6732398e99c
--- /dev/null
+++ b/audio/pithos/pkg-descr
@@ -0,0 +1,5 @@
+Pithos is a Pandora client for the GNOME Desktop. The official
+Flash-based client is a CPU hog, and Pianobar is a great
+reverse-engineered implementation, but is command-line only. Neither
+integrate with the desktop very well, missing things like media key
+support and song notifications.
diff --git a/audio/pithos/pkg-plist b/audio/pithos/pkg-plist
new file mode 100644
index 000000000000..060f1d4caa45
--- /dev/null
+++ b/audio/pithos/pkg-plist
@@ -0,0 +1,97 @@
+bin/pithos
+%%PYTHON_SITELIBDIR%%/pithos/AboutPithosDialog.py
+%%PYTHON_SITELIBDIR%%/pithos/PreferencesPithosDialog.py
+%%PYTHON_SITELIBDIR%%/pithos/SearchDialog.py
+%%PYTHON_SITELIBDIR%%/pithos/StationsDialog.py
+%%PYTHON_SITELIBDIR%%/pithos/__init__.py
+%%PYTHON_SITELIBDIR%%/pithos/dbus_service.py
+%%PYTHON_SITELIBDIR%%/pithos/gobject_worker.py
+%%PYTHON_SITELIBDIR%%/pithos/plugin.py
+%%PYTHON_SITELIBDIR%%/pithos/pylast.py
+%%PYTHON_SITELIBDIR%%/pithos/sound_menu.py
+%%PYTHON_SITELIBDIR%%/pithos/pandora/__init__.py
+%%PYTHON_SITELIBDIR%%/pithos/pandora/blowfish.py
+%%PYTHON_SITELIBDIR%%/pithos/pandora/fake.py
+%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora.py
+%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora_keys.py
+%%PYTHON_SITELIBDIR%%/pithos/pandora/xmlrpc.py
+%%PYTHON_SITELIBDIR%%/pithos/pandora/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pithos/pandora/blowfish.pyc
+%%PYTHON_SITELIBDIR%%/pithos/pandora/fake.pyc
+%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora.pyc
+%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora_keys.pyc
+%%PYTHON_SITELIBDIR%%/pithos/pandora/xmlrpc.pyc
+%%PYTHON_SITELIBDIR%%/pithos/pandora/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pithos/pandora/blowfish.pyo
+%%PYTHON_SITELIBDIR%%/pithos/pandora/fake.pyo
+%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora.pyo
+%%PYTHON_SITELIBDIR%%/pithos/pandora/pandora_keys.pyo
+%%PYTHON_SITELIBDIR%%/pithos/pandora/xmlrpc.pyo
+%%PYTHON_SITELIBDIR%%/pithos/plugins/__init__.py
+%%PYTHON_SITELIBDIR%%/pithos/plugins/mediakeys.py
+%%PYTHON_SITELIBDIR%%/pithos/plugins/notification_icon.py
+%%PYTHON_SITELIBDIR%%/pithos/plugins/notify.py
+%%PYTHON_SITELIBDIR%%/pithos/plugins/screensaver_pause.py
+%%PYTHON_SITELIBDIR%%/pithos/plugins/scrobble.py
+%%PYTHON_SITELIBDIR%%/pithos/plugins/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pithos/plugins/mediakeys.pyc
+%%PYTHON_SITELIBDIR%%/pithos/plugins/notification_icon.pyc
+%%PYTHON_SITELIBDIR%%/pithos/plugins/notify.pyc
+%%PYTHON_SITELIBDIR%%/pithos/plugins/screensaver_pause.pyc
+%%PYTHON_SITELIBDIR%%/pithos/plugins/scrobble.pyc
+%%PYTHON_SITELIBDIR%%/pithos/plugins/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pithos/plugins/mediakeys.pyo
+%%PYTHON_SITELIBDIR%%/pithos/plugins/notification_icon.pyo
+%%PYTHON_SITELIBDIR%%/pithos/plugins/notify.pyo
+%%PYTHON_SITELIBDIR%%/pithos/plugins/screensaver_pause.pyo
+%%PYTHON_SITELIBDIR%%/pithos/plugins/scrobble.pyo
+%%PYTHON_SITELIBDIR%%/pithos/pithosconfig.py
+%%PYTHON_SITELIBDIR%%/pithos/AboutPithosDialog.pyc
+%%PYTHON_SITELIBDIR%%/pithos/PreferencesPithosDialog.pyc
+%%PYTHON_SITELIBDIR%%/pithos/SearchDialog.pyc
+%%PYTHON_SITELIBDIR%%/pithos/StationsDialog.pyc
+%%PYTHON_SITELIBDIR%%/pithos/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pithos/dbus_service.pyc
+%%PYTHON_SITELIBDIR%%/pithos/gobject_worker.pyc
+%%PYTHON_SITELIBDIR%%/pithos/plugin.pyc
+%%PYTHON_SITELIBDIR%%/pithos/pylast.pyc
+%%PYTHON_SITELIBDIR%%/pithos/sound_menu.pyc
+%%PYTHON_SITELIBDIR%%/pithos/pithosconfig.pyc
+%%PYTHON_SITELIBDIR%%/pithos/AboutPithosDialog.pyo
+%%PYTHON_SITELIBDIR%%/pithos/PreferencesPithosDialog.pyo
+%%PYTHON_SITELIBDIR%%/pithos/SearchDialog.pyo
+%%PYTHON_SITELIBDIR%%/pithos/StationsDialog.pyo
+%%PYTHON_SITELIBDIR%%/pithos/__init__.pyo
+%%PYTHON_SITELIBDIR%%/pithos/dbus_service.pyo
+%%PYTHON_SITELIBDIR%%/pithos/gobject_worker.pyo
+%%PYTHON_SITELIBDIR%%/pithos/plugin.pyo
+%%PYTHON_SITELIBDIR%%/pithos/pylast.pyo
+%%PYTHON_SITELIBDIR%%/pithos/sound_menu.pyo
+%%PYTHON_SITELIBDIR%%/pithos/pithosconfig.pyo
+%%DATADIR%%/icons/scalable/apps/pithos-mono.svg
+%%DATADIR%%/icons/scalable/apps/pithos.svg
+%%DATADIR%%/media/album_default.png
+%%DATADIR%%/media/album_default.svg
+%%DATADIR%%/media/icon.png
+%%DATADIR%%/media/pithos-mono.png
+%%DATADIR%%/media/rate_bg.png
+%%DATADIR%%/media/rate_bg.svg
+%%DATADIR%%/ui/AboutPithosDialog.ui
+%%DATADIR%%/ui/PithosWindow.ui
+%%DATADIR%%/ui/PreferencesPithosDialog.ui
+%%DATADIR%%/ui/SearchDialog.ui
+%%DATADIR%%/ui/StationsDialog.ui
+%%DATADIR%%/ui/about_pithos_dialog.xml
+%%DATADIR%%/ui/pithos_window.xml
+%%DATADIR%%/ui/preferences_pithos_dialog.xml
+%%DATADIR%%/ui/search_dialog.xml
+%%DATADIR%%/ui/stations_dialog.xml
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%/media
+@dirrm %%DATADIR%%/icons/scalable/apps
+@dirrm %%DATADIR%%/icons/scalable
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/pithos/plugins
+@dirrm %%PYTHON_SITELIBDIR%%/pithos/pandora
+@dirrm %%PYTHON_SITELIBDIR%%/pithos