aboutsummaryrefslogtreecommitdiff
path: root/audio/pithos
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2012-04-27 21:02:43 +0000
committerXin LI <delphij@FreeBSD.org>2012-04-27 21:02:43 +0000
commit5650de72497905e32e4d1ddbeb490453d1c8d578 (patch)
treead173927c90d84d087315ed4385f2b139c346f73 /audio/pithos
parent4ee08b9095cecbff5f1b92d4d223a7c43845b499 (diff)
downloadports-5650de72497905e32e4d1ddbeb490453d1c8d578.tar.gz
ports-5650de72497905e32e4d1ddbeb490453d1c8d578.zip
patch pithos to work with pandora v34.
PR: ports/167377 Submitted by: John Hixson (maintainer)
Notes
Notes: svn path=/head/; revision=295623
Diffstat (limited to 'audio/pithos')
-rw-r--r--audio/pithos/Makefile1
-rw-r--r--audio/pithos/files/patch-pandora.py31
2 files changed, 32 insertions, 0 deletions
diff --git a/audio/pithos/Makefile b/audio/pithos/Makefile
index b9c9d2339031..e8df8191a17a 100644
--- a/audio/pithos/Makefile
+++ b/audio/pithos/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pithos
PORTVERSION= 0.3.14
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= DEBIAN
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
diff --git a/audio/pithos/files/patch-pandora.py b/audio/pithos/files/patch-pandora.py
new file mode 100644
index 000000000000..5bc7e3816d6f
--- /dev/null
+++ b/audio/pithos/files/patch-pandora.py
@@ -0,0 +1,31 @@
+--- pithos/pandora/pandora.py.orig 2011-12-14 16:33:47.000000000 -0800
++++ pithos/pandora/pandora.py 2012-04-27 13:41:25.000000000 -0700
+@@ -22,7 +22,7 @@
+ from pithos.pandora.xmlrpc import *
+ from pithos.pandora.blowfish import Blowfish
+
+-PROTOCOL_VERSION = "33"
++PROTOCOL_VERSION = "34"
+ RPC_URL = "www.pandora.com/radio/xmlrpc/v"+PROTOCOL_VERSION+"?"
+ USER_AGENT = "Mozilla/5.0 (X11; U; Linux i586; de; rv:5.0) Gecko/20100101 Firefox/5.0 (compatible; Pithos/0.3)"
+ HTTP_TIMEOUT = 30
+@@ -161,12 +161,16 @@
+ def connect(self, user, password):
+ self.rid = "%07iP"%(int(time.time()) % 10000000)
+ self.listenerId = self.authToken = None
++
++ logging.info("Attempting to connect...");
++ timeurl = urllib2.urlopen("http://ridetheclown.com/s2/synctime.php");
++ pandora_time=int(timeurl.read(),10);
++ logging.info("Synctime is %s", pandora_time)
+
+- pandora_time = self.xmlrpc_call('misc.sync', [], [], secure=True, includeTime=False)
+- pandora_time = int(re.sub(r"\D", "", pandora_decrypt(pandora_time)))
+ self.time_offset = pandora_time - time.time()
+
+- user = self.xmlrpc_call('listener.authenticateListener', [user, password], [], secure=True)
++ user = self.xmlrpc_call('listener.authenticateListener', ["",user, password,"html5tuner","","","HTML5",True], [], secure=True)
++
+
+ self.webAuthToken = user['webAuthToken']
+ self.listenerId = user['listenerId'] \ No newline at end of file