aboutsummaryrefslogtreecommitdiff
path: root/audio/play
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-06-07 02:21:52 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-06-07 02:21:52 +0000
commit0467aae499c92d2291845dfda27e5622a727a993 (patch)
tree34ed02ae681900dda940f9ba00d20f84e185a83b /audio/play
parent3842be24171bd26fb70d2551ccf75d9cddff3e53 (diff)
downloadports-0467aae499c92d2291845dfda27e5622a727a993.tar.gz
ports-0467aae499c92d2291845dfda27e5622a727a993.zip
machine/soundcard.h -> sys/soundcard.h
Submitted by: bento
Notes
Notes: svn path=/head/; revision=60745
Diffstat (limited to 'audio/play')
-rw-r--r--audio/play/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/audio/play/Makefile b/audio/play/Makefile
index 24e7bf0c6e9c..aab44d23cedc 100644
--- a/audio/play/Makefile
+++ b/audio/play/Makefile
@@ -15,4 +15,13 @@ MAINTAINER= seiken@ARGV.AC
MANLANG= ja
MAN1= play.1
MANCOMPRESSED = yes
+
+post-patch:
+.for file in play_audio.c mixer_ctl.c encode_sun.c encode_riff.c speed.c
+ @${CHMOD} u+w ${WRKSRC}/${file}
+ @${SED} 's,machine/soundcard.h,sys/soundcard.h,' < ${WRKSRC}/${file} \
+ > ${WRKSRC}/${file}.new
+ @${MV} ${WRKSRC}/${file}.new ${WRKSRC}/${file}
+.endfor
+
.include <bsd.port.mk>