aboutsummaryrefslogtreecommitdiff
path: root/audio/playgsf/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-04-03 08:37:47 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-04-03 08:37:47 +0000
commit3ec5fd26a47984efb4ce2840657e0f251ea8f22f (patch)
tree774606d7d7ee0739deb991e3e2ec910e84d8cd65 /audio/playgsf/Makefile
parent091d8dff2a793c50aa50e44d701dd87414bdbb82 (diff)
downloadports-3ec5fd26a47984efb4ce2840657e0f251ea8f22f.tar.gz
ports-3ec5fd26a47984efb4ce2840657e0f251ea8f22f.zip
Notes
Diffstat (limited to 'audio/playgsf/Makefile')
-rw-r--r--audio/playgsf/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/audio/playgsf/Makefile b/audio/playgsf/Makefile
index db862db0f4ab..307f96cd923b 100644
--- a/audio/playgsf/Makefile
+++ b/audio/playgsf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= playgsf
PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://projects.raphnet.net/playgsf/ \
CRITICAL
@@ -11,29 +11,32 @@ MASTER_SITES= http://projects.raphnet.net/playgsf/ \
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Command-line player for gsf audio files
-LIB_DEPENDS= ao.4:${PORTSDIR}/audio/libao
+LIB_DEPENDS= ao:${PORTSDIR}/audio/libao
USE_GMAKE= yes
+USE_DOS2UNIX= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-# disable optimization flags to avoid a possible bug in gcc
-# (gcc tries to allocate memory in an endless loop)
-CFLAGS+= -O0
-
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= LIBS="${LDFLAGS}"
CONFIGURE_ENV+= LIBS="${LDFLAGS}"
+CONFIGURE_ARGS+= --enable-ccore --disable-optimisations
PLIST_FILES= bin/playgsf
-# contains x86 assembler
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
PORTSCOUT= skipv:0.7.2
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 901000
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-VBA__Util.cpp
+.endif
+
post-patch:
@${REINPLACE_CMD} \
-e 's|\(@LDFLAGS@\)|\1 ${LDFLAGS}|' \
@@ -51,4 +54,4 @@ do-install:
post-install:
${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>