aboutsummaryrefslogtreecommitdiff
path: root/audio/playgsf
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-28 12:15:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-28 12:15:12 +0000
commit853ffe1b2b3b95d78a2414c012e39baf2d5f3760 (patch)
tree1fabb518e5e1f66333427fb950dc6ba5beb1791a /audio/playgsf
parent2c98a82bf1d9f400e14d7df95254548d7c977391 (diff)
downloadports-853ffe1b2b3b95d78a2414c012e39baf2d5f3760.tar.gz
ports-853ffe1b2b3b95d78a2414c012e39baf2d5f3760.zip
Playgsf is a simple command line player for gsf files based on a winamp plugin
called 'Highly Advanced'. The gsf file format is a music format similar to the psf format for playstation(TM). PR: ports/84025 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=140307
Diffstat (limited to 'audio/playgsf')
-rw-r--r--audio/playgsf/Makefile38
-rw-r--r--audio/playgsf/distinfo2
-rw-r--r--audio/playgsf/pkg-descr10
-rw-r--r--audio/playgsf/pkg-message4
4 files changed, 54 insertions, 0 deletions
diff --git a/audio/playgsf/Makefile b/audio/playgsf/Makefile
new file mode 100644
index 000000000000..0974a4564bc9
--- /dev/null
+++ b/audio/playgsf/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: playgsf
+# Date created: 10 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= playgsf
+PORTVERSION= 0.6
+CATEGORIES= audio
+MASTER_SITES= http://projects.raphnet.net/playgsf/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command line player for gsf audio files
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+USE_GCC= 3.4+
+
+# avoid a "of memory error" gcc bug
+CFLAGS+= -O0
+
+PLIST_FILES= bin/playgsf
+
+ONLY_FOR_ARCHS= i386 # contains x86 assembler
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(CFLAGS="\)\(-DLINUX\)|\1${CFLAGS} \2|' \
+ ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/audio/playgsf/distinfo b/audio/playgsf/distinfo
new file mode 100644
index 000000000000..ed041293a968
--- /dev/null
+++ b/audio/playgsf/distinfo
@@ -0,0 +1,2 @@
+MD5 (playgsf-0.6.tar.gz) = 019f052657896e0fed6939ca1a3527e6
+SIZE (playgsf-0.6.tar.gz) = 243894
diff --git a/audio/playgsf/pkg-descr b/audio/playgsf/pkg-descr
new file mode 100644
index 000000000000..8c6ee2b5a914
--- /dev/null
+++ b/audio/playgsf/pkg-descr
@@ -0,0 +1,10 @@
+Playgsf is a simple command line player for gsf files based on a winamp plugin
+called 'Highly Advanced'.
+
+The gsf file format is a music format similar to the psf format for
+playstation(TM).
+
+WWW: http://projects.raphnet.net/#playgsf
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/audio/playgsf/pkg-message b/audio/playgsf/pkg-message
new file mode 100644
index 000000000000..3a1307dfbfdc
--- /dev/null
+++ b/audio/playgsf/pkg-message
@@ -0,0 +1,4 @@
+================================================================================
+A huge gsf file collection can be found at:
+ http://www.caitsith2.com/gsf/ or http://www.zophar.net/gsf/
+================================================================================