aboutsummaryrefslogtreecommitdiff
path: root/audio/portaudio/Makefile
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2012-12-30 17:57:04 +0000
committerMarcus von Appen <mva@FreeBSD.org>2012-12-30 17:57:04 +0000
commit6ee31886c911678177a10c557fb2840d9ba0b523 (patch)
tree2f9548d7bf4165d372787d883bcf8215757bf1fd /audio/portaudio/Makefile
parent59ca196eee2e4df784fdb535740747b8cf800435 (diff)
downloadports-6ee31886c911678177a10c557fb2840d9ba0b523.tar.gz
ports-6ee31886c911678177a10c557fb2840d9ba0b523.zip
Notes
Diffstat (limited to 'audio/portaudio/Makefile')
-rw-r--r--audio/portaudio/Makefile74
1 files changed, 42 insertions, 32 deletions
diff --git a/audio/portaudio/Makefile b/audio/portaudio/Makefile
index f5d32b863020..8fa93678a148 100644
--- a/audio/portaudio/Makefile
+++ b/audio/portaudio/Makefile
@@ -1,62 +1,72 @@
-# New ports collection makefile for: portaudio
-# Date created: 18 May 2003
-# Whom: michaelnottebrock@gmx.net and lioux@FreeBSD.org
-#
+# Created by: michaelnottebrock@gmx.net and lioux@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= portaudio
PORTVERSION= 18.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://www.portaudio.com/archives/
DISTNAME= ${PORTNAME}_v${PORTVERSION:S/./_/}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Portable cross-platform Audio API
+LICENSE= MIT
+
USE_ZIP= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_DOS2UNIX= yes
USE_LDCONFIG= yes
-USE_DOS2UNIX= yes
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_CFLAGS}
PLIST_SUB+= SHLIB_VERSION=${SHLIB_VERSION}
SHLIB_VERSION= 0
-pre-everything::
-.if !defined(WITH_PATESTS)
- @${ECHO_MSG}
- @${ECHO_MSG} "You can additionally build portaudio's testsuite by defining WITH_PATESTS."
- @${ECHO_MSG}
-PLIST_SUB+= WITH_PATESTS="@comment "
+PORTDOCS= *
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= README.txt index.html
+
+DOCSRCDIR2= ${WRKSRC}/docs
+DOCSDIR2= ${DOCSDIR}/docs
+DOC_FILES2= *.html *.txt *.pdf
+
+OPTIONS_DEFINE= PATEST
+OPTIONS_DEFAULT= PATEST
+
+PATEST_DESC= PortAudio Test Programs
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPATEST}
+PLIST_SUB+= PATEST=""
.else
-PLIST_SUB+= WITH_PATESTS=""
+PLIST_SUB+= PATEST="@comment "
.endif
post-patch:
-# replace obsolete headers, and fix up thread library
- @${FIND} ${WRKSRC} -type f \
- | ${XARGS} -x -n 10 \
- ${REINPLACE_CMD} -E \
- -e 's|malloc.h|stdlib.h|' \
- -e 's|machine\/soundcard.h|sys\/soundcard.h|' \
- -e 's|-lpthread|${PTHREAD_LIBS}|'
+ @${REINPLACE_CMD} -e 's|#include <malloc.h>|#include <stdlib.h>|' ${WRKSRC}/pa_unix_oss/pa_unix.h
+ @${REINPLACE_CMD} -e 's|machine/soundcard.h|sys/soundcard.h|' ${WRKSRC}/pa_unix_oss/pa_unix_oss.c
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure ${WRKSRC}/configure.in \
+ ${WRKSRC}/pa_unix_oss/Makefile
+
pre-configure:
-# Make configure executable
@${CHMOD} +x ${WRKSRC}/configure
-.if !defined(WITH_PATESTS)
-post-configure:
- @${REINPLACE_CMD} -e 's|tests$$||' ${WRKSRC}/Makefile
-.endif
-
post-install:
-.if defined(WITH_PATESTS)
- @${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin
-.endif
@${LN} -sf libportaudio.so \
${PREFIX}/lib/libportaudio.so.${SHLIB_VERSION}
+.if ${PORT_OPTIONS:MPATEST}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/* ${PREFIX}/bin
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR2}
+.endif
.include <bsd.port.mk>