aboutsummaryrefslogtreecommitdiff
path: root/audio/portaudio
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-03-01 09:36:43 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-03-01 09:36:43 +0000
commit27a22a51818b3eb3e34302b76cdc178f73c7f7a4 (patch)
tree38c289644c3c6a276bbd53e0062b53ceb698c630 /audio/portaudio
parentfbc4e413a7f4f110a04d32bc3a75d168b787b7ce (diff)
downloadports-27a22a51818b3eb3e34302b76cdc178f73c7f7a4.tar.gz
ports-27a22a51818b3eb3e34302b76cdc178f73c7f7a4.zip
audio/portaudio: Stop always building useless test and example programs
While here also install C++ bindings examples
Notes
Notes: svn path=/head/; revision=494247
Diffstat (limited to 'audio/portaudio')
-rw-r--r--audio/portaudio/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/audio/portaudio/Makefile b/audio/portaudio/Makefile
index 059c9d0afbc1..fd21e3b7ba64 100644
--- a/audio/portaudio/Makefile
+++ b/audio/portaudio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= portaudio
PORTVERSION= 19.6.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= http://www.portaudio.com/archives/
@@ -23,6 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking \
--enable-cxx \
--without-alsa
+MAKE_ARGS= EXAMPLES=""
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_JOBS_UNSAFE= yes
@@ -42,6 +43,8 @@ PORTEXAMPLES= *
JACK_LIB_DEPENDS= libjack.so:audio/jack
JACK_CONFIGURE_WITH= jack
+PATEST_MAKE_ARGS_OFF= SELFTESTS="" TESTS=""
+
SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
SNDIO_CONFIGURE_WITH= sndio
@@ -49,10 +52,6 @@ post-extract:
@${MKDIR} ${WRKSRC}/src/hostapi/sndio
@${CP} ${FILESDIR}/pa_sndio.c ${WRKSRC}/src/hostapi/sndio
-post-patch:
- @${REINPLACE_CMD} -i '' '/EXAMPLES =/,/bin\/paex_write_sine_nonint/s/^/#/' \
- ${WRKSRC}/Makefile.in
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libportaudio.so \
${STAGEDIR}${PREFIX}/lib/libportaudiocpp.so
@@ -67,7 +66,10 @@ post-install-DOXYGEN-on:
@cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}
post-install-EXAMPLES-on:
- @cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/bindings/cpp/example/*.cxx \
+ ${WRKSRC}/examples/*.c ${WRKSRC}/examples/*.cpp \
+ ${STAGEDIR}${EXAMPLESDIR}
post-install-PATEST-on:
.for f in pa_m* paqa_* patest*