aboutsummaryrefslogtreecommitdiff
path: root/audio/portaudio
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-06-03 19:03:16 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-06-03 19:03:16 +0000
commit671899ff6fc7954e4f04568e15c26f94c887381e (patch)
tree733446073095d8361330d5ba3e54048fb00b1f7b /audio/portaudio
parentab52677e5c991cb59d904495b35a4783db091c31 (diff)
downloadports-671899ff6fc7954e4f04568e15c26f94c887381e.tar.gz
ports-671899ff6fc7954e4f04568e15c26f94c887381e.zip
New port portaudio version 18: Portable cross-platform Audio API
PR: 52406 Submitted by: Michael Nottebrock <michaelnottebrock@gmx.net> et. al.
Notes
Notes: svn path=/head/; revision=82206
Diffstat (limited to 'audio/portaudio')
-rw-r--r--audio/portaudio/Makefile49
-rw-r--r--audio/portaudio/distinfo1
-rw-r--r--audio/portaudio/pkg-descr11
-rw-r--r--audio/portaudio/pkg-plist3
4 files changed, 64 insertions, 0 deletions
diff --git a/audio/portaudio/Makefile b/audio/portaudio/Makefile
new file mode 100644
index 000000000000..37e0c64658ff
--- /dev/null
+++ b/audio/portaudio/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: portaudio
+# Date created: 18 May 2003
+# Whom: michaelnottebrock@gmx.net and lioux@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= portaudio
+PORTVERSION= 18
+CATEGORIES= audio
+MASTER_SITES= http://www.portaudio.com/archives/
+DISTNAME= ${PORTNAME}_v${PORTVERSION}
+
+MAINTAINER= michaelnottebrock@gmx.net
+COMMENT= Portable cross-platform Audio API
+
+USE_REINPLACE= yes
+USE_ZIP= yes
+USE_GMAKE= yes
+MAKEFILE= Makefile.linux
+ALL_TARGET= sharedlib
+PLIST_SUB= SHLIB_VERSION=${SHLIB_VERSION}
+INSTALLS_SHLIB= yes
+
+SHLIB_VERSION= 0
+
+post-patch:
+# replace \r\n with \n
+# replace <malloc.h> with <stdlib.h>
+ @${FIND} ${WRKSRC} -type f \
+ | ${XARGS} -x -n 10 \
+ ${REINPLACE_CMD} -E \
+ -e 's| ||' \
+ -e 's|malloc.h|stdlib.h|'
+# C{C,FLAGS} and PREFIX safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|gcc|${CC} ${CFLAGS}|' \
+ -e 's|^CFLAGS.*$$||' \
+ ${BUILD_WRKSRC}/${MAKEFILE}
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/pa_common/portaudio.h \
+ ${PREFIX}/include
+ @${INSTALL_DATA} ${WRKSRC}/pa_unix_oss/libportaudio.so \
+ ${PREFIX}/lib
+ @${LN} -sf libportaudio.so \
+ ${PREFIX}/lib/libportaudio.so.${SHLIB_VERSION}
+
+.include <bsd.port.mk>
diff --git a/audio/portaudio/distinfo b/audio/portaudio/distinfo
new file mode 100644
index 000000000000..39cfec9976a6
--- /dev/null
+++ b/audio/portaudio/distinfo
@@ -0,0 +1 @@
+MD5 (portaudio_v18.zip) = 4371cbba9e0aa13d0b605c7bf31da50a
diff --git a/audio/portaudio/pkg-descr b/audio/portaudio/pkg-descr
new file mode 100644
index 000000000000..99c36c3bd475
--- /dev/null
+++ b/audio/portaudio/pkg-descr
@@ -0,0 +1,11 @@
+PortAudio is a free, cross platform, open-source, audio I/O library.
+It lets you write simple audio programs in 'C' that will compile
+and run on many platforms including Windows, Macintosh (8,9,X),
+Unix (OSS), SGI, and BeOS. PortAudio is intended to promote the
+exchange of audio synthesis software between developers on different
+platforms, and was recently selected as the audio component of a
+larger PortMusic project that includes MIDI and sound file support.
+
+WWW: http://www.portaudio.com/
+
+michaelnottebrock@gmx.net
diff --git a/audio/portaudio/pkg-plist b/audio/portaudio/pkg-plist
new file mode 100644
index 000000000000..654d74c5ad80
--- /dev/null
+++ b/audio/portaudio/pkg-plist
@@ -0,0 +1,3 @@
+include/portaudio.h
+lib/libportaudio.so
+lib/libportaudio.so.%%SHLIB_VERSION%%