aboutsummaryrefslogtreecommitdiff
path: root/audio/praat
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-12-06 14:23:51 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-12-06 14:23:51 +0000
commit68fc0c3fd0e5d804d90da4edc58d1dd66143c3c3 (patch)
tree4505b887453918167ce2ab0c57bb15c593229519 /audio/praat
parent421a52c18f068a7cd5651f4225415e6adb9c3362 (diff)
downloadports-68fc0c3fd0e5d804d90da4edc58d1dd66143c3c3.tar.gz
ports-68fc0c3fd0e5d804d90da4edc58d1dd66143c3c3.zip
Update audio/praat to latest upstream release
With this update, I'm taking the time to tidy up some bits: - jack was not used - configurable audio was not used (I suppose there used to be OSS / JACK / ALSA, but it's settled on just ALSA here) - simplify the dos2unix bits (I'll report the remainder upstream) - there are fonts for phonetics, although I don't see a difference: leave them commented-out Release notes as always at: https://www.fon.hum.uva.nl/praat/manual/What_s_new_.html with new scripting commands as most-interesting-bit (in 6.1.35). There were some intermediate releases, which didn't add anything for us on FreeBSD.
Notes
Notes: svn path=/head/; revision=557136
Diffstat (limited to 'audio/praat')
-rw-r--r--audio/praat/Makefile13
-rw-r--r--audio/praat/distinfo6
-rw-r--r--audio/praat/files/makefile.defs.freebsd.alsa4
-rw-r--r--audio/praat/files/patch-external_portaudio_Makefile14
-rw-r--r--audio/praat/files/patch-external_portaudio_pa__unix__hostapis.c11
5 files changed, 13 insertions, 35 deletions
diff --git a/audio/praat/Makefile b/audio/praat/Makefile
index 71cd7b13ab1a..162b8cfc0db7 100644
--- a/audio/praat/Makefile
+++ b/audio/praat/Makefile
@@ -2,7 +2,7 @@
PORTNAME= praat
DISTVERSIONPREFIX= v
-DISTVERSION= 6.1.31
+DISTVERSION= 6.1.35
CATEGORIES= audio science
MAINTAINER= adridg@FreeBSD.org
@@ -12,15 +12,22 @@ LICENSE= GPLv2
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libjack.so:audio/jack \
libasound.so:audio/alsa-lib
+# These are recommended but I can't tell the difference
+# RUN_DEPENDS= CharisSIL>=0:x11-fonts/charis \
+# DoulosSIL>=0:x11-fonts/doulos
USES= compiler:c++11-lang dos2unix gnome iconv pkgconfig
USE_GNOME= cairo gdkpixbuf2 gtk30
USE_GITHUB= yes
USE_XORG= x11
-DOS2UNIX_REGEX= .*Makefile
+DOS2UNIX_FILES= \
+ fon/Makefile \
+ melder/Makefile \
+ sys/Makefile \
+ EEG/Makefile
+
PLIST_FILES= bin/praat man/man1/praat.1.gz
HARDCPPFLAGS= ${WRKSRC}/EEG/Makefile \
diff --git a/audio/praat/distinfo b/audio/praat/distinfo
index f8acf03cced7..d1318116d739 100644
--- a/audio/praat/distinfo
+++ b/audio/praat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1605223479
-SHA256 (praat-praat-v6.1.31_GH0.tar.gz) = aa2ce29b8b7228d6e39449565e976e6ed3e5670fe7a078662593aea3b0017229
-SIZE (praat-praat-v6.1.31_GH0.tar.gz) = 32235642
+TIMESTAMP = 1607259331
+SHA256 (praat-praat-v6.1.35_GH0.tar.gz) = 60fbd7bb588562f4f9e253e9b3a672351c9d23d465acc2c887db3039b99c104c
+SIZE (praat-praat-v6.1.35_GH0.tar.gz) = 32721488
diff --git a/audio/praat/files/makefile.defs.freebsd.alsa b/audio/praat/files/makefile.defs.freebsd.alsa
index b5d03a2a011b..eba79e9d4e8b 100644
--- a/audio/praat/files/makefile.defs.freebsd.alsa
+++ b/audio/praat/files/makefile.defs.freebsd.alsa
@@ -26,7 +26,3 @@ RANLIB = ls
ICON =
MAIN_ICON =
-# Replace pa_linux_alsa.o in portaudio/Makefile.
-# Does not seem necessary anymore. If not, the portaudio patches can probably
-# be removed as well.
-# PA_BACKEND = pa_unix_oss.o
diff --git a/audio/praat/files/patch-external_portaudio_Makefile b/audio/praat/files/patch-external_portaudio_Makefile
deleted file mode 100644
index e244a4c1e2a5..000000000000
--- a/audio/praat/files/patch-external_portaudio_Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
---- external/portaudio/Makefile.orig 2019-11-27 13:52:21 UTC
-+++ external/portaudio/Makefile
-@@ -3,8 +3,10 @@
-
- include ../../makefile.defs
-
-+PA_BACKEND ?= pa_linux_alsa.o
-+
- OBJECTS = \
-- pa_unix_hostapis.o pa_unix_util.o pa_linux_alsa.o pa_jack.o pa_ringbuffer.o \
-+ pa_unix_hostapis.o pa_unix_util.o $(PA_BACKEND) pa_jack.o pa_ringbuffer.o \
- pa_win_hostapis.o pa_win_util.o pa_win_wmme.o pa_win_waveformat.o \
- pa_front.o pa_debugprint.o pa_cpuload.o \
- pa_allocation.o pa_process.o pa_converters.o pa_dither.o \
diff --git a/audio/praat/files/patch-external_portaudio_pa__unix__hostapis.c b/audio/praat/files/patch-external_portaudio_pa__unix__hostapis.c
deleted file mode 100644
index b0ad5c809ba7..000000000000
--- a/audio/praat/files/patch-external_portaudio_pa__unix__hostapis.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- external/portaudio/pa_unix_hostapis.c.orig 2019-11-26 11:48:46 UTC
-+++ external/portaudio/pa_unix_hostapis.c
-@@ -64,6 +64,8 @@ PaUtilHostApiInitializer *paHostApiInitializers[] =
- #elif defined (JACK)
- PaJack_Initialize,
- #endif
-+ #else
-+ PaOSS_Initialize,
- #endif
- 0 /* NULL terminated array */
- };