aboutsummaryrefslogtreecommitdiff
path: root/audio/py-SoundFile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-02-13 20:03:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-02-13 20:03:04 +0000
commitb7d5f1cdc2f95e937c15c86d54325e8e606fdfe0 (patch)
treeaee9b2a780e00bfe30130f9af928435ad12397ea /audio/py-SoundFile
parent876a2a7a0cc322ad55d637aae560b80498df7d07 (diff)
downloadports-b7d5f1cdc2f95e937c15c86d54325e8e606fdfe0.tar.gz
ports-b7d5f1cdc2f95e937c15c86d54325e8e606fdfe0.zip
New port: audio/py-SoundFile: Audio library based on libsndfile, CFFI and NumPy
See https://github.com/bastibe/SoundFile Approved by: tcberner (mentor)
Notes
Notes: svn path=/head/; revision=461740
Diffstat (limited to 'audio/py-SoundFile')
-rw-r--r--audio/py-SoundFile/Makefile24
-rw-r--r--audio/py-SoundFile/distinfo3
-rw-r--r--audio/py-SoundFile/pkg-descr5
3 files changed, 32 insertions, 0 deletions
diff --git a/audio/py-SoundFile/Makefile b/audio/py-SoundFile/Makefile
new file mode 100644
index 000000000000..58a308a67da2
--- /dev/null
+++ b/audio/py-SoundFile/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= SoundFile
+DISTVERSION= 0.9.0
+DISTVERSIONSUFFIX= .post1
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Audio library based on libsndfile, CFFI and NumPy
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=0.6:devel/py-cffi@${FLAVOR} \
+ ${PYNUMPY} \
+ ${PREFIX}/lib/libsndfile.so:audio/libsndfile
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/audio/py-SoundFile/distinfo b/audio/py-SoundFile/distinfo
new file mode 100644
index 000000000000..3f802eb1e313
--- /dev/null
+++ b/audio/py-SoundFile/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518517499
+SHA256 (SoundFile-0.9.0.post1.tar.gz) = e01b53f6ba6dce389f388c819b43466b8708e85e9d832a8a3a1ff95af7c60731
+SIZE (SoundFile-0.9.0.post1.tar.gz) = 1817974
diff --git a/audio/py-SoundFile/pkg-descr b/audio/py-SoundFile/pkg-descr
new file mode 100644
index 000000000000..7e953cd168b1
--- /dev/null
+++ b/audio/py-SoundFile/pkg-descr
@@ -0,0 +1,5 @@
+PySoundFile can read and write sound files. File reading/writing is supported
+through libsndfile, which is a free, cross-platform, open-source (LGPL) library
+for reading and writing many different sampled sound file formats.
+
+WWW: https://github.com/bastibe/PySoundFile