aboutsummaryrefslogtreecommitdiff
path: root/audio/py-gtts
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-07-30 19:18:12 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-07-30 19:18:12 +0000
commitd02141c9eb5529b458de54f81ae5c7de1d64d1ce (patch)
tree8ea2e9b7557e205f6a9a648c00d0bd3c3700d6d2 /audio/py-gtts
parent8e49ad617a26f6d5b661e98b0b9d636a5e90f49c (diff)
downloadports-d02141c9eb5529b458de54f81ae5c7de1d64d1ce.tar.gz
ports-d02141c9eb5529b458de54f81ae5c7de1d64d1ce.zip
games/py-mnemosyne: Take Maintainer'ship, fix runtime error and add missing dependencies
Latest version of games/py-mnemosyne requires new dependencies. This commit adds the missing dependencies: - audio/py-gtts - security/py-gtts-token (required by audio/py-gtts) - textproc/py-googletrans The games/py-mnemosyne port needs to be limited to Python 3.7+ to keep the dependency chains intact. This is because textproc/py-googletrans depends on www/py-httpx which is only for Python 3.7+. PR: 247595 Submitted by: kai Reported by: gspurki@gmail.com Approved by: tcberner (mentor) MFH: 2020Q3 Differential Revision: https://reviews.freebsd.org/D25895
Notes
Notes: svn path=/head/; revision=543817
Diffstat (limited to 'audio/py-gtts')
-rw-r--r--audio/py-gtts/Makefile43
-rw-r--r--audio/py-gtts/distinfo3
-rw-r--r--audio/py-gtts/pkg-descr13
3 files changed, 59 insertions, 0 deletions
diff --git a/audio/py-gtts/Makefile b/audio/py-gtts/Makefile
new file mode 100644
index 000000000000..67e0661b7bea
--- /dev/null
+++ b/audio/py-gtts/Makefile
@@ -0,0 +1,43 @@
+# $FreeBSD$
+
+PORTNAME= gtts
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.1.1
+CATEGORIES= audio python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Library/CLI tool to interface with Google Translate text-to-speech API
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gtts-token>=1.1.3:security/py-gtts-token@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.9:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}testfixtures>0:devel/py-testfixtures@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= pndurette
+GH_PROJECT= gTTS
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3600
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}twine1>=1.11:devel/py-twine1@${PY_FLAVOR}
+.else
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}twine>=1.11:devel/py-twine@${PY_FLAVOR}
+.endif
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
+
+.include <bsd.port.post.mk>
diff --git a/audio/py-gtts/distinfo b/audio/py-gtts/distinfo
new file mode 100644
index 000000000000..d5015035d30f
--- /dev/null
+++ b/audio/py-gtts/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1594610064
+SHA256 (pndurette-gTTS-v2.1.1_GH0.tar.gz) = 7ba54c933aadf83811d397947a2702360188a03b3571b3caff0d618aa34c0d7c
+SIZE (pndurette-gTTS-v2.1.1_GH0.tar.gz) = 33476
diff --git a/audio/py-gtts/pkg-descr b/audio/py-gtts/pkg-descr
new file mode 100644
index 000000000000..ff462aaa8577
--- /dev/null
+++ b/audio/py-gtts/pkg-descr
@@ -0,0 +1,13 @@
+gTTS (Google Text-to-Speech), a Python library and CLI tool to interface with
+Google Translate's text-to-speech API. Write spoken mp3 data to a file, a
+file-like object (bytestring) for further audio manipulation, or stdout.
+
+Or simply pre-generate Google Translate TTS request URLs to feed to an external
+program.
+
+Customizable speech-specific sentence tokenizer that allows for unlimited
+lengths of text to be read, all while keeping proper intonation, abbreviations,
+decimals and more; Customizable text pre-processors which can, for example,
+provide pronunciation corrections; Automatic retrieval of supported languages.
+
+WWW: https://github.com/pndurette/gTTS