aboutsummaryrefslogtreecommitdiff
path: root/audio/py-pyaudio
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-04-05 18:04:38 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-04-05 18:04:38 +0000
commit8b7b50355c5924b732dbc6adef8b5726e3bcd7cc (patch)
tree23954aa1f1fd0752fe3570eaaff1d5a643ce8f29 /audio/py-pyaudio
parent8548ef54c1c60d130130ac4fddb01ddcb4b96f67 (diff)
downloadports-8b7b50355c5924b732dbc6adef8b5726e3bcd7cc.tar.gz
ports-8b7b50355c5924b732dbc6adef8b5726e3bcd7cc.zip
audio/py-pyaudio: 0.2.8 -> 0.2.9
- Fix overflow error handling logic for pa_read_stream. Stream.read takes an additional parameter that specifies whether an exception is raised on audio buffer overflow, for parity with Stream.write. Includes relevant bug fixes in the C module logic. Thanks to Tony Jacobson for submitting a patch! - Fix IOError arguments. IOError exceptions previously had values in the strerror and errno fields swapped, which is now corrected. Thanks to Sami Liedes for the report! - Miscellaneous updates. Python library surfaces issues with importing low-level C module. Code formatting update. Updates to examples for Python 3 compatibility. PR: 208517 Submitted by: jaap@NLnetLabs.nl (maintainer)
Notes
Notes: svn path=/head/; revision=412579
Diffstat (limited to 'audio/py-pyaudio')
-rw-r--r--audio/py-pyaudio/Makefile6
-rw-r--r--audio/py-pyaudio/distinfo4
-rw-r--r--audio/py-pyaudio/files/patch-setup.py12
3 files changed, 11 insertions, 11 deletions
diff --git a/audio/py-pyaudio/Makefile b/audio/py-pyaudio/Makefile
index bcc8ed851f9f..b9162ac8bdbb 100644
--- a/audio/py-pyaudio/Makefile
+++ b/audio/py-pyaudio/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= pyaudio
-PORTVERSION= 0.2.8
-PORTREVISION= 1
+PORTVERSION= 0.2.9
CATEGORIES= audio python
-MASTER_SITES= http://people.csail.mit.edu/hubert/pyaudio/packages/
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyAudio-${PORTVERSION}
MAINTAINER= jaap@NLnetLabs.nl
COMMENT= Portaudio toolkit bindings for Python
diff --git a/audio/py-pyaudio/distinfo b/audio/py-pyaudio/distinfo
index 33bb06e41723..e47e6942ac8d 100644
--- a/audio/py-pyaudio/distinfo
+++ b/audio/py-pyaudio/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pyaudio-0.2.8.tar.gz) = 4f85367cf79657616684487037957ac38582ecc5389b89420fe61d901b719551
-SIZE (pyaudio-0.2.8.tar.gz) = 235900
+SHA256 (PyAudio-0.2.9.tar.gz) = bfd694272b3d1efc51726d0c27650b3c3ba1345f7f8fdada7e86c9751ce0f2a1
+SIZE (PyAudio-0.2.9.tar.gz) = 289499
diff --git a/audio/py-pyaudio/files/patch-setup.py b/audio/py-pyaudio/files/patch-setup.py
index 016b127e8160..4feed50c13bd 100644
--- a/audio/py-pyaudio/files/patch-setup.py
+++ b/audio/py-pyaudio/files/patch-setup.py
@@ -1,8 +1,8 @@
---- ./setup.py.orig 2012-11-07 00:17:06.624869638 +0100
-+++ ./setup.py 2012-11-07 00:37:17.129040078 +0100
-@@ -74,6 +74,12 @@ else:
- external_libraries = ['portaudio']
- extra_link_args = []
+--- setup.py.orig 2016-04-04 21:15:34 UTC
++++ setup.py
+@@ -63,6 +63,12 @@ extra_link_args = []
+ scripts = []
+ defines = []
+if sys.platform.startswith('dragonfly') or \
+ sys.platform.startswith('freebsd'):
@@ -12,4 +12,4 @@
+
if sys.platform == 'darwin':
defines += [('MACOSX', '1')]
-
+ if mac_sysroot_path: