aboutsummaryrefslogtreecommitdiff
path: root/audio/py-python-mpd2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-25 18:16:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-25 18:16:18 +0000
commit77ca6d59fbc2861212a2ac170f5b83ed5a472f34 (patch)
tree68743b1df9465dfd026ef1b3a9395ba5e55df8b4 /audio/py-python-mpd2
parent2da89afef8a188a8c524302f4ae79a75417db0ce (diff)
downloadports-77ca6d59fbc2861212a2ac170f5b83ed5a472f34.tar.gz
ports-77ca6d59fbc2861212a2ac170f5b83ed5a472f34.zip
Move audio/py-mpd2 to audio/py-python-mpd2
- Remove no-op DOCSDIR and EXAMPLESDIR: they are overwritten by USE_PYTHON=concurrent - Take maintainership
Notes
Notes: svn path=/head/; revision=524053
Diffstat (limited to 'audio/py-python-mpd2')
-rw-r--r--audio/py-python-mpd2/Makefile38
-rw-r--r--audio/py-python-mpd2/distinfo3
-rw-r--r--audio/py-python-mpd2/pkg-descr4
-rw-r--r--audio/py-python-mpd2/pkg-plist21
4 files changed, 66 insertions, 0 deletions
diff --git a/audio/py-python-mpd2/Makefile b/audio/py-python-mpd2/Makefile
new file mode 100644
index 000000000000..48dfa8c376a6
--- /dev/null
+++ b/audio/py-python-mpd2/Makefile
@@ -0,0 +1,38 @@
+# Created by: rene@FreeBSD.org (repocopied from audio/py-mpd)
+# $FreeBSD$
+
+PORTNAME= python-mpd2
+PORTVERSION= 1.1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= audio python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python MPD client library
+
+LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python shebangfix
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= Mic92
+
+SHEBANG_FILES= doc/*.py examples/*.py
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/topics
+ ${INSTALL_DATA} ${WRKSRC}/doc/commands_header.txt ${WRKSRC}/doc/*.rst ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/doc/topics/*.rst ${STAGEDIR}${DOCSDIR}/topics/
+ ${INSTALL_SCRIPT} ${WRKSRC}/doc/generate_command_reference.py ${STAGEDIR}${DOCSDIR}/
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/*.py ${WRKSRC}/examples/summary.txt ${STAGEDIR}${EXAMPLESDIR}/
+
+.include <bsd.port.mk>
diff --git a/audio/py-python-mpd2/distinfo b/audio/py-python-mpd2/distinfo
new file mode 100644
index 000000000000..f887843fb993
--- /dev/null
+++ b/audio/py-python-mpd2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579953627
+SHA256 (Mic92-python-mpd2-v1.1.0_GH0.tar.gz) = 2402b4a264bfc96fe743e7e8ee0128d896fc76a7847ae38d467fa58c03833d5f
+SIZE (Mic92-python-mpd2-v1.1.0_GH0.tar.gz) = 61104
diff --git a/audio/py-python-mpd2/pkg-descr b/audio/py-python-mpd2/pkg-descr
new file mode 100644
index 000000000000..57a44a296c27
--- /dev/null
+++ b/audio/py-python-mpd2/pkg-descr
@@ -0,0 +1,4 @@
+python-mpd2 is a Python library which provides a client interface for the Music
+Player Daemon.
+
+WWW: https://github.com/Mic92/python-mpd2
diff --git a/audio/py-python-mpd2/pkg-plist b/audio/py-python-mpd2/pkg-plist
new file mode 100644
index 000000000000..7b33905d89e6
--- /dev/null
+++ b/audio/py-python-mpd2/pkg-plist
@@ -0,0 +1,21 @@
+%%PORTDOCS%%%%DOCSDIR%%/changes.rst
+%%PORTDOCS%%%%DOCSDIR%%/commands_header.txt
+%%PORTDOCS%%%%DOCSDIR%%/generate_command_reference.py
+%%PORTDOCS%%%%DOCSDIR%%/index.rst
+%%PORTDOCS%%%%DOCSDIR%%/topics/advanced.rst
+%%PORTDOCS%%%%DOCSDIR%%/topics/commands.rst
+%%PORTDOCS%%%%DOCSDIR%%/topics/getting-started.rst
+%%PORTDOCS%%%%DOCSDIR%%/topics/logging.rst
+%%PORTDOCS%%%%DOCSDIR%%/topics/porting.rst
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/asyncio_example.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorhandling.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/helloworld.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/idle.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/locking.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logger.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/multitags.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/randomqueue.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stats.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stickers.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/summary.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/twisted_example.py