aboutsummaryrefslogtreecommitdiff
path: root/audio/py-tagpy
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-08-29 19:15:52 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-08-29 19:15:52 +0000
commitaa80ecdafcc2026c87ba35089625813145a86108 (patch)
tree0e2aec0c74071525aef1e906cdea0a04d82a125b /audio/py-tagpy
parent875814f1a547db9bf30dc06f2720420b0e84efcd (diff)
downloadports-aa80ecdafcc2026c87ba35089625813145a86108.tar.gz
ports-aa80ecdafcc2026c87ba35089625813145a86108.zip
Does not depend on GCC hardly but needs a modern compiler
Notes
Notes: svn path=/head/; revision=366552
Diffstat (limited to 'audio/py-tagpy')
-rw-r--r--audio/py-tagpy/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/audio/py-tagpy/Makefile b/audio/py-tagpy/Makefile
index d1fcdd9f78ef..5d62e5957ff4 100644
--- a/audio/py-tagpy/Makefile
+++ b/audio/py-tagpy/Makefile
@@ -16,7 +16,7 @@ LICENSE= MIT
LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
libtag.so:${PORTSDIR}/audio/taglib
-USES= shebangfix
+USES= shebangfix compiler:c++11-lang
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.py
CONFIGURE_ARGS= --taglib-inc-dir="${LOCALBASE}/include/taglib" \
@@ -28,9 +28,7 @@ python_OLD_CMD= /usr/bin/env python
python_CMD= ${PYTHON_CMD}
SHEBANG_FILES= configure.py
-USE_GCC= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>