aboutsummaryrefslogtreecommitdiff
path: root/audio/raul
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-12 06:45:59 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-12 06:45:59 +0000
commit9fad05b0059d6f23e7bfe5614d98c39e000add65 (patch)
treedc7003267ddf2df22ff5a1e3c69e18433bf633d0 /audio/raul
parent532f3da2672ee1d0258a756f86d7a59c1ad367d9 (diff)
downloadports-9fad05b0059d6f23e7bfe5614d98c39e000add65.tar.gz
ports-9fad05b0059d6f23e7bfe5614d98c39e000add65.zip
Notes
Diffstat (limited to 'audio/raul')
-rw-r--r--audio/raul/Makefile45
-rw-r--r--audio/raul/distinfo4
-rw-r--r--audio/raul/files/patch-raul-AtomicInt.hpp65
-rw-r--r--audio/raul/files/patch-raul-AtomicPtr.hpp28
-rw-r--r--audio/raul/pkg-descr2
-rw-r--r--audio/raul/pkg-plist31
6 files changed, 50 insertions, 125 deletions
diff --git a/audio/raul/Makefile b/audio/raul/Makefile
index bb58ed7222b4..b386b0c45837 100644
--- a/audio/raul/Makefile
+++ b/audio/raul/Makefile
@@ -6,31 +6,48 @@
#
PORTNAME= raul
-PORTVERSION= 0.5.1
-PORTREVISION= 3
+PORTVERSION= 0.8.0
CATEGORIES= audio
MASTER_SITES= http://download.drobilla.net/
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ utility library primarily aimed at audio/musical applications
-LIB_DEPENDS= boost_date_time.4:${PORTSDIR}/devel/boost-libs \
- jack.0:${PORTSDIR}/audio/jack \
- lash.2:${PORTSDIR}/audio/lash \
- glibmm-2.4.1:${PORTSDIR}/devel/glibmm
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GNOME= gnomehack
+LIB_DEPENDS= boost_date_time.4:${PORTSDIR}/devel/boost-libs
+
+USE_BZIP2= yes
+USE_GNOME= glib20
+USE_PYTHON_BUILD=yes
USE_LDCONFIG= yes
-CXXFLAGS+= ${CFLAGS}
-CONFIGURE_ENV= "-I${LOCALBASE}/include"
-CONFIGURE_ENV= "CXXFLAGS=${CFLAGS} -I${LOCALBASE}/include"
+
+CFLAGS+= -I${LOCALBASE}/include
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-BROKEN= Does not compile
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+WAF_VERBOSE= --verbose
+.endif
+
+.if defined(MAKE_JOBS_NUMBER)
+WAF_JOBS= --jobs=${MAKE_JOBS_NUMBER}
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ "s|$$[{]LIBDIRNAME[}]/pkgconfig|libdata/pkgconfig| ; \
+ s|-fshow-column'|-fshow-column ${CXXFLAGS}'|" \
+ ${WRKSRC}/autowaf/autowaf.py
+
+do-configure:
+ @(cd ${WRKSRC} && ./waf ${WAF_VERBOSE} --prefix=${PREFIX} configure)
+
+do-build:
+ @(cd ${WRKSRC} && ./waf ${WAF_VERBOSE} ${WAF_JOBS} build)
+
+do-install:
+ @(cd ${WRKSRC} && ./waf ${WAF_VERBOSE} install)
+
.include <bsd.port.post.mk>
diff --git a/audio/raul/distinfo b/audio/raul/distinfo
index b90464271481..7c000a482c56 100644
--- a/audio/raul/distinfo
+++ b/audio/raul/distinfo
@@ -1,2 +1,2 @@
-SHA256 (raul-0.5.1.tar.gz) = e82c3b8f95c13fedc83430f6b70e588304fe9bf04eb4b17758be914bbd0f79a0
-SIZE (raul-0.5.1.tar.gz) = 391193
+SHA256 (raul-0.8.0.tar.bz2) = 0b35cd7bb6fb0b1ca0340be07678a2561888572c96cf4e4da4d8f4c03a20ba26
+SIZE (raul-0.8.0.tar.bz2) = 155450
diff --git a/audio/raul/files/patch-raul-AtomicInt.hpp b/audio/raul/files/patch-raul-AtomicInt.hpp
deleted file mode 100644
index 3af6024517a8..000000000000
--- a/audio/raul/files/patch-raul-AtomicInt.hpp
+++ /dev/null
@@ -1,65 +0,0 @@
---- raul/AtomicInt.hpp.orig 2008-11-16 16:23:19.000000000 +0100
-+++ raul/AtomicInt.hpp 2008-11-16 16:32:45.000000000 +0100
-@@ -27,22 +27,22 @@
- public:
-
- inline AtomicInt(int val)
-- { g_atomic_int_set(&_val, val); }
-+ { g_atomic_int_set((volatile gint *)&_val, (gint)val); }
-
- inline AtomicInt(const AtomicInt& copy)
-- { g_atomic_int_set(&_val, copy.get()); }
-+ { g_atomic_int_set((volatile gint *)&_val, (gint)copy.get()); }
-
- inline int get() const
-- { return g_atomic_int_get(&_val); }
-+ { return g_atomic_int_get((volatile gint *)&_val); }
-
- inline void operator=(int val)
-- { g_atomic_int_set(&_val, val); }
-+ { g_atomic_int_set((volatile gint *)&_val, (gint)val); }
-
- inline void operator+=(int val)
-- { g_atomic_int_add(&_val, val); }
-+ { g_atomic_int_add((volatile gint *)&_val, (gint)val); }
-
- inline void operator-=(int val)
-- { g_atomic_int_add(&_val, -val); }
-+ { g_atomic_int_add((volatile gint *)&_val, (gint)-val); }
-
- inline bool operator==(int val) const
- { return get() == val; }
-@@ -51,28 +51,28 @@
- { return get() + val; }
-
- inline AtomicInt& operator++() // prefix
-- { g_atomic_int_inc(&_val); return *this; }
-+ { g_atomic_int_inc((volatile gint *)&_val); return *this; }
-
- inline AtomicInt& operator--() // prefix
-- { g_atomic_int_add(&_val, -1); return *this; }
-+ { g_atomic_int_add((volatile gint *)&_val, -1); return *this; }
-
- /** Set value to newval iff current value is oldval.
- * @return whether set succeeded.
- */
- inline bool compare_and_exchange(int oldval, int newval)
-- { return g_atomic_int_compare_and_exchange(&_val, oldval, newval); }
-+ { return g_atomic_int_compare_and_exchange((volatile gint *)&_val, (gint)oldval, (gint)newval); }
-
- /** Add val to value.
- * @return value immediately before addition took place.
- */
- inline int exchange_and_add(int val)
-- { return g_atomic_int_exchange_and_add(&_val, val); }
-+ { return g_atomic_int_exchange_and_add((volatile gint *)&_val, (gint)val); }
-
- /** Decrement value.
- * @return true if value is now 0, otherwise false.
- */
- inline bool decrement_and_test()
-- { return g_atomic_int_dec_and_test(&_val); }
-+ { return g_atomic_int_dec_and_test((gint *)&_val); }
-
- private:
- volatile int _val;
diff --git a/audio/raul/files/patch-raul-AtomicPtr.hpp b/audio/raul/files/patch-raul-AtomicPtr.hpp
deleted file mode 100644
index f8a33b63819f..000000000000
--- a/audio/raul/files/patch-raul-AtomicPtr.hpp
+++ /dev/null
@@ -1,28 +0,0 @@
---- raul/AtomicPtr.hpp.orig 2008-11-16 16:20:09.000000000 +0100
-+++ raul/AtomicPtr.hpp 2008-11-16 16:23:06.000000000 +0100
-@@ -28,20 +28,20 @@
- public:
-
- inline AtomicPtr()
-- { g_atomic_pointer_set(&_val, NULL); }
-+ { g_atomic_pointer_set((volatile gpointer *)&_val, NULL); }
-
- inline AtomicPtr(const AtomicPtr& copy)
-- { g_atomic_pointer_set(&_val, copy.get()); }
-+ { g_atomic_pointer_set((volatile gpointer *)&_val, (gpointer)copy.get()); }
-
- inline T* get() const
-- { return (T*)g_atomic_pointer_get(&_val); }
-+ { return (T*)g_atomic_pointer_get((volatile gpointer *)&_val); }
-
- inline void operator=(T* val)
-- { g_atomic_pointer_set(&_val, val); }
-+ { g_atomic_pointer_set((volatile gpointer *)&_val, (gpointer)val); }
-
- /** Set value to newval iff current value is oldval */
- inline bool compare_and_exchange(int oldval, int newval)
-- { return g_atomic_pointer_compare_and_exchange(&_val, oldval, newval); }
-+ { return g_atomic_pointer_compare_and_exchange((volatile gpointer *)&_val, oldval, newval); }
-
- private:
- volatile T* _val;
diff --git a/audio/raul/pkg-descr b/audio/raul/pkg-descr
index 7e8650873dcb..d1e17036d8a8 100644
--- a/audio/raul/pkg-descr
+++ b/audio/raul/pkg-descr
@@ -3,4 +3,4 @@ primarily aimed at audio/musical applications.
It is used by Ingen, Patchage, and Machina.
-WWW: http://wiki.drobilla.net/Raul
+WWW: http://drobilla.net/software/raul/
diff --git a/audio/raul/pkg-plist b/audio/raul/pkg-plist
index 3cb761909dd6..0078be6879bd 100644
--- a/audio/raul/pkg-plist
+++ b/audio/raul/pkg-plist
@@ -1,43 +1,44 @@
include/raul/Array.hpp
+include/raul/ArrayStack.hpp
include/raul/Atom.hpp
-include/raul/AtomicInt.hpp
-include/raul/AtomicPtr.hpp
include/raul/AtomLiblo.hpp
include/raul/AtomRDF.hpp
-include/raul/Command.hpp
+include/raul/AtomicInt.hpp
+include/raul/AtomicPtr.hpp
+include/raul/Configuration.hpp
include/raul/Deletable.hpp
include/raul/DoubleBuffer.hpp
include/raul/EventRingBuffer.hpp
-include/raul/JackDriver.hpp
+include/raul/IntrusivePtr.hpp
include/raul/List.hpp
include/raul/ListImpl.hpp
-include/raul/lv2_event.h
-include/raul/Maid.hpp
-include/raul/midi_events.h
-include/raul/midi_names.h
include/raul/MIDISink.hpp
+include/raul/Maid.hpp
include/raul/Path.hpp
include/raul/PathTable.hpp
include/raul/Process.hpp
include/raul/Quantizer.hpp
include/raul/RingBuffer.hpp
-include/raul/Semaphore.hpp
-include/raul/SharedPtr.hpp
-include/raul/Slave.hpp
include/raul/SMFReader.hpp
include/raul/SMFWriter.hpp
include/raul/SRMWQueue.hpp
include/raul/SRSWQueue.hpp
-include/raul/Stateful.hpp
+include/raul/Semaphore.hpp
+include/raul/SharedPtr.hpp
+include/raul/Slave.hpp
include/raul/Symbol.hpp
include/raul/Table.hpp
include/raul/TableImpl.hpp
include/raul/Thread.hpp
include/raul/TimeSlice.hpp
include/raul/TimeStamp.hpp
+include/raul/URI.hpp
include/raul/WeakPtr.hpp
-@dirrm include/raul
-lib/libraul.so.2
+include/raul/log.hpp
+include/raul/midi_events.h
+include/raul/midi_names.h
lib/libraul.so
-lib/libraul.la
+lib/libraul.so.10
+lib/libraul.so.10.0.0
libdata/pkgconfig/raul.pc
+@dirrm include/raul