aboutsummaryrefslogtreecommitdiff
path: root/audio/rawrec
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-08 10:22:14 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-08 10:22:14 +0000
commit31154892b641cd15adf68371929358d08862d264 (patch)
tree04c60b5eee34ac32bb4e64c7f467d3bf71838892 /audio/rawrec
parent9b646e86c33d57c3d495a4a0218969df75dcbd63 (diff)
downloadports-31154892b641cd15adf68371929358d08862d264.tar.gz
ports-31154892b641cd15adf68371929358d08862d264.zip
PERL -> REINPLACE_CMD
PR: 39283 Submitted by: Oliver Braun <obraun@informatik.unibw-muenchen.de>
Notes
Notes: svn path=/head/; revision=62644
Diffstat (limited to 'audio/rawrec')
-rw-r--r--audio/rawrec/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/audio/rawrec/Makefile b/audio/rawrec/Makefile
index 5875d3a872ed..2c2da8cdf6e7 100644
--- a/audio/rawrec/Makefile
+++ b/audio/rawrec/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
WRKSRC= ${WRKDIR}/${DISTNAME}/src
+USE_REINPLACE= yes
USE_GMAKE= yes
MAKE_ARGS= CC="${CC}" \
CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
@@ -30,7 +31,7 @@ MAN1= rawrec.1
MLINKS= rawrec.1 rawplay.1
post-patch:
- @${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
's|<linux/soundcard.h>|<sys/soundcard.h>|g'
do-install: